Loading ...
Sorry, an error occurred while loading the content.

vi compatibility (was Re: VimRegEx.vim beta)

Expand Messages
  • Antony Scriven
    ... I don t think that s true at all. I bet there are even some vim users who think they are using vi. ... See ... `:set nocp in the system-wide vimrc if you
    Message 1 of 1 , Sep 30, 2004
    • 0 Attachment
      Dave Silvia wrote:

      > Now this to me makes sense. Vim is far enough removed from
      > vi, I think, that if someone is using Vim, it's because
      > they want to use Vim (not vi).

      I don't think that's true at all. I bet there are even some
      vim users who think they are using vi.

      > So the default of nocompatible makes more sense. Let the
      > die hard vi users force compatibility instead.

      See
      :help 'compatible'
      :help design-compatible
      :help design-flexible

      `:set nocp' in the system-wide vimrc if you want all users
      on your system to default to compatible. However this may
      unnecessarily confuse and annoy users with an .exrc.

      Antony
    Your message has been successfully submitted and would be delivered to recipients shortly.