Loading ...
Sorry, an error occurred while loading the content.

Re: Unable to set font-attribute

Expand Messages
  • Klaus Bosau
    ... Benji, thanks for your response! I recently upgraded to 6.3 and the problem disappeared, so I assume it has been fixed in the meantime. (What version did
    Message 1 of 3 , Jun 9, 2004
    • 0 Attachment
      On Tue, 8 Jun 2004, Benji Fisher wrote:
      > On Sun, May 30, 2004 at 06:26:29PM +0200, Klaus Bosau wrote:
      >
      >> [Vim shows font mixture]
      >
      > I do not see this. I tried adding
      >
      > set gfn=Courier\ 12
      > au BufNewFile,BufRead *.vim set gfn=Courier\ 10
      >
      > to my gvimrc file, and did not see anything wrong. The fonts did
      > change depending on what file I edited, so I seem to have the right
      > font descriptions for my system (GTK2, I think).

      Benji,

      thanks for your response! I recently upgraded to 6.3 and the problem
      disappeared, so I assume it has been fixed in the meantime. (What
      version did you use for testing?) - I found highlighting for vim-scripts
      is faster now (and also incorrect).

      > Does it matter whether the "set gfn" is inside a function,

      No.

      > or vimrc file instead of gvimrc?

      Maybe. I don't use separate config. files, just vimrc (for both Vim and
      GVim). I seem to be able to reproduce it.

      > Note that your autocommand does not trigger when editing your vimrc
      > or gvimrc file. For this and other reasons, I suggest making your own
      > after/ftplugin/vim.vim file and putting the s:Init_vim() function in
      > there. No need for the autocommand, then.
      >
      > :help ftplugin-overrule

      Thanks! I'll have a look..

      Klaus
    Your message has been successfully submitted and would be delivered to recipients shortly.