Loading ...
Sorry, an error occurred while loading the content.
 

Re: Installation help for GUI vim on linux.

Expand Messages
  • Antoine J. Mechelynck
    1) I m not the ultimate vim guru. Please send your queries not just to me alone, but also to the mailing list. 2) From what you list below, the only thing I
    Message 1 of 5 , Jun 1 3:42 AM
      1) I'm not the ultimate vim guru. Please send your queries not just to me
      alone, but also to the mailing list.

      2) From what you list below, the only thing I can imagine is blocking you is
      a spurious alias for gvim in your shell. Try

      alias

      to see if this is the case, and, OTOH, see if the GUI starts when you type

      /usr/X11R6/bin/gvim

      (i.e., with a full path) at the shell prompt.


      Regards,
      Tony.

      ----- Original Message -----
      From: "rohit tripathi" <rohittri@...>
      To: "Antoine J. Mechelynck" <antoine.mechelynck@...>
      Sent: Tuesday, June 01, 2004 2:16 AM
      Subject: Re: Installation help for GUI vim on linux.


      > Hello,
      >
      > Some time back i posted a question for GUI based vim
      > support for linux. Thanks for your reply on that.
      > But still i am not able to get my gvim working.
      >
      > Here are the logs for the commands u had suggested.
      > ===================================================
      > [root@Andy root]# rpm -qa |grep vim
      > vim-minimal-6.1-29
      > vim-common-6.1-29
      > vim-enhanced-6.1-29
      > vim-X11-6.2-291
      > [root@Andy root]# which gvim
      > /usr/X11R6/bin/gvim
      > [root@Andy root]# gvim
      > E25: GUI cannot be used: Not enabled at compile time
      > [root@Andy root]# vim -g
      > E25: GUI cannot be used: Not enabled at compile time
      > [root@Andy root]#
      > ====================================================
      >
      > As you see i have tried out everything but still
      > i don't get the gui based vim.
      >
      > I would really appreciate any help from you on this.
      >
      > Thanks and best regards,
      > Rohit.
      >
      > ----- Original Message -----
      > From: "Antoine J. Mechelynck" <antoine.mechelynck@...>
      > Date: Sunday, April 4, 2004 12:52 pm
      > Subject: Re: Installation help for GUI vim on linux.
      >
      > > 8rohit tripathi <rohittri@...> wrote:
      > > > Hello All,
      > > >
      > > > I am new to this mailing list and appreciate the time
      > > > and effort put by you all in maintaing this list.
      > > >
      > > > We have Redhat linux 9 on our server and i find that by
      > > > defualt the GUI based vim is not supported. It says :
      > > > =============================================
      > > > [root@eeb205-7 root]# vim -g
      > > > E25: GUI cannot be used: Not enabled at compile time
      > > > [root@eeb205-7 root]#
      > > > =============================================
      > > >
      > > > I tried to reinstall vim using both, the vim installable
      > > > vim-6.2.tar.gz from the vim.org homepage as well as the RPM
      > > > vim-6.1-29.src.rpm. But still i get the same message. I believe
      > > > by default the GUI is enabled in all these packages and i
      > > > don't have to make any explicit changes in Makefile.
      > > >
      > > > Please let me know if i am doing something wrong or i need
      > > > to install some other packages before going ahead with VIM
      > > > installation.
      > > >
      > > > Thanks and best regards,
      > > > Rohit.
      > >
      > > The RedHat distribution uncludes 4 packages. To see which of them are
      > > installed you may do (IIRC)
      > >
      > > rpm -qa | grep vim
      > >
      > > from the shell. The package names are as follows (I show only the
      > > distinctive names, there will be version numbers, subversions,
      architecture
      > > names, etc. after the name itself):
      > >
      > > vim-common
      > > the runtime files, which must always be installed.
      > >
      > > vim-minimal
      > > a "minimum" version of the vim executable, intalled under the name
      "vi"
      > > on a filesystem which is always mounted, even in a "single" or "rescue"
      > > boot, so it is always available.
      > >
      > > vim-enhanced
      > > a full-featured "console" executable, intalled under the name "vim".
      It
      > > has almost everything compiled-in, except the GUI capabilities.
      > >
      > > vim-x11
      > > a full-featured GUI executable, installed under the name "gvim".
      > >
      > > The vim-minimal package, and one or more of the executables, must be
      > > intalled for vim to function. It is quite possible to install all three
      > > executables. The installation should take care of placing the
      executable(s)
      > > in your $PATH.
      > >
      > > To use the gui, you must have vim-common and vim-x11 installed. If you
      have
      > > vim-enhanced but not vim-x11, find the vim-x11*.rpm file and install it
      with
      > >
      > > rpm -Uvh vim-x11*.rpm
      > >
      > > If you _have_ the vim-x11 package installed, invoke it with the
      program-name
      > > "gvim".
      > >
      > > HTH,
      > > Tony.
      > >
      > >
      > >
      >
      >
    • Benji Fisher
      Some other things to try: 1. # vim --version # gvim --version # /usr/X11R6/bin/gvim --version The version information might be interesting. 2. Install
      Message 2 of 5 , Jun 8 1:49 PM
        Some other things to try:

        1.
        # vim --version
        # gvim --version
        # /usr/X11R6/bin/gvim --version

        The version information might be interesting.

        2. Install compatible versions of the vim RPM's. I notice that three
        of your RPM's are vim 6.1 and that the third is vim 6.2. I do not know
        whether this causes problems. For recent RPM's, try searching for "RPM"
        on http://vim.sourceforge.net/download.php .

        3. Forget about RPM's. I leave the version installed by Red Hat alone
        in /usr/bin/ and do "make; sudo make install" to put a current version
        in /usr/local/bin/ , which is first in my PATH.

        HTH --Benji Fisher

        On Tue, Jun 01, 2004 at 12:42:48PM +0200, Antoine J. Mechelynck wrote:
        > 1) I'm not the ultimate vim guru. Please send your queries not just to me
        > alone, but also to the mailing list.
        >
        > 2) From what you list below, the only thing I can imagine is blocking you is
        > a spurious alias for gvim in your shell. Try
        >
        > alias
        >
        > to see if this is the case, and, OTOH, see if the GUI starts when you type
        >
        > /usr/X11R6/bin/gvim
        >
        > (i.e., with a full path) at the shell prompt.
        >
        >
        > Regards,
        > Tony.
        >
        > ----- Original Message -----
        > From: "rohit tripathi" <rohittri@...>
        > To: "Antoine J. Mechelynck" <antoine.mechelynck@...>
        > Sent: Tuesday, June 01, 2004 2:16 AM
        > Subject: Re: Installation help for GUI vim on linux.
        >
        >
        > > Hello,
        > >
        > > Some time back i posted a question for GUI based vim
        > > support for linux. Thanks for your reply on that.
        > > But still i am not able to get my gvim working.
        > >
        > > Here are the logs for the commands u had suggested.
        > > ===================================================
        > > [root@Andy root]# rpm -qa |grep vim
        > > vim-minimal-6.1-29
        > > vim-common-6.1-29
        > > vim-enhanced-6.1-29
        > > vim-X11-6.2-291
        > > [root@Andy root]# which gvim
        > > /usr/X11R6/bin/gvim
        > > [root@Andy root]# gvim
        > > E25: GUI cannot be used: Not enabled at compile time
        > > [root@Andy root]# vim -g
        > > E25: GUI cannot be used: Not enabled at compile time
        > > [root@Andy root]#
        > > ====================================================
        > >
        > > As you see i have tried out everything but still
        > > i don't get the gui based vim.
        > >
        > > I would really appreciate any help from you on this.
        > >
        > > Thanks and best regards,
        > > Rohit.
        [snip]
      Your message has been successfully submitted and would be delivered to recipients shortly.