Loading ...
Sorry, an error occurred while loading the content.

vim compiling best practices & help with vimirc

Expand Messages
  • Eric Winger
    Being my usual tangental self, I found the VimIRC plugin on my way to making vim my email editor and immediately had to dive in. In trying to make the VimIRC
    Message 1 of 11 , Apr 1, 2004
    • 0 Attachment
      Being my usual tangental self, I found the VimIRC plugin on my way to
      making vim my email editor and immediately had to dive in. In trying to
      make the VimIRC plugin work, I ventured into the realm of compiling my
      own vim so I could turn on the perl interface. However, I've run into
      several problems. Hoping someone can guide me.

      1.When compiling vim, after having used the vim binaries precompiled for
      sometime, I'm confused as to where my defaults are now. Here's what I did.

      *downloaded linux source into ~/vimsource.
      *bunzip'd & untar'd creating vim62 dir with lots of goodies.
      *cd'd down to vim62/src
      *uncommented the Makefile perl options
      *make install, worked.

      i had put the vimirc.vim file in ~/.vim/plugin and when I directly start
      vim from that directory - it still gives the "must install perl
      warnings". Idease on why this does this? This may be in part because of
      the way i've installed vim. So my next questions may solve the problem.

      2. I'm also getting this error when starting 6.2.

      Error detected while processing /home/ewinger/.vimrc:
      line 1:
      E484: Can't open file /usr/local/share/vim/syntax/syntax.vim

      For the life of me I can't figure out why its looking in there. I
      attached my .vimrc at the bottom.


      3. having now two working versions of vim on my system, what are the
      best practices for compiling one's own vim on linux? as far as where to
      put the source, compile options, etc.

      4. How does vim determine which .vimrc files it uses? How can I be sure
      that the vim I'm running is using the correct files, etc?

      any help is appreciated,

      Eric





      contents of .vimrc

      :s on :set incsearch
      :set laststatus=2
      :set wildmode=longest,list
      :set wildmenu
      " Wed 01 Jan 2003
      :ab mdyl <c-r>=strftime("%a %d %b %Y")<cr>
      :" 01/01/2003 07:55:50
      :ab mdyc <c-r>=strftime("%c")<cr>
      :" 01/01/03 19:56:01
      :ab hml <c-r>=strftime("%d/%m/%y %H:%M:%S")<cr>
      :" 19:56:06
      :ab hms <c-r>=strftime("%H:%M:%S")<cr>
      :imap <Insert> <C-N>

      :set printoptions=paper:letter
      nmap <silent> gw "_yiw:s/\(\%#\w\+\)\(\W\+\)\(\w\+\)/\3\2\1/<cr><c-o><c-l>

      -----------------------------------------
      This email message is intended only for the addressee(s) and contains information that may be confidential to and/or copyrighted by Key Technology. If you are not the intended recipient, please notify the sender by reply email and immediately delete this email. Use, disclosure or reproduction of this email by anyone other than the intended recipient(s) is strictly prohibited. Any views expressed in the email are those of the individual sender unless the sender expressly states them to be the views of Key Technology. No representation is made that this email or any attachments are free of viruses. Virus scanning is recommended and is the responsibility of the recipient.
    • Gary Johnson
      ... Did you run ./configure? It appears that you didn t. This is an important step if you re going to build vim with a non-standard option or install it in a
      Message 2 of 11 , Apr 1, 2004
      • 0 Attachment
        On 2004-04-01, Eric Winger <ewinger@...> wrote:
        > Being my usual tangental self, I found the VimIRC plugin on my way to
        > making vim my email editor and immediately had to dive in. In trying to
        > make the VimIRC plugin work, I ventured into the realm of compiling my
        > own vim so I could turn on the perl interface. However, I've run into
        > several problems. Hoping someone can guide me.
        >
        > 1.When compiling vim, after having used the vim binaries precompiled for
        > sometime, I'm confused as to where my defaults are now. Here's what I did.
        >
        > *downloaded linux source into ~/vimsource.
        > *bunzip'd & untar'd creating vim62 dir with lots of goodies.
        > *cd'd down to vim62/src
        > *uncommented the Makefile perl options
        > *make install, worked.

        Did you run ./configure? It appears that you didn't. This is an
        important step if you're going to build vim with a non-standard
        option or install it in a non-standard place. Read the file
        vim62/src/INSTALL and the output of "./configure --help".

        > i had put the vimirc.vim file in ~/.vim/plugin and when I directly start
        > vim from that directory - it still gives the "must install perl
        > warnings". Idease on why this does this? This may be in part because of
        > the way i've installed vim. So my next questions may solve the problem.

        I don't know. Maybe. I've never used or installed vim with perl.

        > 2. I'm also getting this error when starting 6.2.
        >
        > Error detected while processing /home/ewinger/.vimrc:
        > line 1:
        > E484: Can't open file /usr/local/share/vim/syntax/syntax.vim
        >
        > For the life of me I can't figure out why its looking in there. I
        > attached my .vimrc at the bottom.

        Because you told it to. Or rather, by not using configure to
        specify a location for these files, you got the default locations.

        > 3. having now two working versions of vim on my system, what are the
        > best practices for compiling one's own vim on linux? as far as where to
        > put the source, compile options, etc.

        I'm not sure there is one "best" place. It depends in part on
        whether you are the sys admin and are installing vim for everyone's
        use, or whether you are a user installing your own copy of vim for
        your own use. At work, I'm just a user. For each release of vim, I
        create a directory such as ~/src/vim-6.2 where I unpack the source.
        I run configure as

        ./configure --prefix=$HOME/src/vim-6.2

        plus options for any non-standard features that I want to include,
        then 'make' and 'make install'. I then use symbolic links to the
        files that have now been installed under ~/src/vim-6.2, like this:

        ln -sf ~/src/vim-6.2/bin/vim ~/bin/vim
        ln -sf ~/src/vim-6.2/man/man1/vim.1 ~/man/man1/vim.1
        ln -sf ~/src/vim-6.2/man/man1/vimdiff.1 ~/man/man1/vimdiff.1

        My ~/bin directory already contains symbolic links from gvim, view,
        vimdiff, etc. to vim.

        I keep copies of all the configure, make, ln, etc. commands I use in
        a README file, ~/src/vim-6.2/README, so that I can remember what I
        did and be able to build the next released or patched version with
        confidence.

        I've tried a number of different approaches to installing software
        over the years and have finally settled on this one. It's not
        standard Unix practice, but it keeps all the files (except the
        ~/.*rc files) together in one place and makes it really easy to
        change from one release of a package to another.

        > 4. How does vim determine which .vimrc files it uses? How can I be sure
        > that the vim I'm running is using the correct files, etc?

        See

        :help startup

        Executing ':version' will show you where vim is looking for
        configuration files.

        Those aren't all complete answers, but I didn't know how complete I
        needed to be, so if anything is still unclear, I'll be glad to try
        to fill in the blanks.

        HTH,
        Gary

        --
        Gary Johnson | Agilent Technologies
        garyjohn@... | Wireless Division
        | Spokane, Washington, USA
      • Benji Fisher
        ... I believe that is not necessary: running make will automatically reun configure. I normally do make first, then make install, but that should not
        Message 3 of 11 , Apr 1, 2004
        • 0 Attachment
          On Thu, Apr 01, 2004 at 05:20:36PM -0800, Gary Johnson wrote:
          > On 2004-04-01, Eric Winger <ewinger@...> wrote:
          > > Being my usual tangental self, I found the VimIRC plugin on my way to
          > > making vim my email editor and immediately had to dive in. In trying to
          > > make the VimIRC plugin work, I ventured into the realm of compiling my
          > > own vim so I could turn on the perl interface. However, I've run into
          > > several problems. Hoping someone can guide me.
          > >
          > > 1.When compiling vim, after having used the vim binaries precompiled for
          > > sometime, I'm confused as to where my defaults are now. Here's what I did.
          > >
          > > *downloaded linux source into ~/vimsource.
          > > *bunzip'd & untar'd creating vim62 dir with lots of goodies.
          > > *cd'd down to vim62/src
          > > *uncommented the Makefile perl options
          > > *make install, worked.
          >
          > Did you run ./configure? It appears that you didn't. This is an
          > important step if you're going to build vim with a non-standard
          > option or install it in a non-standard place. Read the file
          > vim62/src/INSTALL and the output of "./configure --help".

          I believe that is not necessary: running make will automatically
          reun configure. I normally do "make" first, then "make install," but
          that should not matter. I would try again, looking for error messages,
          or maybe read the configure log or try "make test."

          > > i had put the vimirc.vim file in ~/.vim/plugin and when I directly start
          > > vim from that directory - it still gives the "must install perl
          > > warnings". Idease on why this does this? This may be in part because of
          > > the way i've installed vim. So my next questions may solve the problem.
          >
          > I don't know. Maybe. I've never used or installed vim with perl.

          What does :version tell you? If you are accidentally running the
          old version, you should find out right away. You can also check for
          +perl or -perl .

          > > 2. I'm also getting this error when starting 6.2.
          > >
          > > Error detected while processing /home/ewinger/.vimrc:
          > > line 1:
          > > E484: Can't open file /usr/local/share/vim/syntax/syntax.vim
          > >
          > > For the life of me I can't figure out why its looking in there. I
          > > attached my .vimrc at the bottom.
          >
          > Because you told it to. Or rather, by not using configure to
          > specify a location for these files, you got the default locations.

          I think that is only part of the problem. First of all, something
          like "vim62/" should be part of the path: for me, $VIMRUNTIME is
          /usr/local/share/vim/vim62 . Second, why is there an error from the
          first line of the personal vimrc file? It has been snipped, but I do
          not remember seeing a "syntax on" line or anything. OTOH, the first
          line looked a little weird, something like "s on": did that get copied
          into the e-mail correctly?

          The output of :version should tell you what the default value of
          $VIM is and where the system vimrc file is. You can also try

          :echo $VIM $VIMRUNTIME

          > > 3. having now two working versions of vim on my system, what are the
          > > best practices for compiling one's own vim on linux? as far as where to
          > > put the source, compile options, etc.
          [snip]

          It just occurred to me: I usually compile vim with

          $ make
          $ sudo make install

          The OP did not mention using su nor sudo; are we really sure it
          "worked"? This is my best guess for now.

          HTH --Benji Fisher
        • Mikolaj Machowski
          ... Hmm. I prefer ./configure way: ./configure --enable-gui=gtk2 --with-features=big --enable-perlinterp --enable-pythoninterp ... Yes. It s strange, should
          Message 4 of 11 , Apr 2, 2004
          • 0 Attachment
            Dnia pią 2. kwietnia 2004 01:54, Eric Winger napisał:
            > Being my usual tangental self, I found the VimIRC plugin on my way to
            > making vim my email editor and immediately had to dive in. In trying to
            > make the VimIRC plugin work, I ventured into the realm of compiling my
            > own vim so I could turn on the perl interface. However, I've run into
            > several problems. Hoping someone can guide me.
            >
            > 1.When compiling vim, after having used the vim binaries precompiled for
            > sometime, I'm confused as to where my defaults are now. Here's what I
            > did.
            >
            > *downloaded linux source into ~/vimsource.
            > *bunzip'd & untar'd creating vim62 dir with lots of goodies.
            > *cd'd down to vim62/src
            > *uncommented the Makefile perl options

            Hmm. I prefer ./configure way:
            ./configure --enable-gui=gtk2 --with-features=big --enable-perlinterp
            --enable-pythoninterp

            > 2. I'm also getting this error when starting 6.2.
            >
            > Error detected while processing /home/ewinger/.vimrc:
            > line 1:
            > E484: Can't open file /usr/local/share/vim/syntax/syntax.vim
            >
            > For the life of me I can't figure out why its looking in there. I
            > attached my .vimrc at the bottom.

            Yes. It's strange, should look in
            /usr/local/share/vim/vim62/syntax/syntax.vim

            >
            > 3. having now two working versions of vim on my system, what are the
            > best practices for compiling one's own vim on linux? as far as where to
            > put the source, compile options, etc.

            I am using standard compiler options:
            :r !echo $CFLAGS
            -march=athlon -mcpu=athlon -Os -fomit-frame-pointer -pipe -DNDEBUG
            -DG_DISABLE_ASSERT
            :r !echo $LDFLAGS
            -z combreloc

            Probably you would like add stripping flags.

            > 4. How does vim determine which .vimrc files it uses? How can I be sure
            > that the vim I'm running is using the correct files, etc?

            :version

            m.


            --
            LaTeX + Vim = http://vim-latex.sourceforge.net/
            Vim-list(s) Users Map: (last change 10 Mar)
            http://skawina.eu.org/mikolaj/vimlist
            Are You There?
          • Eric Winger
            A bunch of my mail got dropped during a freak bout of stupidity. If you happened to reply to this, could you resend? sorry. thx. Or maybe there s a very recent
            Message 5 of 11 , Apr 2, 2004
            • 0 Attachment
              A bunch of my mail got dropped during a freak bout of stupidity. If you
              happened to reply to this, could you resend? sorry. thx. Or maybe
              there's a very recent archive someone can point me to. thx

              Eric Winger wrote:
              > Being my usual tangental self, I found the VimIRC plugin on my way to
              > making vim my email editor and immediately had to dive in. In trying to
              > make the VimIRC plugin work, I ventured into the realm of compiling my
              > own vim so I could turn on the perl interface. However, I've run into
              > several problems. Hoping someone can guide me.
              >
              > 1.When compiling vim, after having used the vim binaries precompiled for
              > sometime, I'm confused as to where my defaults are now. Here's what I did.
              >
              > *downloaded linux source into ~/vimsource.
              > *bunzip'd & untar'd creating vim62 dir with lots of goodies.
              > *cd'd down to vim62/src
              > *uncommented the Makefile perl options
              > *make install, worked.
              >
              > i had put the vimirc.vim file in ~/.vim/plugin and when I directly start
              > vim from that directory - it still gives the "must install perl
              > warnings". Idease on why this does this? This may be in part because of
              > the way i've installed vim. So my next questions may solve the problem.
              >
              > 2. I'm also getting this error when starting 6.2.
              >
              > Error detected while processing /home/ewinger/.vimrc:
              > line 1:
              > E484: Can't open file /usr/local/share/vim/syntax/syntax.vim
              >
              > For the life of me I can't figure out why its looking in there. I
              > attached my .vimrc at the bottom.
              >
              >
              > 3. having now two working versions of vim on my system, what are the
              > best practices for compiling one's own vim on linux? as far as where to
              > put the source, compile options, etc.
              >
              > 4. How does vim determine which .vimrc files it uses? How can I be sure
              > that the vim I'm running is using the correct files, etc?
              >
              > any help is appreciated,
              >
              > Eric
              >
              >
              >
              >
              >
              > contents of .vimrc
              >
              > :s on :set incsearch
              > :set laststatus=2
              > :set wildmode=longest,list
              > :set wildmenu
              > " Wed 01 Jan 2003
              > :ab mdyl <c-r>=strftime("%a %d %b %Y")<cr>
              > :" 01/01/2003 07:55:50
              > :ab mdyc <c-r>=strftime("%c")<cr>
              > :" 01/01/03 19:56:01
              > :ab hml <c-r>=strftime("%d/%m/%y %H:%M:%S")<cr>
              > :" 19:56:06
              > :ab hms <c-r>=strftime("%H:%M:%S")<cr>
              > :imap <Insert> <C-N>
              >
              > :set printoptions=paper:letter
              > nmap <silent> gw "_yiw:s/\(\%#\w\+\)\(\W\+\)\(\w\+\)/\3\2\1/<cr><c-o><c-l>
              >
              > -----------------------------------------
              > This email message is intended only for the addressee(s) and contains
              > information that may be confidential to and/or copyrighted by Key
              > Technology. If you are not the intended recipient, please notify the
              > sender by reply email and immediately delete this email. Use,
              > disclosure or reproduction of this email by anyone other than the
              > intended recipient(s) is strictly prohibited. Any views expressed in
              > the email are those of the individual sender unless the sender expressly
              > states them to be the views of Key Technology. No representation is
              > made that this email or any attachments are free of viruses. Virus
              > scanning is recommended and is the responsibility of the recipient.
              >
              >

              -----------------------------------------
              This email message is intended only for the addressee(s) and contains information that may be confidential to and/or copyrighted by Key Technology. If you are not the intended recipient, please notify the sender by reply email and immediately delete this email. Use, disclosure or reproduction of this email by anyone other than the intended recipient(s) is strictly prohibited. Any views expressed in the email are those of the individual sender unless the sender expressly states them to be the views of Key Technology. No representation is made that this email or any attachments are free of viruses. Virus scanning is recommended and is the responsibility of the recipient.
            • Gary Johnson
              ... There s an archive at of this thread at http://marc.theaimsgroup.com/?l=vim&r=1&b=200404&w=2 You can find more about vim archives at
              Message 6 of 11 , Apr 2, 2004
              • 0 Attachment
                On 2004-04-02, Eric Winger <ewinger@...> wrote:
                > A bunch of my mail got dropped during a freak bout of stupidity. If you
                > happened to reply to this, could you resend? sorry. thx. Or maybe
                > there's a very recent archive someone can point me to. thx

                There's an archive at of this thread at

                http://marc.theaimsgroup.com/?l=vim&r=1&b=200404&w=2

                You can find more about vim archives at

                http://vim.sourceforge.net/maillist.php#vim

                HTH,
                Gary

                --
                Gary Johnson | Agilent Technologies
                garyjohn@... | Wireless Division
                | Spokane, Washington, USA
              • Eric Winger
                ... Thanks for the link. I ve reviewed all the comments & suggestions. But I ve noticed after doing my compile that :version still returns perl & python are -.
                Message 7 of 11 , Apr 2, 2004
                • 0 Attachment
                  Gary Johnson wrote:
                  >
                  > There's an archive at of this thread at
                  >
                  > http://marc.theaimsgroup.com/?l=vim&r=1&b=200404&w=2
                  >
                  > You can find more about vim archives at
                  >
                  > http://vim.sourceforge.net/maillist.php#vim


                  Thanks for the link. I've reviewed all the comments & suggestions. But
                  I've noticed after doing my compile that :version still returns perl &
                  python are -. i.e. -perl & -python.

                  Here is the configuration command I ran:
                  ./configure --enable-gui=gtk2 --with-features=big --enable-perlinterp
                  --enable-pythoninterp --prefix=$HOME/src/vim6

                  which did lots of things seeimgly without error. (this should eliminate
                  the need for having to tweak the makefile right?)

                  then I ran make which said
                  link.sh: Linked fine with a few libraries removed

                  then I ran make install which seemed to work.

                  I included the output of :version below.

                  And it doesn't seem to be finding my plugin directory as :VimIRC is
                  being reported as a non-command. I copied a copy of the dir to my new
                  home directory, but to no avail.

                  Thoughts?

                  Eric





                  Big version without GUI. Features included (+) or not (-):
                  +arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent
                  +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                  +comments
                  +cryptv +cscope +dialog_con +diff +digraphs -dnd -ebcdic +emacs_tags +eval
                  +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding -footer
                  +fork() -gettext -hangul_input +iconv +insert_expand +jumplist +keymap
                  +langmap
                  +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
                  +modify_fname +mouse -mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm
                  +mouse_netterm +mouse_xterm +multi_byte +multi_lang -netbeans_intg
                  -osfiletype
                  +path_extra -perl +postscript +printer -python +quickfix +rightleft -ruby
                  +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax
                  +tag_binary +tag_old_static -tag_any_white -tcl +terminfo +termresponse
                  +textobjects +title -toolbar +user_commands +vertsplit +virtualedit +visual
                  +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup
                  +X11 +xfontset -xim -xsmp +xterm_clipboard -xterm_save
                  system vimrc file: "$VIM/vimrc"
                  user vimrc file: "$HOME/.vimrc"
                  user exrc file: "$HOME/.exrc"
                  fall-back for $VIM: "/home/ewinger/src/vim6/share/vim"
                  Compilation:
                  gcc -c -I. -Iproto -DHAVE_CONFIG_H -g -O2 -I/usr/X11R6/include
                  Linking:
                  gcc -L/usr/X11R6/lib -L/usr/local/lib -o vim -lXt -lncurses -ldl



                  -----------------------------------------
                  This email message is intended only for the addressee(s) and contains information that may be confidential to and/or copyrighted by Key Technology. If you are not the intended recipient, please notify the sender by reply email and immediately delete this email. Use, disclosure or reproduction of this email by anyone other than the intended recipient(s) is strictly prohibited. Any views expressed in the email are those of the individual sender unless the sender expressly states them to be the views of Key Technology. No representation is made that this email or any attachments are free of viruses. Virus scanning is recommended and is the responsibility of the recipient.
                • Eric Winger
                  ... I realized a mistake with the prefix which I changed to --prefix=$HOME/vim/vim62 but it made not a difference. The $HOME is correct /home/ewinger/ fyi eric
                  Message 8 of 11 , Apr 2, 2004
                  • 0 Attachment
                    Eric Winger wrote:
                    >
                    > Here is the configuration command I ran:
                    > ./configure --enable-gui=gtk2 --with-features=big --enable-perlinterp
                    > --enable-pythoninterp --prefix=$HOME/src/vim6
                    >

                    I realized a mistake with the prefix which I changed to
                    --prefix=$HOME/vim/vim62 but it made not a difference. The $HOME is
                    correct /home/ewinger/

                    fyi

                    eric

                    -----------------------------------------
                    This email message is intended only for the addressee(s) and contains information that may be confidential to and/or copyrighted by Key Technology. If you are not the intended recipient, please notify the sender by reply email and immediately delete this email. Use, disclosure or reproduction of this email by anyone other than the intended recipient(s) is strictly prohibited. Any views expressed in the email are those of the individual sender unless the sender expressly states them to be the views of Key Technology. No representation is made that this email or any attachments are free of viruses. Virus scanning is recommended and is the responsibility of the recipient.
                  • Benji Fisher
                    ... If configure has problems finding your perl library, it will not give an error message. It will just arrange to compile without perl support. Have a look
                    Message 9 of 11 , Apr 2, 2004
                    • 0 Attachment
                      On Fri, Apr 02, 2004 at 04:53:31PM -0800, Eric Winger wrote:
                      > >
                      > Thanks for the link. I've reviewed all the comments & suggestions. But
                      > I've noticed after doing my compile that :version still returns perl &
                      > python are -. i.e. -perl & -python.
                      >
                      > Here is the configuration command I ran:
                      > ./configure --enable-gui=gtk2 --with-features=big --enable-perlinterp
                      > --enable-pythoninterp --prefix=$HOME/src/vim6
                      >
                      > which did lots of things seeimgly without error. (this should eliminate
                      > the need for having to tweak the makefile right?)

                      If configure has problems finding your perl library, it will not
                      give an error message. It will just arrange to compile without perl
                      support. Have a look at vim62/src/auto/config.log to figure out why you
                      get -perl .

                      > then I ran make which said
                      > link.sh: Linked fine with a few libraries removed
                      >
                      > then I ran make install which seemed to work.
                      >
                      > I included the output of :version below.

                      It looks as though you snipped the first few lines, including the
                      date. I am not sure that this is the version you just compiled rather
                      than the version that has been there all along.

                      > And it doesn't seem to be finding my plugin directory as :VimIRC is
                      > being reported as a non-command. I copied a copy of the dir to my new
                      > home directory, but to no avail.

                      One thing at a time ...

                      > Thoughts?
                      >
                      > Eric
                      >
                      > Big version without GUI. Features included (+) or not (-):
                      > +arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent
                      [snip]
                      > +path_extra -perl +postscript +printer -python +quickfix +rightleft -ruby
                      [snip]

                      Is this right?

                      > fall-back for $VIM: "/home/ewinger/src/vim6/share/vim"

                      HTH --Benji Fisher
                    • Eric Winger
                      ... I moved my config.log file, then reran configure. The results are attached in all there glory. I didn t snip because I m not sure what s relevant. But it
                      Message 10 of 11 , Apr 5, 2004
                      • 0 Attachment
                        Benji Fisher wrote:
                        >
                        > If configure has problems finding your perl library, it will not
                        > give an error message. It will just arrange to compile without perl
                        > support. Have a look at vim62/src/auto/config.log to figure out why you
                        > get -perl .
                        >
                        >

                        I moved my config.log file, then reran configure. The results are
                        attached in all there glory. I didn't snip because I'm not sure what's
                        relevant. But it appears that there are no errors in the perl detection.

                        >
                        > It looks as though you snipped the first few lines, including the
                        > date. I am not sure that this is the version you just compiled rather
                        > than the version that has been there all along.
                        >

                        Attached with date below.

                        >
                        >>And it doesn't seem to be finding my plugin directory as :VimIRC is
                        >>being reported as a non-command. I copied a copy of the dir to my new
                        >>home directory, but to no avail.
                        >
                        >
                        > One thing at a time ...

                        Good idea.

                        Eric



                        :version
                        VIM - Vi IMproved 6.2 (2003 Jun 1, compiled Apr 2 2004 16:59:54)
                        Compiled by ewinger@nuffin
                        Big version without GUI. Features included (+) or not (-):
                        +arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset +cindent
                        +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
                        +comments
                        +cryptv +cscope +dialog_con +diff +digraphs -dnd -ebcdic +emacs_tags +eval
                        +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding -footer
                        +fork() -gettext -hangul_input +iconv +insert_expand +jumplist +keymap
                        +langmap
                        +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
                        +modify_fname +mouse -mouseshape +mouse_dec -mouse_gpm -mouse_jsbterm
                        +mouse_netterm +mouse_xterm +multi_byte +multi_lang -netbeans_intg
                        -osfiletype
                        +path_extra -perl +postscript +printer -python +quickfix +rightleft -ruby
                        +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax
                        +tag_binary +tag_old_static -tag_any_white -tcl +terminfo +termresponse
                        +textobjects +title -toolbar +user_commands +vertsplit +virtualedit +visual
                        +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup
                        +X11 +xfontset -xim -xsmp +xterm_clipboard -xterm_save
                        system vimrc file: "$VIM/vimrc"
                        user vimrc file: "$HOME/.vimrc"
                        user exrc file: "$HOME/.exrc"
                        fall-back for $VIM: "/home/ewinger/vim/vim62/share/vim"
                        Compilation:
                        gcc -c -I. -Iproto -DHAVE_CONFIG_H -g -O2 -I/usr/X11R6/include
                        Linking:
                        gcc -L/usr/X11R6/lib -L/usr/local/lib -o vim -lXt -lncurses -ldl



                        -----------------------------------------
                        This email message is intended only for the addressee(s) and contains information that may be confidential to and/or copyrighted by Key Technology. If you are not the intended recipient, please notify the sender by reply email and immediately delete this email. Use, disclosure or reproduction of this email by anyone other than the intended recipient(s) is strictly prohibited. Any views expressed in the email are those of the individual sender unless the sender expressly states them to be the views of Key Technology. No representation is made that this email or any attachments are free of viruses. Virus scanning is recommended and is the responsibility of the recipient.
                      • Benji Fisher
                        ... [snip] ... [snip] ... All right, this seems to be a recently compiled vim, with -perl and -python. It looks as though you have not applied any patches.
                        Message 11 of 11 , Apr 15, 2004
                        • 0 Attachment
                          On Mon, Apr 05, 2004 at 09:01:05AM -0700, Eric Winger wrote:
                          >
                          > Benji Fisher wrote:
                          > >
                          > > If configure has problems finding your perl library, it will not
                          > >give an error message. It will just arrange to compile without perl
                          > >support. Have a look at vim62/src/auto/config.log to figure out why you
                          > >get -perl .
                          >
                          > I moved my config.log file, then reran configure. The results are
                          > attached in all there glory. I didn't snip because I'm not sure what's
                          > relevant. But it appears that there are no errors in the perl detection.
                          >
                          > >
                          > > It looks as though you snipped the first few lines, including the
                          > >date. I am not sure that this is the version you just compiled rather
                          > >than the version that has been there all along.
                          > >
                          >
                          > Attached with date below.
                          >
                          > :version
                          > VIM - Vi IMproved 6.2 (2003 Jun 1, compiled Apr 2 2004 16:59:54)
                          > Compiled by ewinger@nuffin
                          > Big version without GUI. Features included (+) or not (-):
                          [snip]
                          > +path_extra -perl +postscript +printer -python +quickfix +rightleft -ruby
                          [snip]
                          > system vimrc file: "$VIM/vimrc"
                          > user vimrc file: "$HOME/.vimrc"
                          > user exrc file: "$HOME/.exrc"
                          > fall-back for $VIM: "/home/ewinger/vim/vim62/share/vim"
                          > Compilation:
                          > gcc -c -I. -Iproto -DHAVE_CONFIG_H -g -O2 -I/usr/X11R6/include
                          > Linking:
                          > gcc -L/usr/X11R6/lib -L/usr/local/lib -o vim -lXt -lncurses -ldl

                          All right, this seems to be a recently compiled vim, with -perl and
                          -python. It looks as though you have not applied any patches. Last I
                          checked, there were 472 official patches, and it is possible that one of
                          them already solves your problem. I suggest either getting the patches
                          or using CVS (or GNU Arch) to get a more recent version of the source.
                          http://www.vim.org/download.php

                          > This file contains any messages produced by compilers while
                          > running configure, to aid debugging if configure makes a mistake.
                          >
                          > configure:616: checking whether make sets ${MAKE}
                          > configure:646: checking for gcc
                          > configure:759: checking whether the C compiler (gcc ) works
                          > configure:775: gcc -o conftest conftest.c 1>&5
                          > configure:801: checking whether the C compiler (gcc ) is a cross-compiler
                          [snip]

                          Ugh. I do not see anything obviously wrong. Comparing with my own
                          config.log, one difference is that mine has lots of flags (including
                          some to link with the perl libs) in those lines (inside the
                          parentheses). I am not sure how this is supposed to work.

                          Conclusion: I cannot figure out what is going wrong, but getting
                          the current version of the source may help.

                          HTH --Benji Fisher
                        Your message has been successfully submitted and would be delivered to recipients shortly.