Loading ...
Sorry, an error occurred while loading the content.
 

Keypresses being ignored - Solaris GTK

Expand Messages
  • William.Fulton@ubs.com
    I am having some basic editing problems using gvim on Solaris which seems to only occur with syntax highlighting turned on. Keypresses are being ignored. It
    Message 1 of 4 , Mar 2, 2004
      I am having some basic editing problems using gvim on Solaris which seems to only occur with syntax highlighting turned on. Keypresses are being ignored. It can be demonstrated by creating the following file (vimproblem.h)

      class LockoutCalculator
      {
      public:
      LockoutCalculator();
      virtual ~LockoutCalculator();
      };

      Load it up using gvim -u NONE -U NONE vimproblem.h
      Append an X (or anything else) to the class name then attempt to comment out the word public... gvim commands:
      :syn on [enter]
      1G
      AX [esc]
      jj
      I//

      The second forward slash does not appear, in fact any further editing on this line requires most letters to be typed out twice for them to appear.

      Version is 6.2 no patches, gtk build. The problem does not seem to occur when syntax highlighting is off (syn=off). Any suggestions much appreciated.

      William

      bash-2.04$ gvim --version
      VIM - Vi IMproved 6.2 (2003 Jun 1, compiled Dec 30 2003 10:05:20)
      Compiled @sldn0037dsc
      Normal version with GTK GUI. Features included (+) or not (-):
      -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
      -cryptv -cscope +dialog_con_gui +diff +digraphs +dnd -ebcdic -emacs_tags +eval
      +ex_extra +extra_search -farsi +file_in_path +find_in_path +folding -footer
      +fork() -gettext -hangul_input -iconv +insert_expand +jumplist -keymap -langmap
      +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
      +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm -mouse_jsbterm
      -mouse_netterm +mouse_xterm -multi_byte +multi_lang +netbeans_intg -osfiletype
      +path_extra +perl +postscript +printer +python +quickfix -rightleft -ruby
      +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax
      +tag_binary +tag_old_static -tag_any_white +tcl +terminfo +termresponse
      +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual
      +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup
      +X11 -xfontset +xim -xsmp +xterm_clipboard +xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/sbcimp/run/pd/vim/6.2/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/sbcimp/run/pd/gtk/1.2.10/include/gtk-1.2 -I/sbcimp/run/pd/gtk/1.2.10/include/glib-1.2 -I/sbcimp/run/pd/gtk/1.2.10/lib/glib/include -I/usr/openwin/include -g -O2 -fno-strength-reduce -I/usr/openwin/include -fno-strict-aliasing -I/sbcimp/run/pd/gdbm/1.8.0/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/sbcimp/run/pd/perl/5.8.0/lib/CORE -I/sbcimp/run/pd/python/2.2/include/python2.2 -pthread -I/sbcimp/run/pd/tcl/8.3.2/include
      Linking: gcc -L/usr/openwin/lib -R/usr/openwin/lib -o vim -L/sbcimp/run/pd/gtk/1.2.10/lib -R/sbcimp/run/pd/gtk/1.2.10/lib -L/usr/openwin/lib -R/usr/openwin/lib -lgtk -lgdk -lgmodule -lglib -ldl -lXext -lXt -lX11 -ltermlib -ldl -L/sbcimp/run/pd/gdbm/1.8.0/lib /sbcimp/run/pd/perl/5.8.0/lib/auto/DynaLoader/DynaLoader.a -L/sbcimp/run/pd/perl/5.8.0/lib/CORE -lperl -ldl -lc -L/sbcimp/run/pd/python/2.2/lib/python2.2/config -lpython2.2 -ldl -L/usr/lib -R/usr/lib -L/sbcimp/run/pd/tcl/8.3.2/lib -R/sbcimp/run/pd/tcl/8.3.2/lib -ltcl8.3 -ldl -lsocket -lnsl -lm

      Build details
      o-----------o

      O-S: SunOS 5.8 Generic_108528-12 sun4u sparc SUNW,Ultra-Enterprise

      Compiler: gcc 3.1

      Built with: /sbcimp/run/pd/gtk/1.2.10
      /sbcimp/run/pd/perl/5.8.0/bin
      /sbcimp/run/pd/python/2.2/bin
      /sbcimp/run/pd/tcl/8.3.2/bin

      Defaults changed:
      -cryptv
      +xterm_save

      Configure:
      ./configure --prefix=/sbcimp/run/pd/vim/6.2 \
      --with-cc=gcc \
      --enable-gui=gtk \
      --disable-motif-check \
      --disable-athena-check \
      --with-gtk-prefix=/sbcimp/run/pd/gtk/1.2.10 \
      --enable-max-features \
      --enable-perlinterp \
      --enable-pythoninterp \
      --with-python-config-dir=/sbcimp/run/pd/python/2.2/lib/python2.2/config \
      --enable-tclinterp


      --

      Visit our website at http://www.ubs.com

      This message contains confidential information and is intended only
      for the individual named. If you are not the named addressee you
      should not disseminate, distribute or copy this e-mail. Please
      notify the sender immediately by e-mail if you have received this
      e-mail by mistake and delete this e-mail from your system.

      E-mail transmission cannot be guaranteed to be secure or error-free
      as information could be intercepted, corrupted, lost, destroyed,
      arrive late or incomplete, or contain viruses. The sender therefore
      does not accept liability for any errors or omissions in the contents
      of this message which arise as a result of e-mail transmission. If
      verification is required please request a hard-copy version. This
      message is provided for informational purposes and should not be
      construed as a solicitation or offer to buy or sell any securities or
      related financial instruments.
    • Bram Moolenaar
      ... Strange, and I can t reproduce it. Especially because you first need to append something to the first line. Does this only happen when inserting // ?
      Message 2 of 4 , Mar 2, 2004
        William Fulton wrote:

        > I am having some basic editing problems using gvim on Solaris which
        > seems to only occur with syntax highlighting turned on. Keypresses are
        > being ignored. It can be demonstrated by creating the following file
        > (vimproblem.h)
        >
        > class LockoutCalculator
        > {
        > public:
        > LockoutCalculator();
        > virtual ~LockoutCalculator();
        > };
        >
        > Load it up using gvim -u NONE -U NONE vimproblem.h
        > Append an X (or anything else) to the class name then attempt to
        > comment out the word public... gvim commands:
        > :syn on [enter]
        > 1G
        > AX [esc]
        > jj
        > I//
        >
        > The second forward slash does not appear, in fact any further editing
        > on this line requires most letters to be typed out twice for them to
        > appear.

        Strange, and I can't reproduce it. Especially because you first need to
        append something to the first line.

        Does this only happen when inserting "//"? That starts a comment, might
        be relevant. Does typing "/x" work?

        Did you try setting 'imdisable'? Just guessing... Hmm, "-multi_byte"
        suggests that you don't use XIM, thus this would not be the problem.

        > Compiler: gcc 3.1

        Try building without optimizing. Some gcc versions have a broken
        optimizer.

        > Built with: /sbcimp/run/pd/gtk/1.2.10
        > /sbcimp/run/pd/perl/5.8.0/bin
        > /sbcimp/run/pd/python/2.2/bin
        > /sbcimp/run/pd/tcl/8.3.2/bin

        Try without perl/python/tcl. They may cause another library to be used
        (threaded).

        --
        BLACK KNIGHT: I move for no man.
        ARTHUR: So be it!
        [hah] [parry thrust]
        [ARTHUR chops the BLACK KNIGHT's left arm off]
        ARTHUR: Now stand aside, worthy adversary.
        BLACK KNIGHT: 'Tis but a scratch.
        The Quest for the Holy Grail (Monty Python)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
        \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
      • William.Fulton@ubs.com
        ... It will happen with anything one types. In fact if I type out the alphabet instead, this is what I get: abdfgijkmoqsuvwyzpublic: Same occurs if I insert
        Message 3 of 4 , Mar 3, 2004
          >-----Original Message-----
          >From: Bram@... [mailto:Bram@...]
          >Sent: 02 March 2004 13:13
          >To: Fulton, William
          >Cc: vim@...
          >Subject: Re: Keypresses being ignored - Solaris GTK
          >
          >
          >
          >William Fulton wrote:
          >
          >> I am having some basic editing problems using gvim on Solaris which
          >> seems to only occur with syntax highlighting turned on.
          >Keypresses are
          >> being ignored. It can be demonstrated by creating the following file
          >> (vimproblem.h)
          >>
          >> class LockoutCalculator
          >> {
          >> public:
          >> LockoutCalculator();
          >> virtual ~LockoutCalculator();
          >> };
          >>
          >> Load it up using gvim -u NONE -U NONE vimproblem.h
          >> Append an X (or anything else) to the class name then attempt to
          >> comment out the word public... gvim commands:
          >> :syn on [enter]
          >> 1G
          >> AX [esc]
          >> jj
          >> I//
          >>
          >> The second forward slash does not appear, in fact any further editing
          >> on this line requires most letters to be typed out twice for them to
          >> appear.
          >
          >Strange, and I can't reproduce it. Especially because you
          >first need to
          >append something to the first line.
          >
          >Does this only happen when inserting "//"? That starts a
          >comment, might
          >be relevant. Does typing "/x" work?
          >
          It will happen with anything one types. In fact if I type out the alphabet instead, this is what I get:

          abdfgijkmoqsuvwyzpublic:

          Same occurs if I insert text at the beginning of the following line, but all the other lines are okay. I've tried very hard to find a pattern, but can't. It can occur with any of the insert type commands, like i or a and seems to affect only certain lines. I get the same problem if instead of appending X, I insert of append anything on the first two lines. This is a repeatable case, but it seemingly happens at random when editing.

          >Did you try setting 'imdisable'? Just guessing... Hmm, "-multi_byte"
          >suggests that you don't use XIM, thus this would not be the problem.
          >
          >> Compiler: gcc 3.1
          >
          >Try building without optimizing. Some gcc versions have a broken
          >optimizer.
          >
          >> Built with: /sbcimp/run/pd/gtk/1.2.10
          >> /sbcimp/run/pd/perl/5.8.0/bin
          >> /sbcimp/run/pd/python/2.2/bin
          >> /sbcimp/run/pd/tcl/8.3.2/bin
          >
          >Try without perl/python/tcl. They may cause another library to be used
          >(threaded).
          >

          I've got a corporate build and I couldn't get vim's configure to find gtk. Also it worked from another Solaris (5.6) box. Anyway I have switched from using Reflection as my X server (on Windows) to XFree86 with Cygwin and all is well now. I also tried Exceed and it gave the same problem. It is possibly an X server issue. Anyway I've bypassed the problem, thanks for all the suggestions.

          William

          --


          Visit our website at http://www.ubs.com

          This message contains confidential information and is intended only
          for the individual named. If you are not the named addressee you
          should not disseminate, distribute or copy this e-mail. Please
          notify the sender immediately by e-mail if you have received this
          e-mail by mistake and delete this e-mail from your system.

          E-mail transmission cannot be guaranteed to be secure or error-free
          as information could be intercepted, corrupted, lost, destroyed,
          arrive late or incomplete, or contain viruses. The sender therefore
          does not accept liability for any errors or omissions in the contents
          of this message which arise as a result of e-mail transmission. If
          verification is required please request a hard-copy version. This
          message is provided for informational purposes and should not be
          construed as a solicitation or offer to buy or sell any securities or
          related financial instruments.
        • Yakov Lerner
          ... I tried this on vim 6.2.60 and on vim 6.2.263 on Solaris 8 (gtk 1.2). The problem does not appear. Yakov
          Message 4 of 4 , Mar 3, 2004
            William.Fulton@... wrote:
            > I am having some basic editing problems using gvim on Solaris which seems to only occur with syntax highlighting turned on. Keypresses are being ignored. It can be demonstrated by creating the following file (vimproblem.h)
            >
            > class LockoutCalculator
            > {
            > public:
            > LockoutCalculator();
            > virtual ~LockoutCalculator();
            > };
            >
            > Load it up using gvim -u NONE -U NONE vimproblem.h
            > Append an X (or anything else) to the class name then attempt to comment out the word public... gvim commands:
            > :syn on [enter]
            > 1G
            > AX [esc]
            > jj
            > I//
            >
            > The second forward slash does not appear, in fact any further editing on this line requires most letters to be typed out twice for them to appear.
            >
            > Version is 6.2 no patches, gtk build. The problem does not seem to occur when syntax highlighting is off (syn=off). Any suggestions much appreciated.

            I tried this on vim 6.2.60 and on vim 6.2.263 on Solaris 8 (gtk 1.2).
            The problem does not appear.

            Yakov

            >
            > William
            >
            > bash-2.04$ gvim --version
            > VIM - Vi IMproved 6.2 (2003 Jun 1, compiled Dec 30 2003 10:05:20)
            > Compiled @sldn0037dsc
            > Normal version with GTK GUI. Features included (+) or not (-):
            > -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent
            > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
            > -cryptv -cscope +dialog_con_gui +diff +digraphs +dnd -ebcdic -emacs_tags +eval
            > +ex_extra +extra_search -farsi +file_in_path +find_in_path +folding -footer
            > +fork() -gettext -hangul_input -iconv +insert_expand +jumplist -keymap -langmap
            > +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession
            > +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm -mouse_jsbterm
            > -mouse_netterm +mouse_xterm -multi_byte +multi_lang +netbeans_intg -osfiletype
            > +path_extra +perl +postscript +printer +python +quickfix -rightleft -ruby
            > +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax
            > +tag_binary +tag_old_static -tag_any_white +tcl +terminfo +termresponse
            > +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual
            > +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup
            > +X11 -xfontset +xim -xsmp +xterm_clipboard +xterm_save
            > system vimrc file: "$VIM/vimrc"
            > user vimrc file: "$HOME/.vimrc"
            > user exrc file: "$HOME/.exrc"
            > system gvimrc file: "$VIM/gvimrc"
            > user gvimrc file: "$HOME/.gvimrc"
            > system menu file: "$VIMRUNTIME/menu.vim"
            > fall-back for $VIM: "/sbcimp/run/pd/vim/6.2/share/vim"
            > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/sbcimp/run/pd/gtk/1.2.10/include/gtk-1.2 -I/sbcimp/run/pd/gtk/1.2.10/include/glib-1.2 -I/sbcimp/run/pd/gtk/1.2.10/lib/glib/include -I/usr/openwin/include -g -O2 -fno-strength-reduce -I/usr/openwin/include -fno-strict-aliasing -I/sbcimp/run/pd/gdbm/1.8.0/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/sbcimp/run/pd/perl/5.8.0/lib/CORE -I/sbcimp/run/pd/python/2.2/include/python2.2 -pthread -I/sbcimp/run/pd/tcl/8.3.2/include
            > Linking: gcc -L/usr/openwin/lib -R/usr/openwin/lib -o vim -L/sbcimp/run/pd/gtk/1.2.10/lib -R/sbcimp/run/pd/gtk/1.2.10/lib -L/usr/openwin/lib -R/usr/openwin/lib -lgtk -lgdk -lgmodule -lglib -ldl -lXext -lXt -lX11 -ltermlib -ldl -L/sbcimp/run/pd/gdbm/1.8.0/lib /sbcimp/run/pd/perl/5.8.0/lib/auto/DynaLoader/DynaLoader.a -L/sbcimp/run/pd/perl/5.8.0/lib/CORE -lperl -ldl -lc -L/sbcimp/run/pd/python/2.2/lib/python2.2/config -lpython2.2 -ldl -L/usr/lib -R/usr/lib -L/sbcimp/run/pd/tcl/8.3.2/lib -R/sbcimp/run/pd/tcl/8.3.2/lib -ltcl8.3 -ldl -lsocket -lnsl -lm
            >
            > Build details
            > o-----------o
            >
            > O-S: SunOS 5.8 Generic_108528-12 sun4u sparc SUNW,Ultra-Enterprise
            >
            > Compiler: gcc 3.1
            >
            > Built with: /sbcimp/run/pd/gtk/1.2.10
            > /sbcimp/run/pd/perl/5.8.0/bin
            > /sbcimp/run/pd/python/2.2/bin
            > /sbcimp/run/pd/tcl/8.3.2/bin
            >
            > Defaults changed:
            > -cryptv
            > +xterm_save
            >
            > Configure:
            > ./configure --prefix=/sbcimp/run/pd/vim/6.2 \
            > --with-cc=gcc \
            > --enable-gui=gtk \
            > --disable-motif-check \
            > --disable-athena-check \
            > --with-gtk-prefix=/sbcimp/run/pd/gtk/1.2.10 \
            > --enable-max-features \
            > --enable-perlinterp \
            > --enable-pythoninterp \
            > --with-python-config-dir=/sbcimp/run/pd/python/2.2/lib/python2.2/config \
            > --enable-tclinterp
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.