Loading ...
Sorry, an error occurred while loading the content.

vi question

Expand Messages
  • darren
    Please help, I have a question regarding your tuitorial on the text editor vi. I must have accidentally typed something, because now whenever I run vi, the
    Message 1 of 4 , Mar 2, 2004
    View Source
    • 0 Attachment
      Please help,

      I have a question regarding your tuitorial on the text
      editor vi. I must have accidentally typed something,
      because now whenever I run vi, the number one is
      highlighted when I type it. No other character does
      this. Any ideas on what could be causing this?

      -dm

      __________________________________
      Do you Yahoo!?
      Yahoo! Search - Find what you�re looking for faster
      http://search.yahoo.com
    • Ilya Sher
      ... Hash: SHA1 ... It s probably a simple search. try ... or search for something else /enter-your-search-here ... Version: GnuPG v1.2.4 (GNU/Linux) Comment:
      Message 2 of 4 , Mar 2, 2004
      View Source
      • 0 Attachment
        -----BEGIN PGP SIGNED MESSAGE-----
        Hash: SHA1

        darren wrote:
        | Please help,
        |
        | I have a question regarding your tuitorial on the text
        | editor vi. I must have accidentally typed something,
        | because now whenever I run vi, the number one is
        | highlighted when I type it. No other character does
        | this. Any ideas on what could be causing this?
        It's probably a simple search.
        try
        :noh
        or search for something else
        /enter-your-search-here
        |
        | -dm
        |
        | __________________________________
        | Do you Yahoo!?
        | Yahoo! Search - Find what youre looking for faster
        | http://search.yahoo.com
        |
        |

        -----BEGIN PGP SIGNATURE-----
        Version: GnuPG v1.2.4 (GNU/Linux)
        Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

        iD8DBQFARF0BKQCqGJKGZm4RAqw0AKCtFx0PJJX5RQLN7XnNRP3PJ66cQQCfQUNE
        7Kk6AkEe1ffm7G28oQBcKlw=
        =vBrV
        -----END PGP SIGNATURE-----
      • Andrei A. Voropaev
        ... Most likely you ve searched for 1. Now it gets highlighted. Try :nohls Andrei
        Message 3 of 4 , Mar 2, 2004
        View Source
        • 0 Attachment
          On Tue, Mar 02, 2004 at 01:43:48AM -0800, darren wrote:
          > Please help,
          >
          > I have a question regarding your tuitorial on the text
          > editor vi. I must have accidentally typed something,
          > because now whenever I run vi, the number one is
          > highlighted when I type it. No other character does
          > this. Any ideas on what could be causing this?

          Most likely you've searched for 1. Now it gets highlighted. Try :nohls

          Andrei
        • gumnos (Tim Chase)
          ... While the others offered temporary solutions, if you don t want your searches to be highlighted at all, you can set the option (either in an editing
          Message 4 of 4 , Mar 2, 2004
          View Source
          • 0 Attachment
            > I have a question regarding your tuitorial on the text
            > editor vi. I must have accidentally typed something,
            > because now whenever I run vi, the number one is
            > highlighted when I type it. No other character does
            > this. Any ideas on what could be causing this?

            While the others offered temporary solutions, if you don't want your
            searches to be highlighted at all, you can set the option (either in an
            editing session, or in your vimrc file.

            To disable it for just the current search, use what was suggested:

            :noh

            To disable it for the entire editing session, use:

            :set nohls

            To disable it on a long-term basis, put the line

            set nohls

            in your vimrc file. You can read more in the help at

            :help :nohlsearch
            :help 'hlsearch'

            which should get you pointed in the right direction. Also, if you want
            the highlighted searching, but don't want it to preserve across editing
            sessions, you can prevent it from being saved in your viminfo file, by
            adding "h" to your viminfo setting

            :set viminfo+=h

            and possibly (to prevent search history from carrying over)

            :set viminfo+=/0

            (should do it)...more help can be found at

            :help 'viminfo'

            Hope this helps,

            -tim
          Your message has been successfully submitted and would be delivered to recipients shortly.