Loading ...
Sorry, an error occurred while loading the content.

Re: Romanian IME on Windows XP

Expand Messages
  • Bram Moolenaar
    ... I don t know much about IME, but in order for someone to give you a hint, you need to mention the relevant Vim settings. Especially encoding and other
    Message 1 of 7 , Mar 1 1:56 AM
    • 0 Attachment
      Ionutz Borcoman wrote:

      > I have some problem with the Windows IME on WIndows XP.
      >
      > I am trying to write some text in Romanian using the windows IME. The
      > problem is that, when I switch the IME and try to produce \u 0x015f I
      > get \u 0x00ba.
      >
      > I have attached a file to this e-mail to illustrate my problem. Lines
      > 3-6 where typed in VIM with the Romanian IME activated. Lines 10-13
      > where typed using the same IME, but in Notepad.exe, then copyed from it
      > and pasted in the VIM. Lines 3-6 should be identical with 10-13, but
      > they aren't !
      >
      > My questions are:
      >
      > 1. any ideea why is this happening ?
      > 2. can this be solved without making a keymap for vim that translates \u
      > 0x00ba to \u 0x015f ?
      > 3. should I make a keymap that translates \u 0x00ba to \u 0x0015f or
      > ignore alltogether the windows IME and make a keymap that translates ';'
      > to \u 015f, for example ?

      I don't know much about IME, but in order for someone to give you a
      hint, you need to mention the relevant Vim settings. Especially
      'encoding' and other options starting with "im".

      --
      ** Hello and Welcome to the Psychiatric Hotline **
      If you are obsessive-compulsive, please press 1 repeatedly.
      If you are co-dependent, please ask someone to press 2.
      If you have multiple personalities, please press 3, 4, 5 and 6.
      If you are paranoid-delusional, we know who you are and what you want
      - just stay on the line so we can trace the call.
      If you are schizophrenic, listen carefully and a little voice will
      tell you which number to press next.
      If you are manic-depressive, it doesn't matter which number you press
      - no one will answer.
      If you suffer from panic attacks, push every button you can find.
      If you are sane, please hold on - we have the rest of humanity on the
      other line and they desparately want to ask you a few questions.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
    • Ionutz Borcoman
      ... Setting the termencoding to iso-8859-2 solved the problem. Ionutz
      Message 2 of 7 , Mar 1 2:38 AM
      • 0 Attachment
        Antoine J. Mechelynck wrote:

        > http://vim.sourceforge.net/tips/tip.php?tip_id=246 (What to know, and
        > where to look for help, when using Unicode in gvim)

        Setting the termencoding to iso-8859-2 solved the problem.

        Ionutz
      • Antoine J. Mechelynck
        ... The right way is what works for you. See :help iminsert about switching between East-Asian IM, keymap, and neither. HTH, Tony.
        Message 3 of 7 , Mar 1 3:04 AM
        • 0 Attachment
          Ionutz Borcoman <borco@...> wrote:
          > Antoine J. Mechelynck wrote:
          >
          > > http://vim.sourceforge.net/tips/tip.php?tip_id=246 (What to
          > > know, and where to look for help, when using Unicode in gvim)
          >
          > Setting the termencoding to iso-8859-2 solved the problem.
          >
          > Ionutz

          Ionutz Borcoman <borco@...> wrote:
          > > Antoine J. Mechelynck wrote:
          > > > Ionutz Borcoman <borco@...> wrote:
          > > >
          > > > I'm not sure what you call "Romanian IME". (I thought IM were
          > > > only for languages like Chinese, Japanese and Korean.) If you
          > > > mean the same thing as what I call the "International Keyboard"
          > > > application, then I can tell you that Vim is not aware of it.
          > >
          > > Yep, it was my mistake. I was thinking at the Romanian keyboard.
          > >
          > > What I would like to have is to be able to rotate the keyboards from
          > > EN->RO->Japanese->EN when I press ALT-SPACE (I whant to be able to
          > > edit files that contain both Japanese and Romanian characters). I
          > > can do this
          > > in Notepad, and I was curious if I can do it in VIM.
          > >
          > > I have attached my custom _vimrc to the e-mail. The script called
          > > in it
          > > is one of those you were talking about:
          > >
          > > http://vim.sourceforge.net/scripts/script.php?script_id=789
          > >
          > > I have also done my own romanian keymap, that does the translation
          > > between what the vim receives and what I was expecting it to
          > > receive,
          > > but I'm not sure yet that this is the 'right way'.
          > >
          > > TIA,
          > >
          > > Ionutz
          > >
          >
          >
          >
          > > source $VIM\_vimrc
          > >
          > > runtime scripts/set_utf8.vim
          > > set guifont=courier_new:h10


          The "right way" is what works for you. See ":help 'iminsert'" about
          switching between East-Asian IM, keymap, and neither.

          HTH,
          Tony.
        Your message has been successfully submitted and would be delivered to recipients shortly.