Loading ...
Sorry, an error occurred while loading the content.

Romanian IME on Windows XP

Expand Messages
  • Ionutz Borcoman
    Hi, I have some problem with the Windows IME on WIndows XP. I am trying to write some text in Romanian using the windows IME. The problem is that, when I
    Message 1 of 7 , Mar 1 12:15 AM
    • 0 Attachment
      Hi,

      I have some problem with the Windows IME on WIndows XP.

      I am trying to write some text in Romanian using the windows IME. The
      problem is that, when I switch the IME and try to produce \u 0x015f I
      get \u 0x00ba.

      I have attached a file to this e-mail to illustrate my problem. Lines
      3-6 where typed in VIM with the Romanian IME activated. Lines 10-13
      where typed using the same IME, but in Notepad.exe, then copyed from it
      and pasted in the VIM. Lines 3-6 should be identical with 10-13, but
      they aren't !

      My questions are:

      1. any ideea why is this happening ?
      2. can this be solved without making a keymap for vim that translates \u
      0x00ba to \u 0x015f ?
      3. should I make a keymap that translates \u 0x00ba to \u 0x0015f or
      ignore alltogether the windows IME and make a keymap that translates ';'
      to \u 015f, for example ?

      TIA,

      Ionutz
    • Ionutz Borcoman
      Sorry, I ve forgot to attach the file. Here it is. TIA, Ionutz ... VIM with Romanian-IME ]1234567890+ [! #¤%&/()=?* qwertzuiopãîâQWERTZUIOPÃÎÂ
      Message 2 of 7 , Mar 1 12:17 AM
      • 0 Attachment
        Sorry, I've forgot to attach the file. Here it is.

        TIA,

        Ionutz

        Ionutz Borcoman wrote:

        > Hi,
        >
        > I have some problem with the Windows IME on WIndows XP.
        >
        > I am trying to write some text in Romanian using the windows IME. The
        > problem is that, when I switch the IME and try to produce \u 0x015f I
        > get \u 0x00ba.
        >
        > I have attached a file to this e-mail to illustrate my problem. Lines
        > 3-6 where typed in VIM with the Romanian IME activated. Lines 10-13
        > where typed using the same IME, but in Notepad.exe, then copyed from it
        > and pasted in the VIM. Lines 3-6 should be identical with 10-13, but
        > they aren't !
        >
        > My questions are:
        >
        > 1. any ideea why is this happening ?
        > 2. can this be solved without making a keymap for vim that translates \u
        > 0x00ba to \u 0x015f ?
        > 3. should I make a keymap that translates \u 0x00ba to \u 0x0015f or
        > ignore alltogether the windows IME and make a keymap that translates ';'
        > to \u 015f, for example ?
        >
        > TIA,
        >
        > Ionutz
        >
        >
      • Bram Moolenaar
        ... I don t know much about IME, but in order for someone to give you a hint, you need to mention the relevant Vim settings. Especially encoding and other
        Message 3 of 7 , Mar 1 1:56 AM
        • 0 Attachment
          Ionutz Borcoman wrote:

          > I have some problem with the Windows IME on WIndows XP.
          >
          > I am trying to write some text in Romanian using the windows IME. The
          > problem is that, when I switch the IME and try to produce \u 0x015f I
          > get \u 0x00ba.
          >
          > I have attached a file to this e-mail to illustrate my problem. Lines
          > 3-6 where typed in VIM with the Romanian IME activated. Lines 10-13
          > where typed using the same IME, but in Notepad.exe, then copyed from it
          > and pasted in the VIM. Lines 3-6 should be identical with 10-13, but
          > they aren't !
          >
          > My questions are:
          >
          > 1. any ideea why is this happening ?
          > 2. can this be solved without making a keymap for vim that translates \u
          > 0x00ba to \u 0x015f ?
          > 3. should I make a keymap that translates \u 0x00ba to \u 0x0015f or
          > ignore alltogether the windows IME and make a keymap that translates ';'
          > to \u 015f, for example ?

          I don't know much about IME, but in order for someone to give you a
          hint, you need to mention the relevant Vim settings. Especially
          'encoding' and other options starting with "im".

          --
          ** Hello and Welcome to the Psychiatric Hotline **
          If you are obsessive-compulsive, please press 1 repeatedly.
          If you are co-dependent, please ask someone to press 2.
          If you have multiple personalities, please press 3, 4, 5 and 6.
          If you are paranoid-delusional, we know who you are and what you want
          - just stay on the line so we can trace the call.
          If you are schizophrenic, listen carefully and a little voice will
          tell you which number to press next.
          If you are manic-depressive, it doesn't matter which number you press
          - no one will answer.
          If you suffer from panic attacks, push every button you can find.
          If you are sane, please hold on - we have the rest of humanity on the
          other line and they desparately want to ask you a few questions.

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
          \\\ Buy at Amazon and help AIDS victims -- http://ICCF.nl/click1.html ///
        • Antoine J. Mechelynck
          ... I m not sure what you call Romanian IME . (I thought IM were only for languages like Chinese, Japanese and Korean.) If you mean the same thing as what I
          Message 4 of 7 , Mar 1 2:01 AM
          • 0 Attachment
            Ionutz Borcoman <borco@...> wrote:
            > Hi,
            >
            > I have some problem with the Windows IME on WIndows XP.
            >
            > I am trying to write some text in Romanian using the windows IME. The
            > problem is that, when I switch the IME and try to produce \u 0x015f I
            > get \u 0x00ba.
            >
            > I have attached a file to this e-mail to illustrate my problem. Lines
            > 3-6 where typed in VIM with the Romanian IME activated. Lines 10-13
            > where typed using the same IME, but in Notepad.exe, then copyed from
            > it and pasted in the VIM. Lines 3-6 should be identical with 10-13,
            > but they aren't !
            >
            > My questions are:
            >
            > 1. any ideea why is this happening ?
            > 2. can this be solved without making a keymap for vim that translates
            > \u 0x00ba to \u 0x015f ?
            > 3. should I make a keymap that translates \u 0x00ba to \u 0x0015f or
            > ignore alltogether the windows IME and make a keymap that translates
            > ';' to \u 015f, for example ?
            >
            > TIA,
            >
            > Ionutz

            I'm not sure what you call "Romanian IME". (I thought IM were only for
            languages like Chinese, Japanese and Korean.) If you mean the same thing as
            what I call the "International Keyboard" application, then I can tell you
            that Vim is not aware of it.

            I have an International Keyboard installed on my W98 system, and it works
            somehow (with the help of "paper keyboards" to tell me which key I must
            press to get what) in WordPad (not in W98 Notepad, which is very primitive,
            and knows nothing about any encoding other than the default 8-bit encoding
            defined by the locale). But in gvim, I keep the keyboard setting to its
            startup default (fr_BE in my case), and if and when I need some "exotic"
            characters like the accented consonants of Esperanto or the non-Latin
            characters of Russian and Arabic, then I use either digraphs or keymaps.
            Those keymaps define "language mappings" whose "left-hand sides" are based
            on my default keyboard setting, i.e., latin1.

            IMHO, digraphs are enough for most Latin encodings; for non-Latin alphabets,
            they are usable, but keymaps are easier.

            See also

            :help 'keymap'
            :help keymap-file-format

            http://vim.sourceforge.net/tips/tip.php?tip_id=246 (What to know, and
            where to look for help, when using Unicode in gvim)

            http://vim.sourceforge.net/scripts/script.php?script_id=789 (Orderly
            switching from one's defaul "locale" encoding to UTF-8)

            I have also published two sample keymaps: a very simple one for Esperanto
            (and Bram included it in the 6.2 distro), another for Russian (uploaded
            yesterday at vim-online). You can find more examples by looking in
            $VIMRUNTIME/keymap.

            HTH,
            Tony.
          • Ionutz Borcoman
            ... Yep, it was my mistake. I was thinking at the Romanian keyboard. What I would like to have is to be able to rotate the keyboards from EN- RO- Japanese- EN
            Message 5 of 7 , Mar 1 2:26 AM
            • 0 Attachment
              Antoine J. Mechelynck wrote:
              > Ionutz Borcoman <borco@...> wrote:
              >
              > I'm not sure what you call "Romanian IME". (I thought IM were only for
              > languages like Chinese, Japanese and Korean.) If you mean the same thing as
              > what I call the "International Keyboard" application, then I can tell you
              > that Vim is not aware of it.

              Yep, it was my mistake. I was thinking at the Romanian keyboard.

              What I would like to have is to be able to rotate the keyboards from
              EN->RO->Japanese->EN when I press ALT-SPACE (I whant to be able to edit
              files that contain both Japanese and Romanian characters). I can do this
              in Notepad, and I was curious if I can do it in VIM.

              I have attached my custom _vimrc to the e-mail. The script called in it
              is one of those you were talking about:

              http://vim.sourceforge.net/scripts/script.php?script_id=789

              I have also done my own romanian keymap, that does the translation
              between what the vim receives and what I was expecting it to receive,
              but I'm not sure yet that this is the 'right way'.

              TIA,

              Ionutz
            • Ionutz Borcoman
              ... Setting the termencoding to iso-8859-2 solved the problem. Ionutz
              Message 6 of 7 , Mar 1 2:38 AM
              • 0 Attachment
                Antoine J. Mechelynck wrote:

                > http://vim.sourceforge.net/tips/tip.php?tip_id=246 (What to know, and
                > where to look for help, when using Unicode in gvim)

                Setting the termencoding to iso-8859-2 solved the problem.

                Ionutz
              • Antoine J. Mechelynck
                ... The right way is what works for you. See :help iminsert about switching between East-Asian IM, keymap, and neither. HTH, Tony.
                Message 7 of 7 , Mar 1 3:04 AM
                • 0 Attachment
                  Ionutz Borcoman <borco@...> wrote:
                  > Antoine J. Mechelynck wrote:
                  >
                  > > http://vim.sourceforge.net/tips/tip.php?tip_id=246 (What to
                  > > know, and where to look for help, when using Unicode in gvim)
                  >
                  > Setting the termencoding to iso-8859-2 solved the problem.
                  >
                  > Ionutz

                  Ionutz Borcoman <borco@...> wrote:
                  > > Antoine J. Mechelynck wrote:
                  > > > Ionutz Borcoman <borco@...> wrote:
                  > > >
                  > > > I'm not sure what you call "Romanian IME". (I thought IM were
                  > > > only for languages like Chinese, Japanese and Korean.) If you
                  > > > mean the same thing as what I call the "International Keyboard"
                  > > > application, then I can tell you that Vim is not aware of it.
                  > >
                  > > Yep, it was my mistake. I was thinking at the Romanian keyboard.
                  > >
                  > > What I would like to have is to be able to rotate the keyboards from
                  > > EN->RO->Japanese->EN when I press ALT-SPACE (I whant to be able to
                  > > edit files that contain both Japanese and Romanian characters). I
                  > > can do this
                  > > in Notepad, and I was curious if I can do it in VIM.
                  > >
                  > > I have attached my custom _vimrc to the e-mail. The script called
                  > > in it
                  > > is one of those you were talking about:
                  > >
                  > > http://vim.sourceforge.net/scripts/script.php?script_id=789
                  > >
                  > > I have also done my own romanian keymap, that does the translation
                  > > between what the vim receives and what I was expecting it to
                  > > receive,
                  > > but I'm not sure yet that this is the 'right way'.
                  > >
                  > > TIA,
                  > >
                  > > Ionutz
                  > >
                  >
                  >
                  >
                  > > source $VIM\_vimrc
                  > >
                  > > runtime scripts/set_utf8.vim
                  > > set guifont=courier_new:h10


                  The "right way" is what works for you. See ":help 'iminsert'" about
                  switching between East-Asian IM, keymap, and neither.

                  HTH,
                  Tony.
                Your message has been successfully submitted and would be delivered to recipients shortly.