Loading ...
Sorry, an error occurred while loading the content.
 

Vim Clipboard Copy

Expand Messages
  • Mike Woratzeck
    I am running Vim on Windows 2000. In Vim 5.7, if I hilighted a portion of text using any mouse method, = that text was automatically placed in my clipboard
    Message 1 of 8 , Jan 7, 2004
      I am running Vim on Windows 2000.

      In Vim 5.7, if I hilighted a portion of text using any mouse method, =
      that text was automatically placed in my clipboard such that if I =
      subsequently pressed the middle mouse button, or did a RMB paste, the =
      hilighted text was pasted.

      In Vim 6.2, the hilighted text is no longer automatically placed in my =
      clipboard. I have to take the extra step of doing an RMB copy.

      I've read the documentation and faqs and can't find what controls this. =
      I thought it might be ":behave xterm" or ":behave mswin", but they do =
      not seem to be it.

      Has anyone else noticed this? Do you have a way to return to the 5.7 =
      behavior for this?

      Thanks,

      Mike
    • Neil Bird
      Around about 07/01/2004 16:45, Mike Woratzeck typed ... ... What platform, and to where are you trying to paste? -- [neil@fnx ~]# rm -f .signature [neil@fnx
      Message 2 of 8 , Jan 7, 2004
        Around about 07/01/2004 16:45, Mike Woratzeck typed ...
        > In Vim 6.2, the hilighted text is no longer automatically placed in my =
        > clipboard. I have to take the extra step of doing an RMB copy.

        What platform, and to where are you trying to paste?

        --
        [neil@fnx ~]# rm -f .signature
        [neil@fnx ~]# ls -l .signature
        ls: .signature: No such file or directory
        [neil@fnx ~]# exit
      • Neil Bird
        Around about 07/01/2004 16:51, Neil Bird typed ... ... I am an idiot :) Scratch the first bit (W2K) - but the second bit stands. Do you want set
        Message 3 of 8 , Jan 7, 2004
          Around about 07/01/2004 16:51, Neil Bird typed ...
          > What platform, and to where are you trying to paste?

          I am an idiot :) Scratch the first bit (W2K) - but the second bit
          stands.

          Do you want 'set guioptions+=a' ?

          --
          [neil@fnx ~]# rm -f .signature
          [neil@fnx ~]# ls -l .signature
          ls: .signature: No such file or directory
          [neil@fnx ~]# exit
        • Antoine J. Mechelynck
          ... see ... and see also what it resends to HTH, Tony.
          Message 4 of 8 , Jan 7, 2004
            Mike Woratzeck <mworatzeck@...> wrote:
            > I am running Vim on Windows 2000.
            >
            > In Vim 5.7, if I hilighted a portion of text using any mouse method, =
            > that text was automatically placed in my clipboard such that if I =
            > subsequently pressed the middle mouse button, or did a RMB paste, the
            > = hilighted text was pasted.
            >
            > In Vim 6.2, the hilighted text is no longer automatically placed in
            > my = clipboard. I have to take the extra step of doing an RMB copy.
            >
            > I've read the documentation and faqs and can't find what controls
            > this. = I thought it might be ":behave xterm" or ":behave mswin",
            > but they do = not seem to be it.
            >
            > Has anyone else noticed this? Do you have a way to return to the 5.7
            > = behavior for this?
            >
            > Thanks,
            >
            > Mike

            :set clipboard=autoselect

            see
            :help 'clipboard'

            and see also what it resends to

            HTH,
            Tony.
          • Mike Woratzeck
            Neil, set guioptions+=a did it! Where did you find this? I checked the doc and although several guioptions are described, a isn t. I can now hilight any
            Message 5 of 8 , Jan 7, 2004
              Neil,

              set guioptions+=a
              did it! Where did you find this? I checked the doc and although several
              guioptions are described, 'a' isn't.

              I can now hilight any region of text using any mouse technique (with no RMB
              Copy), and then move the
              insertion point somewhere else, and press the MMB and it pastes! This saves
              having to do all those
              RMB Copy's when 99.9999% of the time a copy is what you want to do. And if
              you wanted to Cut,
              you can still RMB Cut.

              If anyone else uses this, watch out for one thing. If you hilight (as
              above), then hit / or ? and MMB
              to paste your highlighted selection. It will work, but it also hilights
              everything from your original position
              to the first found instance of the search string. To avoid this behavior,
              do the / or ? first, then hilight
              and MMB.

              Thanks a lot!

              Mike



              ----- Original Message -----
              From: "Neil Bird" <neil@...>
              To: "Vim Mailing List" <vim@...>
              Sent: Wednesday, January 07, 2004 11:55 AM
              Subject: Re: Vim Clipboard Copy


              > Around about 07/01/2004 16:51, Neil Bird typed ...
              > > What platform, and to where are you trying to paste?
              >
              > I am an idiot :) Scratch the first bit (W2K) - but the second bit
              > stands.
              >
              > Do you want 'set guioptions+=a' ?
              >
            • Mike Woratzeck
              Antoine, ... but not what I was looking for. Neil Bird came up with an answer. Thanks anyway, Mike ... From: Antoine J. Mechelynck
              Message 6 of 8 , Jan 7, 2004
                Antoine,

                This did not seem to help, but I did get some different behavior with:
                :set clipboard=autoselect,unnamed
                but not what I was looking for. Neil Bird came up with an answer.
                Thanks anyway,

                Mike

                ----- Original Message -----
                From: "Antoine J. Mechelynck" <antoine.mechelynck@...>
                To: "Mike Woratzeck" <mworatzeck@...>; <vim@...>
                Sent: Wednesday, January 07, 2004 12:21 PM
                Subject: Re: Vim Clipboard Copy


                > Mike Woratzeck <mworatzeck@...> wrote:
                > > I am running Vim on Windows 2000.
                > >
                > > In Vim 5.7, if I hilighted a portion of text using any mouse method, =
                > > that text was automatically placed in my clipboard such that if I =
                > > subsequently pressed the middle mouse button, or did a RMB paste, the
                > > = hilighted text was pasted.
                > >
                > > In Vim 6.2, the hilighted text is no longer automatically placed in
                > > my = clipboard. I have to take the extra step of doing an RMB copy.
                > >
                > > I've read the documentation and faqs and can't find what controls
                > > this. = I thought it might be ":behave xterm" or ":behave mswin",
                > > but they do = not seem to be it.
                > >
                > > Has anyone else noticed this? Do you have a way to return to the 5.7
                > > = behavior for this?
                > >
                > > Thanks,
                > >
                > > Mike
                >
                > :set clipboard=autoselect
                >
                > see
                > :help 'clipboard'
                >
                > and see also what it resends to
                >
                > HTH,
                > Tony.
                >
              • Antoine J. Mechelynck
                ... Under :help clipboard , the autoselect paragraph resends to :help guioptions_a where you should have found just what Neil told you. Do you by any
                Message 7 of 8 , Jan 7, 2004
                  Mike Woratzeck <mworatzeck@...> wrote:
                  > Antoine,
                  >
                  > This did not seem to help, but I did get some different behavior with:
                  > :set clipboard=autoselect,unnamed
                  > but not what I was looking for. Neil Bird came up with an answer.
                  > Thanks anyway,
                  >
                  > Mike

                  Under :help 'clipboard', the "autoselect" paragraph resends to ":help
                  guioptions_a" where you should have found just what Neil told you. Do you by
                  any chance have a set of runtime files that are out of step with your
                  executable?

                  I uise gvim 6.2.170 for Win32 and my options.txt is dated 2003 Dec 20.

                  For Linux systems using rpm packages (like RedHat and SuSE), you can check
                  the versions of your installed vim packages by entering (in the shell)

                  rpm -a | grep vim

                  There should be a package named vim-common and also one or more of
                  vim-minimal, vim-enhanced and vim-x11. The name of each package is followed
                  by letters and numbers, which include the architecture (for instance, noarch
                  or i386) the version (such as 6.2) and the patchlevel (which comes
                  immediately after the version). Check that version and patchevel are the
                  same for all the installed vim packages. If they aren't, then your vim
                  packages are out of step with each other, a condition that IMHO ought to be
                  remedied.

                  Best regards,
                  Tony.
                • Mike Woratzeck
                  Antoine, I see it now. I was looking at the online help http://vimdoc.sourceforge.net/dion/vimum.html and could not find it there. Thank you, Mike ... From:
                  Message 8 of 8 , Jan 7, 2004
                    Antoine,

                    I see it now. I was looking at the online help
                    http://vimdoc.sourceforge.net/dion/vimum.html and
                    could not find it there.

                    Thank you,
                    Mike

                    ----- Original Message -----
                    From: "Antoine J. Mechelynck" <antoine.mechelynck@...>
                    To: "Mike Woratzeck" <mworatzeck@...>; "Vim Mailing List"
                    <vim@...>
                    Sent: Wednesday, January 07, 2004 3:26 PM
                    Subject: Re: Vim Clipboard Copy


                    > Mike Woratzeck <mworatzeck@...> wrote:
                    > > Antoine,
                    > >
                    > > This did not seem to help, but I did get some different behavior with:
                    > > :set clipboard=autoselect,unnamed
                    > > but not what I was looking for. Neil Bird came up with an answer.
                    > > Thanks anyway,
                    > >
                    > > Mike
                    >
                    > Under :help 'clipboard', the "autoselect" paragraph resends to ":help
                    > guioptions_a" where you should have found just what Neil told you. Do you
                    by
                    > any chance have a set of runtime files that are out of step with your
                    > executable?
                    >
                    > I uise gvim 6.2.170 for Win32 and my options.txt is dated 2003 Dec 20.
                    >
                    > For Linux systems using rpm packages (like RedHat and SuSE), you can check
                    > the versions of your installed vim packages by entering (in the shell)
                    >
                    > rpm -a | grep vim
                    >
                    > There should be a package named vim-common and also one or more of
                    > vim-minimal, vim-enhanced and vim-x11. The name of each package is
                    followed
                    > by letters and numbers, which include the architecture (for instance,
                    noarch
                    > or i386) the version (such as 6.2) and the patchlevel (which comes
                    > immediately after the version). Check that version and patchevel are the
                    > same for all the installed vim packages. If they aren't, then your vim
                    > packages are out of step with each other, a condition that IMHO ought to
                    be
                    > remedied.
                    >
                    > Best regards,
                    > Tony.
                    >
                    >
                  Your message has been successfully submitted and would be delivered to recipients shortly.