Loading ...
Sorry, an error occurred while loading the content.

Re: unset listchars?

Expand Messages
  • Benji Fisher
    ... [snip] ... Then, you can repeat the command, which is pretty easy with command-line completion, to toggle the list option. If you do not use
    Message 1 of 4 , Jan 2, 2004
    • 0 Attachment
      On Fri, Jan 02, 2004 at 02:25:26PM +0100, Stefan Roemer wrote:
      > On Fri, Jan 02, 2004, David Vaartjes wrote:
      [snip]
      > > Is there an option to "uset" the "listchars"? I've tried
      > > "set nolistchars" but that wont work. Does someone have
      > > a "trick" for this one ?
      >
      > This one does the trick:
      >
      > :set nolist

      Here is a little variant:

      :set list!

      Then, you can repeat the command, which is pretty easy with command-line
      completion, to toggle the 'list' option. If you do not use Command-line
      mode in between, you can repeat it with @: (starting in Normal mode).

      :help 'list'
      :help single-repeat
      :help c_<Up>

      HTH --Benji Fisher
    • Michael Naumann
      ... From what you write, I guess you are using vim, not gvim. Consider ... this way, you won t have to worry about this any longer and no need to toggle list
      Message 2 of 4 , Jan 2, 2004
      • 0 Attachment
        On Friday 02 January 2004 14:14, David Vaartjes wrote:
        > Hello list,
        >
        > I use the very handy vi "listchars" option as follows:
        > set listchars=tab:»·,trail:·
        >
        > For example, when this option is set, my code will look
        > like this:
        >
        > < 164 lines snipped>
        > 165 foreach ($i = 0; $i < scalar(@$nessusIDs); $i++)
        > 166 {
        > 167 »····if ($i eq 0)
        > 168 »····{
        > 169 »····»····$nessusIDsString = "\'@$nessusIDs[$i]\'";
        > 170 »····}else
        > < .. snip..>
        >
        > When I want to copy&paste certain lines of code, the "»·"
        > listcharacters will be copied as well (as you can see).
        > Is there an option to "uset" the "listchars"? I've tried
        > "set nolistchars" but that wont work. Does someone have
        > a "trick" for this one ?
        >
        > Thanks in advance,
        >
        > David

        From what you write, I guess you are using vim, not gvim.
        Consider
        :set mouse=nvi

        this way, you won't have to worry about this any longer and
        no need to toggle list before yanking.

        HTH, Michael
      Your message has been successfully submitted and would be delivered to recipients shortly.