Loading ...
Sorry, an error occurred while loading the content.
 

E33: No previous substitute regular expression

Expand Messages
  • Mike Blocker
    I ve used Vim for years but I recently reloaded my Windows XP machine and upgraded to Vim 6.2. For some reason, I now get the following message: E33: No
    Message 1 of 13 , Nov 26, 2003
      I've used Vim for years but I recently reloaded my Windows XP machine and
      upgraded to Vim 6.2. For some reason, I now get the following message:

      E33: No previous substitute regular expression

      repeated 3 times every time I edit a file. I've tried switching to the
      example _gvimrc and _vimrc files, but that didn't help.

      Any ideas?

      Thanks,

      Mike
    • Gary Holloway
      Try starting with: vim -u NONE -U NONE If that comes up clean, then it s definitely someting in the config files. g / FROM: Mike Blocker
      Message 2 of 13 , Nov 26, 2003
        Try starting with:

        vim -u NONE -U NONE

        If that comes up clean, then it's definitely someting in the config files.

        g

        / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:11 2003
        | ABOUT: E33: No previous substitute regular expression
        |
        | I've used Vim for years but I recently reloaded my Windows XP machine and
        | upgraded to Vim 6.2. For some reason, I now get the following message:
        |
        | E33: No previous substitute regular expression
        |
        | repeated 3 times every time I edit a file. I've tried switching to the
        | example _gvimrc and _vimrc files, but that didn't help.
        |
        | Any ideas?
        |
        | Thanks,
        |
        | Mike
        |
        \ END: "Mike Blocker"
      • Mike Blocker
        gvim -u NONE works okay, but when I run syntax on the 3 messages pop up. ... From: Gary Holloway [mailto:gary@castandcrew.com] Sent: Wednesday, November
        Message 3 of 13 , Nov 26, 2003
          "gvim -u NONE" works okay, but when I run "syntax on" the 3 messages pop up.

          -----Original Message-----
          From: Gary Holloway [mailto:gary@...]
          Sent: Wednesday, November 26, 2003 12:20 PM
          To: Mike Blocker; vim@...
          Subject: Re: E33: No previous substitute regular expression


          Try starting with:

          vim -u NONE -U NONE

          If that comes up clean, then it's definitely someting in the config files.

          g

          / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:11 2003
          | ABOUT: E33: No previous substitute regular expression
          |
          | I've used Vim for years but I recently reloaded my Windows XP machine
          | and upgraded to Vim 6.2. For some reason, I now get the following
          | message:
          |
          | E33: No previous substitute regular expression
          |
          | repeated 3 times every time I edit a file. I've tried switching to
          | the example _gvimrc and _vimrc files, but that didn't help.
          |
          | Any ideas?
          |
          | Thanks,
          |
          | Mike
          |
          \ END: "Mike Blocker"
        • Gary Holloway
          When you say edit a file , is it always the same type of file (i.e., file extentsion)? Sounds like there s a problem with the syntax file for the particular
          Message 4 of 13 , Nov 26, 2003
            When you say "edit a file", is it always the same type of file (i.e.,
            file extentsion)? Sounds like there's a problem with the syntax file
            for the particular syntax that's being associated with the file you're
            editing.

            Try editing a "plain" file (e.g., "foo".

            g

            / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
            | ABOUT: RE: E33: No previous substitute regular expression
            |
            | "gvim -u NONE" works okay, but when I run "syntax on" the 3 messages pop up.
            |
            | -----Original Message-----
            | From: Gary Holloway [mailto:gary@...]
            | Sent: Wednesday, November 26, 2003 12:20 PM
            | To: Mike Blocker; vim@...
            | Subject: Re: E33: No previous substitute regular expression
            |
            | Try starting with:
            |
            | vim -u NONE -U NONE
            |
            | If that comes up clean, then it's definitely someting in the config files.
            |
            | g
            |
            | / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:11 2003
            | | ABOUT: E33: No previous substitute regular expression
            | |
            | | I've used Vim for years but I recently reloaded my Windows XP machine
            | | and upgraded to Vim 6.2. For some reason, I now get the following
            | | message:
            | |
            | | E33: No previous substitute regular expression
            | |
            | | repeated 3 times every time I edit a file. I've tried switching to
            | | the example _gvimrc and _vimrc files, but that didn't help.
            | |
            | | Any ideas?
            | |
            | | Thanks,
            | |
            | | Mike
            | |
            | \ END: "Mike Blocker"
            |
            |
            \ END: "Mike Blocker"
          • Mike Blocker
            It happens with all file types, extention or not. Even a new empty file creates the messages. ... From: Gary Holloway [mailto:gary@castandcrew.com] Sent:
            Message 5 of 13 , Nov 26, 2003
              It happens with all file types, extention or not. Even a new empty file
              creates the messages.

              -----Original Message-----
              From: Gary Holloway [mailto:gary@...]
              Sent: Wednesday, November 26, 2003 12:47 PM
              To: Mike Blocker; vim@...
              Subject: RE: E33: No previous substitute regular expression


              When you say "edit a file", is it always the same type of file (i.e., file
              extentsion)? Sounds like there's a problem with the syntax file for the
              particular syntax that's being associated with the file you're editing.

              Try editing a "plain" file (e.g., "foo".

              g

              / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
              | ABOUT: RE: E33: No previous substitute regular expression
              |
              | "gvim -u NONE" works okay, but when I run "syntax on" the 3 messages
              | pop up.
              |
              | -----Original Message-----
              | From: Gary Holloway [mailto:gary@...]
              | Sent: Wednesday, November 26, 2003 12:20 PM
              | To: Mike Blocker; vim@...
              | Subject: Re: E33: No previous substitute regular expression
              |
              | Try starting with:
              |
              | vim -u NONE -U NONE
              |
              | If that comes up clean, then it's definitely someting in the config
              | files.
              |
              | g
              |
              | / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:11 2003
              | | ABOUT: E33: No previous substitute regular expression
              | |
              | | I've used Vim for years but I recently reloaded my Windows XP
              | | machine
              | | and upgraded to Vim 6.2. For some reason, I now get the following
              | | message:
              | |
              | | E33: No previous substitute regular expression
              | |
              | | repeated 3 times every time I edit a file. I've tried switching to
              | | the example _gvimrc and _vimrc files, but that didn't help.
              | |
              | | Any ideas?
              | |
              | | Thanks,
              | |
              | | Mike
              | |
              | \ END: "Mike Blocker"
              |
              |
              \ END: "Mike Blocker"
            • Keith Roberts
              Sounds to me like there s an autocommand for BufCreate (or the like) which is causing something to be sourced that does a :s//something/ ???
              Message 6 of 13 , Nov 26, 2003
                Sounds to me like there's an autocommand for BufCreate (or the like) which
                is causing something to be sourced that does a :s//something/ ???

                >-----Original Message-----
                >From: Mike Blocker [mailto:mrb123@...]
                >Sent: Wednesday, November 26, 2003 11:13 AM
                >To: vim@...
                >Subject: RE: E33: No previous substitute regular expression
                >
                >It happens with all file types, extention or not. Even a new empty file
                >creates the messages.
                >
                >-----Original Message-----
                >From: Gary Holloway [mailto:gary@...]
                >Sent: Wednesday, November 26, 2003 12:47 PM
                >To: Mike Blocker; vim@...
                >Subject: RE: E33: No previous substitute regular expression
                >
                >
                >When you say "edit a file", is it always the same type of file (i.e., file
                >extentsion)? Sounds like there's a problem with the syntax file for the
                >particular syntax that's being associated with the file you're editing.
                >
                >Try editing a "plain" file (e.g., "foo".
                >
                >g
                >
                >/ FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
                >| ABOUT: RE: E33: No previous substitute regular expression
                >|
                >| "gvim -u NONE" works okay, but when I run "syntax on" the 3 messages
                >| pop up.
                >|
                >| -----Original Message-----
                >| From: Gary Holloway [mailto:gary@...]
                >| Sent: Wednesday, November 26, 2003 12:20 PM
                >| To: Mike Blocker; vim@...
                >| Subject: Re: E33: No previous substitute regular expression
                >|
                >| Try starting with:
                >|
                >| vim -u NONE -U NONE
                >|
                >| If that comes up clean, then it's definitely someting in the config
                >| files.
                >|
                >| g
                >|
                >| / FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:11 2003
                >| | ABOUT: E33: No previous substitute regular expression
                >| |
                >| | I've used Vim for years but I recently reloaded my Windows XP
                >| | machine
                >| | and upgraded to Vim 6.2. For some reason, I now get the following
                >| | message:
                >| |
                >| | E33: No previous substitute regular expression
                >| |
                >| | repeated 3 times every time I edit a file. I've tried switching to
                >| | the example _gvimrc and _vimrc files, but that didn't help.
                >| |
                >| | Any ideas?
                >| |
                >| | Thanks,
                >| |
                >| | Mike
                >| |
                >| \ END: "Mike Blocker"
                >|
                >|
                >\ END: "Mike Blocker"
                >
              • Gary Johnson
                ... Looks like it s time for verbose . Execute ... before executing syntax on and see what s being executed when those error messages appear. ... For gvim,
                Message 7 of 13 , Nov 26, 2003
                  On 2003-11-26, Keith Roberts <kroberts@...> wrote:
                  > Sounds to me like there's an autocommand for BufCreate (or the like) which
                  > is causing something to be sourced that does a :s//something/ ???

                  Looks like it's time for 'verbose'. Execute

                  :set verbose=15

                  before executing "syntax on" and see what's being executed when
                  those error messages appear.

                  > >| From: Gary Holloway [mailto:gary@...]
                  > >| Sent: Wednesday, November 26, 2003 12:20 PM
                  > >| To: Mike Blocker; vim@...
                  > >| Subject: Re: E33: No previous substitute regular expression
                  > >|
                  > >| Try starting with:
                  > >|
                  > >| vim -u NONE -U NONE

                  > >/ FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
                  > >| ABOUT: RE: E33: No previous substitute regular expression
                  > >|
                  > >| "gvim -u NONE" works okay, but when I run "syntax on" the 3 messages
                  > >| pop up.

                  For gvim, "-u NONE" may not be sufficient. Use "-U NONE" as well to
                  avoid loading any .gvimrc.

                  HTH,
                  Gary

                  --
                  Gary Johnson | Agilent Technologies
                  garyjohn@... | Wireless Division
                  | Spokane, Washington, USA
                • Mike Blocker
                  verbose=15 created too many messages causing the applicable messages to scoll off. Verbose=14 showed the error messages issued right after: autocommand call
                  Message 8 of 13 , Nov 26, 2003
                    verbose=15 created too many messages causing the applicable messages to
                    scoll off. Verbose=14 showed the error messages issued right after:

                    autocommand call s:SynSet()
                    calling function <SNR>3_SynSet()
                    function <SNR>3_SynSet returning #0
                    continuing in Syntax Auto commands for "*"


                    -----Original Message-----
                    From: Gary Johnson [mailto:garyjohn@...]
                    Sent: Wednesday, November 26, 2003 1:31 PM
                    To: vim@...
                    Subject: Re: E33: No previous substitute regular expression


                    On 2003-11-26, Keith Roberts <kroberts@...> wrote:
                    > Sounds to me like there's an autocommand for BufCreate (or the like)
                    > which is causing something to be sourced that does a :s//something/
                    > ???

                    Looks like it's time for 'verbose'. Execute

                    :set verbose=15

                    before executing "syntax on" and see what's being executed when those error
                    messages appear.

                    > >| From: Gary Holloway [mailto:gary@...]
                    > >| Sent: Wednesday, November 26, 2003 12:20 PM
                    > >| To: Mike Blocker; vim@...
                    > >| Subject: Re: E33: No previous substitute regular expression
                    > >|
                    > >| Try starting with:
                    > >|
                    > >| vim -u NONE -U NONE

                    > >/ FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
                    > >| ABOUT: RE: E33: No previous substitute regular expression
                    > >|
                    > >| "gvim -u NONE" works okay, but when I run "syntax on" the 3
                    > >| messages pop up.

                    For gvim, "-u NONE" may not be sufficient. Use "-U NONE" as well to avoid
                    loading any .gvimrc.

                    HTH,
                    Gary

                    --
                    Gary Johnson | Agilent Technologies
                    garyjohn@... | Wireless Division
                    | Spokane, Washington, USA
                  • Keith Roberts
                    Use :redir to put the messages to a file/buffer for later examination.
                    Message 9 of 13 , Nov 26, 2003
                      Use :redir to put the messages to a file/buffer for later examination.


                      >-----Original Message-----
                      >From: Mike Blocker [mailto:mrb123@...]
                      >Sent: Wednesday, November 26, 2003 12:04 PM
                      >To: vim@...
                      >Subject: RE: E33: No previous substitute regular expression
                      >
                      >verbose=15 created too many messages causing the applicable messages to
                      >scoll off. Verbose=14 showed the error messages issued right after:
                      >
                      >autocommand call s:SynSet()
                      >calling function <SNR>3_SynSet()
                      >function <SNR>3_SynSet returning #0
                      >continuing in Syntax Auto commands for "*"
                      >
                      >
                      >-----Original Message-----
                      >From: Gary Johnson [mailto:garyjohn@...]
                      >Sent: Wednesday, November 26, 2003 1:31 PM
                      >To: vim@...
                      >Subject: Re: E33: No previous substitute regular expression
                      >
                      >
                      >On 2003-11-26, Keith Roberts <kroberts@...> wrote:
                      >> Sounds to me like there's an autocommand for BufCreate (or the like)
                      >> which is causing something to be sourced that does a :s//something/
                      >> ???
                      >
                      >Looks like it's time for 'verbose'. Execute
                      >
                      > :set verbose=15
                      >
                      >before executing "syntax on" and see what's being executed when those error
                      >messages appear.
                      >
                      >> >| From: Gary Holloway [mailto:gary@...]
                      >> >| Sent: Wednesday, November 26, 2003 12:20 PM
                      >> >| To: Mike Blocker; vim@...
                      >> >| Subject: Re: E33: No previous substitute regular expression
                      >> >|
                      >> >| Try starting with:
                      >> >|
                      >> >| vim -u NONE -U NONE
                      >
                      >> >/ FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
                      >> >| ABOUT: RE: E33: No previous substitute regular expression
                      >> >|
                      >> >| "gvim -u NONE" works okay, but when I run "syntax on" the 3
                      >> >| messages pop up.
                      >
                      >For gvim, "-u NONE" may not be sufficient. Use "-U NONE" as well to avoid
                      >loading any .gvimrc.
                      >
                      >HTH,
                      >Gary
                      >
                      >--
                      >Gary Johnson | Agilent Technologies
                      >garyjohn@... | Wireless Division
                      > | Spokane, Washington, USA
                    • Mike Blocker
                      continuing in function 3_SynSet Searching for C: Program Files vim/vimfiles/after syntax/help.vim Searching for
                      Message 10 of 13 , Nov 26, 2003
                        continuing in function <SNR>3_SynSet
                        Searching for "C:\Program Files\vim/vimfiles/after\syntax/help.vim"
                        Searching for "C:\Docume~1\Admini~1\MyDocu~1/vimfiles/after\syntax/help.vim"
                        line 24: " endif

                        line 25: endif

                        function <SNR>3_SynSet returning #0

                        continuing in Syntax Auto commands for "*"

                        line 41: if !s:did_ft

                        line 42: doautoall filetypedetect BufRead

                        E33: No previous substitute regular expression
                        E33: No previous substitute regular expression
                        E33: No previous substitute regular expression

                        -----Original Message-----
                        From: Keith Roberts [mailto:kroberts@...]
                        Sent: Wednesday, November 26, 2003 2:11 PM
                        To: 'Mike Blocker'; vim@...
                        Subject: RE: E33: No previous substitute regular expression


                        Use :redir to put the messages to a file/buffer for later examination.


                        >-----Original Message-----
                        >From: Mike Blocker [mailto:mrb123@...]
                        >Sent: Wednesday, November 26, 2003 12:04 PM
                        >To: vim@...
                        >Subject: RE: E33: No previous substitute regular expression
                        >
                        >verbose=15 created too many messages causing the applicable messages to
                        >scoll off. Verbose=14 showed the error messages issued right after:
                        >
                        >autocommand call s:SynSet()
                        >calling function <SNR>3_SynSet()
                        >function <SNR>3_SynSet returning #0
                        >continuing in Syntax Auto commands for "*"
                        >
                        >
                        >-----Original Message-----
                        >From: Gary Johnson [mailto:garyjohn@...]
                        >Sent: Wednesday, November 26, 2003 1:31 PM
                        >To: vim@...
                        >Subject: Re: E33: No previous substitute regular expression
                        >
                        >
                        >On 2003-11-26, Keith Roberts <kroberts@...> wrote:
                        >> Sounds to me like there's an autocommand for BufCreate (or the like)
                        >> which is causing something to be sourced that does a :s//something/
                        >> ???
                        >
                        >Looks like it's time for 'verbose'. Execute
                        >
                        > :set verbose=15
                        >
                        >before executing "syntax on" and see what's being executed when those
                        >error messages appear.
                        >
                        >> >| From: Gary Holloway [mailto:gary@...]
                        >> >| Sent: Wednesday, November 26, 2003 12:20 PM
                        >> >| To: Mike Blocker; vim@...
                        >> >| Subject: Re: E33: No previous substitute regular expression
                        >> >|
                        >> >| Try starting with:
                        >> >|
                        >> >| vim -u NONE -U NONE
                        >
                        >> >/ FROM: "Mike Blocker" <mrb123@...>, Nov 26 12:39 2003
                        >> >| ABOUT: RE: E33: No previous substitute regular expression
                        >> >|
                        >> >| "gvim -u NONE" works okay, but when I run "syntax on" the 3
                        >> >| messages pop up.
                        >
                        >For gvim, "-u NONE" may not be sufficient. Use "-U NONE" as well to
                        >avoid loading any .gvimrc.
                        >
                        >HTH,
                        >Gary
                        >
                        >--
                        >Gary Johnson | Agilent Technologies
                        >garyjohn@... | Wireless Division
                        > | Spokane, Washington, USA
                      • Gary Johnson
                        ... I don t know. It seems odd to me that there is no :ex command printed along with those errors. Nevertheless, I fired up gvim 6.2 on my Windows2000 box as
                        Message 11 of 13 , Nov 26, 2003
                          On 2003-11-26, Mike Blocker <mrb123@...> wrote:
                          > continuing in function <SNR>3_SynSet
                          > Searching for "C:\Program Files\vim/vimfiles/after\syntax/help.vim"
                          > Searching for "C:\Docume~1\Admini~1\MyDocu~1/vimfiles/after\syntax/help.vim"
                          > line 24: " endif
                          >
                          > line 25: endif
                          >
                          > function <SNR>3_SynSet returning #0
                          >
                          > continuing in Syntax Auto commands for "*"
                          >
                          > line 41: if !s:did_ft
                          >
                          > line 42: doautoall filetypedetect BufRead
                          >
                          > E33: No previous substitute regular expression
                          > E33: No previous substitute regular expression
                          > E33: No previous substitute regular expression

                          I don't know. It seems odd to me that there is no :ex command
                          printed along with those errors. Nevertheless, I fired up gvim 6.2
                          on my Windows2000 box as

                          gvim -N -u NONE -U NONE

                          then executed

                          :set verbose=15
                          :redir @a
                          :syn on
                          :redir END

                          and pasted "a into the buffer. In the region you captured above, I
                          have:

                          ------------------------------------------------------------------------

                          line 24: " endif

                          line 25: endif

                          function <SNR>3_SynSet returning #0

                          continuing in Syntax Auto commands for "*"

                          line 41: if !s:did_ft

                          line 42: doautoall filetypedetect BufRead

                          Executing BufRead Auto commands for "*"
                          autocommand if !did_filetype() && expand("<amatch>") !~ g:ft_ignore_pat | runtime! scripts.vim | endif

                          line 0: if !did_filetype() && expand("<amatch>") !~ g:ft_ignore_pat | runtime! scripts.vim | endif

                          line 0: runtime! scripts.vim | endif

                          Searching for "scripts.vim" in "C:\Documents and Settings\garyjohn/vimfiles,C:\Vim/vimfiles,C:\Vim\vim62,C:\Vim/vimfiles/after,C:\Documents and Settings\garyjohn/vimfiles/after"
                          Searching for "C:\Documents and Settings\garyjohn/vimfiles\scripts.vim"
                          Searching for "C:\Vim/vimfiles\scripts.vim"
                          Searching for "C:\Vim\vim62\scripts.vim"
                          line 0: sourcing "C:\Vim\vim62\scripts.vim"
                          line 1: " Vim support file to detect file types in scripts

                          ------------------------------------------------------------------------

                          I did not have any lines saying:

                          continuing in function <SNR>3_SynSet
                          Searching for "C:\Program Files\vim/vimfiles/after\syntax/help.vim"
                          Searching for "C:\Docume~1\Admini~1\MyDocu~1/vimfiles/after\syntax/help.vim"

                          So _maybe_ you have a private scripts.vim file that contains an
                          error, or _maybe_ you have a private filetype.vim with a BufRead
                          autocommand that contains an error, but without any better idea of
                          what command is causing those errors, it's difficult to say. I hope
                          someone else will catch something I'm not seeing.

                          Gary

                          --
                          Gary Johnson | Agilent Technologies
                          garyjohn@... | Wireless Division
                          | Spokane, Washington, USA
                        • Charles E Campbell
                          ... Try: *) vim -u NONE -U NONE somefile Hopefully your E33 will go away. If so, check out where-did-the-error-occur: *) vim -V somefile should be a bunch of
                          Message 12 of 13 , Nov 30, 2003
                            Mike Blocker wrote:

                            >I've used Vim for years but I recently reloaded my Windows XP machine and
                            >upgraded to Vim 6.2. For some reason, I now get the following message:
                            >
                            >E33: No previous substitute regular expression
                            >
                            >repeated 3 times every time I edit a file. I've tried switching to the
                            >example _gvimrc and _vimrc files, but that didn't help.
                            >
                            >
                            Try:
                            *) vim -u NONE -U NONE somefile
                            Hopefully your E33 will go away.
                            If so, check out where-did-the-error-occur:

                            *) vim -V somefile
                            should be a bunch of messages giving progress as Vim loads.
                            Hopefully you'll be able to figure out where the problem occurs.
                            If not, try even more verbose:

                            *) vim -V20 somefile

                            Regards,
                            Chip Campbell
                          • Mike Blocker
                            It appears to be fixed. I was using a mangled 8.3 pathname to HOME (i.e. c: docume~1 admini~1 mydocu~1). And I think changing this to %USERPROFILE% My
                            Message 13 of 13 , Dec 1, 2003
                              It appears to be fixed. I was using a mangled 8.3 pathname to HOME (i.e.
                              c:\docume~1\admini~1\mydocu~1). And I think changing this to
                              %USERPROFILE%\My Documents fixed it. Unfortunately, I reinstalled vim and
                              removed a mangled directory from by PATH variable at the same time so I'm
                              not positive what fixed it (although I had tried reinstalling before). Now,
                              try as I may, I can't reproduce the error.
                            Your message has been successfully submitted and would be delivered to recipients shortly.