Loading ...
Sorry, an error occurred while loading the content.

Vim context.

Expand Messages
  • Diego Luis Kreutz
    Hi, I m a C developer. Recently I ve compiled vim6.2. Unfortunately there appears a window context at the top of the terminal. I don t like it. So, I would
    Message 1 of 6 , Nov 6, 2003
    • 0 Attachment
      Hi,

      I'm a C developer. Recently I've compiled vim6.2. Unfortunately there
      appears a "window" context at the top of the terminal. I don't like it.
      So, I would appreciate if someone could tell me how to turn off this
      feature? I've no special settings in my ~/.vimrc that could cause this
      behavior. I looked forward and just find out how to manipulate and
      configure this automatic context scroll "window". Maybe I didn't look
      enough through manuals and stuffs like that. But I would really be glad if
      someone could tell me and easy way to turn off this "Windows like
      automagic context system".

      Thanks,

      DLK
    • Charles E. Campbell
      ... I haven t any idea what you re talking about. May I suggest letting us know: What o/s are you using? vim or gvim? Does this context window appear with
      Message 2 of 6 , Nov 6, 2003
      • 0 Attachment
        On Thu, Nov 06, 2003 at 09:46:09AM -0200, Diego Luis Kreutz wrote:
        > I'm a C developer. Recently I've compiled vim6.2. Unfortunately there
        > appears a "window" context at the top of the terminal.
        ---------------------------------------------------------------------

        I haven't any idea what you're talking about. May I suggest
        letting us know:

        What o/s are you using?
        vim or gvim?

        Does this "context window" appear with
        vim -u NONE

        Are you talking about the menubar at the top of gvim?

        Regards,
        C Campbell

        --
        Charles E Campbell, Jr, PhD _ __ __
        Goddard Space Flight Center / /_/\_\_/ /
        cec@... /_/ \/_//_/
        PGP public key: http://www.erols.com/astronaut/pgp.html
      • Diego Luis Kreutz
        ... I just have been using vim. I m running Gentoo on my machine. Everything compiled from scratch. This context window doesn t appear with vim -u NONE. But
        Message 3 of 6 , Nov 6, 2003
        • 0 Attachment
          On Thu, 6 Nov 2003, Charles E. Campbell wrote:
          > On Thu, Nov 06, 2003 at 09:46:09AM -0200, Diego Luis Kreutz wrote:
          > > I'm a C developer. Recently I've compiled vim6.2. Unfortunately there
          > > appears a "window" context at the top of the terminal.
          > ---------------------------------------------------------------------
          >
          > I haven't any idea what you're talking about. May I suggest
          > letting us know:
          >
          > What o/s are you using?
          > vim or gvim?
          >
          > Does this "context window" appear with
          > vim -u NONE
          >
          > Are you talking about the menubar at the top of gvim?
          >
          I just have been using vim. I'm running Gentoo on my machine.
          Everything compiled from scratch.

          This "context window" doesn't appear with vim -u NONE. But then I've
          to setup all my macros, abbreviations, syntax settings and so on, by
          hand. Or is there a way to say at first NONE on ~/.vimrc and after
          put my settings?
          Without any thing on ~/.vimrc this "context window" still rises.

          Well, let my try to give a better example of what is this "context
          window".

          When I'm editing a file .c (C source code) after a few seconds rises a
          "new window" like the command :sp does. Actualy my terminal is "divided"
          in two views.

          For example, if I'm editing a file.c, after some seconds the "window"
          splits in two and it looks like:

          ******************************************************************************
          41:void escreve_arquivo (char *nome, tr_event_t *evento)
          57: if (evento->type == MESTRE_INICIA_ENVIO)
          67: else if(evento->type == MESTRE_TERMINA_ENVIO)
          74: else if(evento->type == MESTRE_INICIA_RECEPCAO)
          82: else if(evento->type == MESTRE_TERMINA_RECEPCAO)
          91: else if(evento->type == MESTRE_COMECA_DESENHAR)
          98: else if(evento->type == MESTRE_TERMINA_DESENHAR)
          105: else if (evento->type == MESTRE_MATA)
          114: else if(evento->type == ESCOLHE_TRABALHO)
          125: else if(evento->type == ESCRAVO_INICIA_ENVIO)
          --context-- 1,1 All
          // AGORA AS DO ESCRAVO
          else if(evento->type == ESCRAVO_INICIA_ENVIO) {
          frpintf(arquivo,"9 %s E n%d \"Escravo Manda\"\n",
          TEMPO, evento->node);
          fprintf(arquivo,"10 %s S n%d \"Bloqueado Enviando\"\n",
          TEMPO, evento->node);
          fprintf(arquivo,"18 %s L m LE n%d le%d\n",

          decodifica.c 126,2-9 36%
          *****************************************************************************

          As you can see, the upper part of the terminal is the automagic context
          wich shows code lines that are similar or have a relationship with the
          part of the code where I'm working on.

          Is there a way to set this context thing off? Is this a vim resource or
          a extra compilation set?

          Ops, I just figured out. This "context thing" is a vim plugin that I
          instaled with Gentoo's emerge system. It's called ctx. I removed it just
          right now and the "context window" disappeared.

          How do I tell to vim to use or not a plugin like this one? Without
          uninstall it.

          Thanks,

          DLK
        • Charles E. Campbell
          ... I m glad you found it -- I was going to ask if you had an errant plugin/ftplugin next as you found you had. If the plugin written in a more or less
          Message 4 of 6 , Nov 6, 2003
          • 0 Attachment
            On Thu, Nov 06, 2003 at 06:50:28PM -0200, Diego Luis Kreutz wrote:
            > On Thu, 6 Nov 2003, Charles E. Campbell wrote:
            > > On Thu, Nov 06, 2003 at 09:46:09AM -0200, Diego Luis Kreutz wrote:
            > > > I'm a C developer. Recently I've compiled vim6.2. Unfortunately there
            > > > appears a "window" context at the top of the terminal.
            > Is there a way to set this context thing off? Is this a vim resource or
            > a extra compilation set?
            >
            > Ops, I just figured out. This "context thing" is a vim plugin that I
            > instaled with Gentoo's emerge system. It's called ctx. I removed it just
            > right now and the "context window" disappeared.
            >
            > How do I tell to vim to use or not a plugin like this one? Without
            > uninstall it.
            ---------------------------------------------------------------------

            I'm glad you found it -- I was going to ask if you had an errant
            plugin/ftplugin next as you found you had.

            If the plugin written in a more or less standard fashion, and your
            <.vimrc> gets loaded first:

            let g:loaded_ctx= 1

            should prevent loading <ctx.vim> from your plugin directory. Actually
            what's being done here is to make the plugin think its already been
            loaded.

            Regards,
            Chip Campbell

            --
            Charles E Campbell, Jr, PhD _ __ __
            Goddard Space Flight Center / /_/\_\_/ /
            cec@... /_/ \/_//_/
            PGP public key: http://www.erols.com/astronaut/pgp.html
          • Michael Geddes
            Sounds like a plugin . Look in your runtime (:help runtime ) path for plugin or ftplugin directories - I suspect you ve got something set up there. Though
            Message 5 of 6 , Nov 6, 2003
            • 0 Attachment
              Sounds like a 'plugin'.

              Look in your 'runtime' (:help 'runtime') path for plugin or ftplugin
              directories - I suspect you've got something set up there. Though that's
              a bit weird.

              //.

              -----Original Message-----
              From: Diego Luis Kreutz [mailto:kreutz@...]
              Sent: Thursday, 6 November 2003 10:46 PM
              To: vim@...
              Subject: Vim context.



              Hi,

              I'm a C developer. Recently I've compiled vim6.2. Unfortunately there
              appears a "window" context at the top of the terminal. I don't like it.
              So, I would appreciate if someone could tell me how to turn off this
              feature? I've no special settings in my ~/.vimrc that could cause this
              behavior. I looked forward and just find out how to manipulate and
              configure this automatic context scroll "window". Maybe I didn't look
              enough through manuals and stuffs like that. But I would really be glad
              if
              someone could tell me and easy way to turn off this "Windows like
              automagic context system".

              Thanks,

              DLK
            • Antoine J. Mechelynck
              ... Another possibility (since IIUC it s not part of the vim distribution) is to move it to someplace it won t be automatically loaded, for instance to
              Message 6 of 6 , Nov 6, 2003
              • 0 Attachment
                Charles E. Campbell <cec@...> wrote:
                > On Thu, Nov 06, 2003 at 06:50:28PM -0200, Diego Luis Kreutz wrote:
                > > On Thu, 6 Nov 2003, Charles E. Campbell wrote:
                > > > On Thu, Nov 06, 2003 at 09:46:09AM -0200, Diego Luis Kreutz wrote:
                > > > > I'm a C developer. Recently I've compiled vim6.2. Unfortunately
                > > > > there appears a "window" context at the top of the terminal.
                > > Is there a way to set this context thing off? Is this a vim
                > > resource or a extra compilation set?
                > >
                > > Ops, I just figured out. This "context thing" is a vim plugin that I
                > > instaled with Gentoo's emerge system. It's called ctx. I removed it
                > > just right now and the "context window" disappeared.
                > >
                > > How do I tell to vim to use or not a plugin like this one? Without
                > > uninstall it.
                > ---------------------------------------------------------------------
                >
                > I'm glad you found it -- I was going to ask if you had an errant
                > plugin/ftplugin next as you found you had.
                >
                > If the plugin written in a more or less standard fashion, and your
                > <.vimrc> gets loaded first:
                >
                > let g:loaded_ctx= 1
                >
                > should prevent loading <ctx.vim> from your plugin directory. Actually
                > what's being done here is to make the plugin think its already been
                > loaded.
                >
                > Regards,
                > Chip Campbell
                >
                > --
                > Charles E Campbell, Jr, PhD _ __ __
                > Goddard Space Flight Center / /_/\_\_/ /
                > cec@... /_/ \/_//_/
                > PGP public key: http://www.erols.com/astronaut/pgp.html

                Another possibility (since IIUC it's not part of the vim distribution) is to
                move it to someplace it won't be automatically loaded, for instance to
                ~/vimfiles/scripts/ (for Windows, but in Vim notation) or ~/.vim/scripts/
                (for Unix). Then you could still invoke it with ":runtime scripts/ctx.vim"
                (without the quotes).

                Of course if you need Gentoo's emerge, and it relies on ctx.vim, then you
                have a problem.

                Regards,
                Tony.
              Your message has been successfully submitted and would be delivered to recipients shortly.