Loading ...
Sorry, an error occurred while loading the content.

Re: Dead keys

Expand Messages
  • Antoine J. Mechelynck
    ... AFAIK, Vim doesn t know anything about dead keys. Their use can result from two circumstances: (a) If your national keyboard includes dead keys (as mine
    Message 1 of 3 , Nov 4, 2003
    • 0 Attachment
      Steve Hall <digitect@...> wrote:
      > Can anyone point me to some info about dead keys? (Using preceeding ^,
      > ~, ', and ` to enable insertion of western European multi-byte chars.)
      > My Vim configuration apparently squashes gvim's usual default to use
      > them but I have no idea what to set or keep from setting to turn them
      > on.
      >
      > TIA.
      >
      > --
      > Steve Hall [ digitect@... ]

      AFAIK, Vim doesn't know anything about dead keys. Their use can result from
      two circumstances:

      (a) If your national keyboard includes dead keys (as mine does) they will
      remain functional in Vim. It will then take two keypresses before a letter
      such as ê or ü appears in Vim's input buffer. Your 'termencoding' (or, if
      &termencoding == "", your 'encoding') must correspond to what your keyboard
      driver is actually sending for all combinations of dead key + "live" key.
      This is usually achieved by either

      1°) not changing 'encoding' and 'termencoding' yourself, or

      2°) setting 'termencoding' explicitly to the old value of 'encoding'
      before you alter the latter. My short script set_utf8.vim,
      http://vim.sourceforge.net/scripts/script.php?script_id=789 , shows how to
      proceed when the target 'encoding' is utf-8. I suppose it can be easily
      adapted for other targets.

      (b) If you have defined mappings (including those defined by a keymap) whose
      {lhs} includes more than one character, all of those characters except the
      last one can be considered "dead keys". Vim will see them, and will show
      them at bottom right of your screen if 'showcmd' is on (which is the
      Vim-not-Vi default), but it will only act on them when you have typed the
      whole {lhs}, or when it becomes evident that what you are typing is not the
      {lhs} of any mapping.

      Regards,
      Tony.
    • Charles E. Campbell
      ... Vim doesn t have dead-keys, but it does have digraphs. See ... However, you may find the plugin of help. See
      Message 2 of 3 , Nov 4, 2003
      • 0 Attachment
        On Tue, Nov 04, 2003 at 10:02:10AM -0500, Steve Hall wrote:
        > Can anyone point me to some info about dead keys? (Using preceeding ^,
        > ~, ', and ` to enable insertion of western European multi-byte chars.)
        ---------------------------------------------------------------------

        Vim doesn't have dead-keys, but it does have digraphs. See

        :he i_ctrl-k

        However, you may find the <EasyAccents.vim> plugin of help. See

        http://vim.sourceforge.net/scripts/script.php?script_id=451

        It basically implements dead keys: ^o 'a `a :e etc.
        EasyAccents toggles on/off via use of the mapping \ea.

        Regards,
        Chip Campbell

        --
        Charles E Campbell, Jr, PhD _ __ __
        Goddard Space Flight Center / /_/\_\_/ /
        cec@... /_/ \/_//_/
        PGP public key: http://www.erols.com/astronaut/pgp.html
      Your message has been successfully submitted and would be delivered to recipients shortly.