Loading ...
Sorry, an error occurred while loading the content.

Re: Vim got frozen when dealing with long line?

Expand Messages
  • Dasn Cups
    ... Thanks for your tips. I did :%j this time, and it took about 5 minutes. Then I pressed , it took about 3 minutes to finish this work. CPU CeleronII
    Message 1 of 35 , Sep 30, 2003
    • 0 Attachment
      On Tue, Sep 30, 2003 at 09:39:52AM -0400, John Aldridge wrote:
      > At 03:20 09-30-2003, Dasn Cups wrote:
      >
      > >On Mon, Sep 29, 2003 at 08:44:58AM -1000, Marc Adler wrote:
      > >> > On Sun, Sep 28, 2003 at 08:54:39PM -1000, Marc Adler wrote: [...]
      > >> > > > But, that didn't do enough joins. I'm sure that this could be
      > >> > > > extended to get the desired results. But for casual typing, my
      > >> > > > original suggestion (repeated below) works quite nicely.
      > >> > > >
      > >> > > > :set tw=99999 gggqG
      > >> > > >
      > >> > > > And then back again:
      > >> > > >
      > >> > > > :set tw=78 gggqG
      > >> > >
      > >
      > >I tried these commands, but my Vim got crashed.
      > >I opened a file (about 300 lines) and did:
      > >
      > > :set tw=99999
      > > gggqG (I got a real _long_ line after this)
      > >
      > >then I press the <End> key, and Vim got frozen.
      > >I am using Vim 6.1, Linux box.
      > >Any idea?
      > >--
      >
      > I don't know about the freezing on the long lines. I was able to
      > copy change.txt into a new buffer, do a :%j, and press <End>.
      > There was no noticeable delay in the movement, and the status line
      > shows 1,54750-57826.
      >
      > Remember, "Formatting does not change empty lines (but it does change
      > lines with only white space!)." (from :h change.txt)
      >
      >
      > ~
      > ~
      > ~
      > "John R. Aldridge, Jr."

      Thanks for your tips.
      I did :%j this time, and it took about 5 minutes.
      Then I pressed <End>, it took about 3 minutes to finish this work.

      CPU CeleronII 566mhz, 64M Memory, an old S3 video card with 2M memory.
      Thanks for any suggestion.
    • Andrey Lebedev
      ... I ve found, that vim works very slow with long lines and syntax highlighting enabled. When you do :syntax off, vim works normally... -- Andrey Lebedev aka
      Message 35 of 35 , Oct 4, 2003
      • 0 Attachment
        On Tue, Sep 30, 2003 at 03:20:41PM +0800, Dasn Cups wrote:
        > On Mon, Sep 29, 2003 at 08:44:58AM -1000, Marc Adler wrote:
        > > > On Sun, Sep 28, 2003 at 08:54:39PM -1000, Marc Adler wrote: [...]
        > > > > > But, that didn't do enough joins. I'm sure that this could be
        > > > > > extended to get the desired results. But for casual typing, my
        > > > > > original suggestion (repeated below) works quite nicely.
        > > > > >
        > > > > > :set tw=99999 gggqG
        > > > > >
        > > > > > And then back again:
        > > > > >
        > > > > > :set tw=78 gggqG
        > > > >
        >
        > I tried these commands, but my Vim got crashed.
        > I opened a file (about 300 lines) and did:
        >
        > :set tw=99999
        > gggqG (I got a real _long_ line after this)
        >
        > then I press the <End> key, and Vim got frozen.
        > I am using Vim 6.1, Linux box.
        > Any idea?

        I've found, that vim works very slow with long lines and syntax
        highlighting enabled. When you do :syntax off, vim works normally...

        --
        Andrey Lebedev aka -.- . -.. -.. . .-.
        Software engineer
        UAB Mikromarketingas (http://micro.lt)
        Homepage: http://micro.lt/~andrey/
        Jabber ID: kedder@...
      Your message has been successfully submitted and would be delivered to recipients shortly.