Loading ...
Sorry, an error occurred while loading the content.
 

Re: russian text in gvim

Expand Messages
  • Andrei A. Voropaev
    ... Actually I ve learned the hard way that only setting LC_CTYPE is the best (for me) because in this case I get only support for russian text but don t get
    Message 1 of 4 , Sep 30 1:53 AM
      On Mon, Sep 29, 2003 at 08:32:58PM +0200, Bram Moolenaar wrote:
      > > Today I tried to type some russian text in gvim under X and got very strange
      > > results. To be able to see russian I did
      > >
      > > export LC_CTYPE=ru_RU
      > >
      > > While typing text everything was looking correct. But after I saved the
      > > file, all the letters there were converted to some other than koi8-r
      > > encoding, so viewing the file with other than gvim program produces
      > > garbage. The funny part is that even vim does not display that file
      > > correctly.
      >
      > Sounds strange. Perhaps there is more in your setup that matters?
      >
      > Just setting $LC_CTYPE is unusual, you might be better off setting $LANG.
      > But most important is the setting of 'encoding'. And possibly
      > 'termencoding'.

      Actually I've learned the hard way that only setting LC_CTYPE is the
      best (for me) because in this case I get only support for russian text
      but don't get russian menus and russian system messages (for many
      programs this is broken). I just was not setting it properly. But when
      it is set correctly (ru_RU.KOI8-R) then it automatically sets 'encoding'
      and 'termencoding' values in gvim. (This magic you have to explain :)

      --
      Andrei
    Your message has been successfully submitted and would be delivered to recipients shortly.