Loading ...
Sorry, an error occurred while loading the content.

turning file name completion on ?

Expand Messages
  • David selby
    This is my first post to you guys, so hello I have been using vim for about a year now, it grows on you .... I kind of love it now ! Its an amazing app, but I
    Message 1 of 4 , Aug 2, 2003
    • 0 Attachment
      This is my first post to you guys, so hello

      I have been using vim for about a year now, it grows on you .... I kind
      of love it now ! Its an amazing app, but I am stuck.

      I have checked :help, but cant find anything ... I have two vims
      running, one gvim6.2 on windows 98SE, the other .... a straight vim,
      unsure of version running inside cygwin environment. Neither have file
      name completion turned on.

      :a index.html

      has to be fully typed out, :a in<tab> does not work, just inserts
      controll chars.
      I have got the line numbers, and colourising of text working AOK

      I am unsure if this feature is from vim or bash, any ideas

      Dave

      PS Im a debian user, these two are for my forreys into windows territory !
    • Antoine J. Mechelynck
      ... see ... and maybe also ... and then, to see what you have and where it was set ... HTH, Tony
      Message 2 of 4 , Aug 2, 2003
      • 0 Attachment
        David selby <vim@...> wrote:
        > This is my first post to you guys, so hello
        >
        > I have been using vim for about a year now, it grows on you .... I
        > kind of love it now ! Its an amazing app, but I am stuck.
        >
        > I have checked :help, but cant find anything ... I have two vims
        > running, one gvim6.2 on windows 98SE, the other .... a straight vim,
        > unsure of version running inside cygwin environment. Neither have file
        > name completion turned on.
        >
        > > a index.html
        >
        > has to be fully typed out, :a in<tab> does not work, just inserts
        > controll chars.
        > I have got the line numbers, and colourising of text working AOK
        >
        > I am unsure if this feature is from vim or bash, any ideas
        >
        > Dave
        >
        > PS Im a debian user, these two are for my forreys into windows
        > territory !

        see
        :help 'compatible'
        :help 'wildchar'
        :help 'wildmode'
        :help 'wildmenu'
        and maybe also
        :help cmdline-completion
        :help command-completion
        :help ins-completion

        and then, to see what you have and where it was set
        :verbose set co? wc? wmnu? wim?

        HTH,
        Tony
      • David selby
        ... I turned compatibility off, once this was done, all the other parameters changed to map my debian vim. File completion works great now Thanks Dave
        Message 3 of 4 , Aug 3, 2003
        • 0 Attachment
          Antoine J. Mechelynck wrote:

          >David selby <vim@...> wrote:
          >
          >
          >>This is my first post to you guys, so hello
          >>
          >>I have been using vim for about a year now, it grows on you .... I
          >>kind of love it now ! Its an amazing app, but I am stuck.
          >>
          >>I have checked :help, but cant find anything ... I have two vims
          >>running, one gvim6.2 on windows 98SE, the other .... a straight vim,
          >>unsure of version running inside cygwin environment. Neither have file
          >>name completion turned on.
          >>
          >>
          >>
          >>>a index.html
          >>>
          >>>
          >>has to be fully typed out, :a in<tab> does not work, just inserts
          >>controll chars.
          >>I have got the line numbers, and colourising of text working AOK
          >>
          >>I am unsure if this feature is from vim or bash, any ideas
          >>
          >>Dave
          >>
          >>PS Im a debian user, these two are for my forreys into windows
          >>territory !
          >>
          >>
          >
          >see
          > :help 'compatible'
          > :help 'wildchar'
          > :help 'wildmode'
          > :help 'wildmenu'
          >and maybe also
          > :help cmdline-completion
          > :help command-completion
          > :help ins-completion
          >
          >and then, to see what you have and where it was set
          > :verbose set co? wc? wmnu? wim?
          >
          >HTH,
          >Tony
          >
          >

          I turned compatibility off, once this was done, all the other parameters
          changed to map my debian vim.
          File completion works great now

          Thanks
          Dave
        • Benji Fisher
          ... [snip] ... [snip] ... I think that nocompatible is set automatically if vim finds a vimrc file (but not if it just finds an exrc file). On Windows, this
          Message 4 of 4 , Aug 14, 2003
          • 0 Attachment
            David selby wrote:
            >
            >
            > Antoine J. Mechelynck wrote:
            >
            >> David selby <vim@...> wrote:
            >>>
            >>> I have checked :help, but cant find anything ... I have two vims
            >>> running, one gvim6.2 on windows 98SE, the other .... a straight vim,
            >>> unsure of version running inside cygwin environment. Neither have file
            >>> name completion turned on.
            [snip]
            >>
            >> see
            >> :help 'compatible'
            [snip]
            >
            > I turned compatibility off, once this was done, all the other parameters
            > changed to map my debian vim.
            > File completion works great now

            I think that 'nocompatible' is set automatically if vim finds a
            vimrc file (but not if it just finds an exrc file). On Windows, this
            file would usually be _vimrc under $HOME or $VIM . Have a look at the
            example files, vimrc_example.vim and gvimrc_example.vim to see what else
            you might be missing. If you are in the mood, try

            :options

            and browse a bit.

            HTH --Benji Fisher
          Your message has been successfully submitted and would be delivered to recipients shortly.