Loading ...
Sorry, an error occurred while loading the content.

Re: command line options (like +) appear as ex commands

Expand Messages
  • Antoine J. Mechelynck
    ... ... gvim.exe --cmd exe set cmdheight=3 | cd (the rest inchanged) will alleviate your problem by allocating 3 lines to the (internal) gvim command line,
    Message 1 of 1 , Jun 2 8:43 AM
    • 0 Attachment
      Neil Bird <neil@...> wrote:
      > In the Tornado IDE we're currently using, I have Vim set up as
      > external editor:
      >
      > "D:\Program Files\Vim\vim62\gvim.exe" --cmd "exe 'cd '
      > fnamemodify('$filename',':p:h')" --servername tornado --remote-silent
      > +$lineno $filename
      >
      >
      > This used to work no probs., but now vim seems to be displaying
      > those command line commands as if I'd typed 'em, and asks for a
      > prompt before I can edit:
      >
      > > cd -
      > > 2235
      > > call foreground()
      >
      > Hit ENTER or type command to continue
      >
      >
      > Am I missing an option now?
      >

      ...\gvim.exe --cmd "exe 'set cmdheight=3 | cd ' (the rest inchanged) will
      alleviate your problem by allocating 3 lines to the (internal) gvim command
      line, but I'm not sure this is what you want. See also :help hit-enter

      HTH,
      Tony.
    Your message has been successfully submitted and would be delivered to recipients shortly.