Loading ...
Sorry, an error occurred while loading the content.

unable to do command/filename completion in vim v6.1

Expand Messages
  • dev null
    Hi, I ve been having problem with getting command/filename completion to work in vim. In the past, when I type in ... matching command (split in this case).
    Message 1 of 3 , Jun 1, 2003
    • 0 Attachment
      Hi,
      I've been having problem with getting
      command/filename completion to work in vim.
      In the past, when I type in
      :sp and followed by a <TAB>, it will try to find the
      matching command (split in this case).
      Instead, I'm getting the ^I character instead.

      What can I do to get original behavior back?

      Thanks,
      David


      __________________________________
      Do you Yahoo!?
      Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
      http://calendar.yahoo.com
    • Antoine J. Mechelynck
      ... Several causes are possible: (a) Not recognising the Tab key as a Tab - is it mapped? (try :map without parameters) - is your termcap/terminfo file OK?
      Message 2 of 3 , Jun 1, 2003
      • 0 Attachment
        dev null <dev_null_cron@...> wrote:
        > Hi,
        > I've been having problem with getting
        > command/filename completion to work in vim.
        > In the past, when I type in
        > > sp and followed by a <TAB>, it will try to find the
        > matching command (split in this case).
        > Instead, I'm getting the ^I character instead.
        >
        > What can I do to get original behavior back?
        >
        > Thanks,
        > David
        >
        >
        > __________________________________
        > Do you Yahoo!?
        > Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
        > http://calendar.yahoo.com

        Several causes are possible:
        (a) Not recognising the Tab key as a Tab
        - is it mapped? (try :map without parameters)
        - is your termcap/terminfo file OK? (see :help startup-terminal)

        (b) Command-line completion not compiled-in
        - You can check this either from the listing of :version (you need
        +cmdline-compl) or by typing :echo has("cmdline-compl") (it must answer 1;
        has() won't work if you don't have +eval)

        (c) Tab not set as wildcard
        - you can test this with :verbose set wildchar? (it should answer
        wildchar=<Tab> or tell you where it is set to something else)
        - if 'wildchar' is set to Ctrl-F, then maybe you forgot to :set
        nocompatible (or :verbose set compatible? will tell you the current value
        and where it was set -- don't forget the question mark, without it you set
        the option to TRUE).
        - Ctrl-D can always be used instead (unless it has been remapped, see
        (a), mutatis mutandis)
        - see :help cmdline-completion

        HTH,
        Tony.
      • Piet Delport
        ... Have you double-checked that compatible is not set? -- Piet Delport Today s subliminal thought is:
        Message 3 of 3 , Jun 2, 2003
        • 0 Attachment
          On Sun, 01 Jun 2003 at 20:46:57 -0700, dev null wrote:
          >
          > I've been having problem with getting
          > command/filename completion to work in vim.
          > In the past, when I type in
          > :sp and followed by a <TAB>, it will try to find the
          > matching command (split in this case).
          > Instead, I'm getting the ^I character instead.
          >
          > What can I do to get original behavior back?

          Have you double-checked that 'compatible' is not set?

          --
          Piet Delport
          Today's subliminal thought is:
        Your message has been successfully submitted and would be delivered to recipients shortly.