Loading ...
Sorry, an error occurred while loading the content.

Re: Vim 6.1.405 archives available

Expand Messages
  • Walter Briscoe
    I am sorry that I took so long to respond to advice from Tony and Robert. I was on holiday for nearly two weeks and have been playing with the vim62 alphas. In
    Message 1 of 13 , Apr 29 3:57 AM
    • 0 Attachment
      I am sorry that I took so long to respond to advice from Tony and
      Robert. I was on holiday for nearly two weeks and have been playing with
      the vim62 alphas.

      In message <036901c2ffed$bb1765c0$cd31c950@tonymec> of Fri, 11 Apr 2003
      07:46:42 in , Antoine J. Mechelynck <antoine.mechelynck@...>
      writes
      >Walter Briscoe <wbriscoe@...> wrote:
      >> In message <3E950B2D.6000702@...> of Wed, 9 Apr 2003
      >> 23:11:57 in , Robert G. Werner <robert@...> writes
      >> > Bram Moolenaar wrote:
      [snip]
      >> > I think the problem is that there isn't a read/write driver in Linux
      >> > for ntfs partitions. It sounded like you were reading the source
      >> > from
      >> > a WinXP disk.
      >> >
      >> I am afraid it is not that problem - my partition is FAT32 for W9X
      >> compatibility. I found an icon for my hard drive and unchecked the
      >> read- only checkbox. I started sh; did a cd to
      >> /mnt/hda1/wfb/vim/bld/vim61 and tried echo > hello. The response was:
      >> Read-only file system.
      >> I looked at a lot of messages on the forums at
      >> http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
      >> question. I wait in hope!
      >> --
      >> Walter Briscoe
      >
      >On my dual-boot W98/LinuxRedHat system I have no problem reading or writing
      >the fat32 filesystems from RedHat; but they are mounted read-write by
      >default by means of /etc/fstab (log in as root and edit /etc/fstab to have
      >it mount your fat32 system read-write, then exit the editor with save, and
      >*then* type "init 6" [without the quotes] to reboot). To see what can go in
      >the fstab file, do: man fstab

      I think I have a chicken and egg situation which stops me trying this
      advice. I run from a CD; I guess /etc is on the CD and I can't write it.

      In message <3E966AD5.8070504@...> of Fri, 11 Apr 2003
      00:12:21 in , Robert G. Werner <robert@...> writes
      >Walter Briscoe wrote:
      >[snip]
      >> I am afraid it is not that problem - my partition is FAT32 for W9X
      >> compatibility. I found an icon for my hard drive and unchecked the read-
      >> only checkbox. I started sh; did a cd to /mnt/hda1/wfb/vim/bld/vim61 and
      >> tried echo > hello. The response was: Read-only file system.
      >> I looked at a lot of messages on the forums at
      >> http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
      >> question. I wait in hope!
      >
      >Try mount -o remount rw /dev/hda1 /mnt/hda1
      >
      >remount allows you to remount an already mounted filesystem with
      >different flags and the rw makes the partition read/write. Try that
      >and let me know if it helps.
      >
      Tried mount -o remount rw /dev/hda1 /mnt/hda1 and was told to use root.
      sudo mount -o remount rw /dev/hda1 /mnt/hda1 gave some man mount data.
      I started man 8 mount and quickly got bored.

      I then had an inspiration.
      My desktop had a "Hard Disk Partition (hda1)" icon.
      "Change read/write mode" was available as a right click option.
      I selected it and a dialog was opened -
      Title: Make partition /dev/hda1 writable
      Text: Do you really want to change partition /dev/hda1 (vfat) to be
      writable
      Buttons: Yes and No
      Default: Yes

      That worked!!!

      I was then able to build deliverables.
      One minor problem - Knoppix thinks I have a US keyboard; I have a UK
      one; Dell agreed to give me a US keyboard when it was last replaced but
      failed to do so!
      --
      Walter Briscoe
    Your message has been successfully submitted and would be delivered to recipients shortly.