Loading ...
Sorry, an error occurred while loading the content.

Vim 6.1.405 archives available

Expand Messages
  • Bram Moolenaar
    For those who are using the huge pile of patches, there are now archives available that include all the patches up to and including 6.1.405: In
    Message 1 of 13 , Mar 31, 2003
    • 0 Attachment
      For those who are using the huge pile of patches, there are now archives
      available that include all the patches up to and including 6.1.405:

      In ftp://ftp.vim.org/pub/vim/unix:

      SIZE FILE CONTENTS
      2948337 vim-6.1.405.tar.bz2 version 6.1.405 runtime + sources
      1240805 vim-6.1.405-rt1.tar.gz version 6.1.405 runtime part 1
      679562 vim-6.1.405-rt2.tar.gz version 6.1.405 runtime part 2
      1314190 vim-6.1.405-src1.tar.gz version 6.1.405 sources part 1
      402200 vim-6.1.405-src2.tar.gz version 6.1.405 sources part 2

      In ftp://ftp.vim.org/pub/vim/extra:

      SIZE FILE DESCRIPTION
      829932 vim-6.1.405-extra.tar.gz Extra files for version 6.1.405
      895992 vim-6.1.405-lang.tar.gz Language files for version 6.1.405


      There is no specific reason the archives are for the 6.1.405 version,
      it's not more stable than other patched versions.

      --
      The greatest lies of all time:
      (1) The check is in the mail.
      (2) We have a really challenging assignment for you.
      (3) I love you.
      (4) All bugs have been fixed.
      (5) This won't hurt a bit.
      (6) Honey, I just need to debug this program and be home in 5 minutes.
      (7) I have just sent you an e-mail about that.
      (8) Of course I'll respect you in the morning.
      (9) I'm from the government, and I'm here to help you.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
      \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
      \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
    • Walter Briscoe
      In message of Mon, 31 Mar 2003 22:28:39 in , Bram Moolenaar writes ... That is REALLY good. I
      Message 2 of 13 , Apr 1, 2003
      • 0 Attachment
        In message <200303312028.h2VKSdg11083@...> of Mon, 31 Mar 2003
        22:28:39 in , Bram Moolenaar <Bram@...> writes
        >
        >For those who are using the huge pile of patches, there are now archives
        >available that include all the patches up to and including 6.1.405:
        >
        >In ftp://ftp.vim.org/pub/vim/unix:
        >
        > SIZE FILE CONTENTS
        > 2948337 vim-6.1.405.tar.bz2 version 6.1.405 runtime + sources
        > 1240805 vim-6.1.405-rt1.tar.gz version 6.1.405 runtime part 1
        > 679562 vim-6.1.405-rt2.tar.gz version 6.1.405 runtime part 2
        > 1314190 vim-6.1.405-src1.tar.gz version 6.1.405 sources part 1
        > 402200 vim-6.1.405-src2.tar.gz version 6.1.405 sources part 2
        >
        >In ftp://ftp.vim.org/pub/vim/extra:
        >
        > SIZE FILE DESCRIPTION
        > 829932 vim-6.1.405-extra.tar.gz Extra files for version 6.1.405
        > 895992 vim-6.1.405-lang.tar.gz Language files for version 6.1.405
        >
        >
        >There is no specific reason the archives are for the 6.1.405 version,
        >it's not more stable than other patched versions.
        >
        That is REALLY good. I intend to download those files at the weekend.
        Would it be possible to publish the scripts used to generate those
        archives - so one could take snapshots in a similar way to Bram. I could
        re-invent the wheel but am not inclined to do so. :-)
        --
        Walter Briscoe
      • Bram Moolenaar
        ... The Makefile at the toplevel of the sources generates these archives. Check the comments to find out what extra requirements there are. -- Never be afraid
        Message 3 of 13 , Apr 2, 2003
        • 0 Attachment
          Walter Briscoe wrote:

          > In message <200303312028.h2VKSdg11083@...> of Mon, 31 Mar 2003
          > 22:28:39 in , Bram Moolenaar <Bram@...> writes
          > >
          > >For those who are using the huge pile of patches, there are now archives
          > >available that include all the patches up to and including 6.1.405:
          >
          > That is REALLY good. I intend to download those files at the weekend.
          > Would it be possible to publish the scripts used to generate those
          > archives - so one could take snapshots in a similar way to Bram. I could
          > re-invent the wheel but am not inclined to do so. :-)

          The Makefile at the toplevel of the sources generates these archives.
          Check the comments to find out what extra requirements there are.

          --
          "Never be afraid to tell the world who you are."
          -- Anonymous

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
          \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
          \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
        • Walter Briscoe
          In message of Wed, 2 Apr 2003 11:18:05 in , Bram Moolenaar writes ... Thanks for that. I found
          Message 4 of 13 , Apr 3, 2003
          • 0 Attachment
            In message <200304020918.h329I5S00803@...> of Wed, 2 Apr 2003
            11:18:05 in , Bram Moolenaar <Bram@...> writes
            >
            >Walter Briscoe wrote:
            >
            >> In message <200303312028.h2VKSdg11083@...> of Mon, 31 Mar 2003
            >> 22:28:39 in , Bram Moolenaar <Bram@...> writes
            >> >
            >> >For those who are using the huge pile of patches, there are now archives
            >> >available that include all the patches up to and including 6.1.405:
            >>
            >> That is REALLY good. I intend to download those files at the weekend.
            >> Would it be possible to publish the scripts used to generate those
            >> archives - so one could take snapshots in a similar way to Bram. I could
            >> re-invent the wheel but am not inclined to do so. :-)
            >
            >The Makefile at the toplevel of the sources generates these archives.
            >Check the comments to find out what extra requirements there are.
            >
            Thanks for that. I found it impossible to make that portable to W2K
            cmd.exe and DJG make. The \ / issue is easily (but clutteringly)
            resolved with a SEP macro and subshells replaced by scripts. The
            stumbling block is that with lines like
            tar c $(RT_ALL) $(RT_ALL_BIN) $(RT_UNIX) $(RT_UNIX_DOS_BIN) | cdx dist$(SEP)$(VIMRTDIR)
            replacing
            tar cf - \
            $(RT_ALL) \
            $(RT_ALL_BIN) \
            $(RT_UNIX) \
            $(RT_UNIX_DOS_BIN) \
            | (cd dist/$(VIMRTDIR); tar xf -)

            the tar command is longer than the make is ready to handle.
            (I found that "f -" was not portable.)

            I am walking away from this at the moment; my sub-consciousness will
            probably continue to work on it. I may try with bash as the shell.

            I shall report anything I find in vim-dev rather than vim. I apologise
            to my readers who find none of this relevant.
            --
            Walter Briscoe
          • Bram Moolenaar
            ... Yes, this only works on Unix. Just install some kind of Unix on a free partition. Or run knoppix directly from CD. That s easier than trying to make
            Message 5 of 13 , Apr 3, 2003
            • 0 Attachment
              Walter Briscoe wrote:

              > >The Makefile at the toplevel of the sources generates these archives.
              > >Check the comments to find out what extra requirements there are.
              > >
              > Thanks for that. I found it impossible to make that portable to W2K
              > cmd.exe and DJG make. The \ / issue is easily (but clutteringly)
              > resolved with a SEP macro and subshells replaced by scripts. The
              > stumbling block is that with lines like
              > tar c $(RT_ALL) $(RT_ALL_BIN) $(RT_UNIX) $(RT_UNIX_DOS_BIN) | cdx dist$(SEP)$(VIMRTDIR)
              > replacing
              > tar cf - \
              > $(RT_ALL) \
              > $(RT_ALL_BIN) \
              > $(RT_UNIX) \
              > $(RT_UNIX_DOS_BIN) \
              > | (cd dist/$(VIMRTDIR); tar xf -)
              >
              > the tar command is longer than the make is ready to handle.
              > (I found that "f -" was not portable.)

              Yes, this only works on Unix. Just install some kind of Unix on a free
              partition. Or run knoppix directly from CD. That's easier than trying
              to make this Makefile portable!

              I'll make an A-A-P recipe for this some day, that will work whereever
              Python is available.

              --
              MORTICIAN: What?
              CUSTOMER: Nothing -- here's your nine pence.
              DEAD PERSON: I'm not dead!
              MORTICIAN: Here -- he says he's not dead!
              CUSTOMER: Yes, he is.
              DEAD PERSON: I'm not!
              The Quest for the Holy Grail (Monty Python)

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
              \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
              \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
            • Walter Briscoe
              In message of Thu, 3 Apr 2003 11:19:28 in , Bram Moolenaar writes ... [snip] ... I did not
              Message 6 of 13 , Apr 7, 2003
              • 0 Attachment
                In message <200304030919.h339JSF00948@...> of Thu, 3 Apr 2003
                11:19:28 in , Bram Moolenaar <Bram@...> writes
                >
                >Walter Briscoe wrote:
                >
                >> >The Makefile at the toplevel of the sources generates these archives.
                >> >Check the comments to find out what extra requirements there are.
                >> >
                >> Thanks for that. I found it impossible to make that portable to W2K
                >> cmd.exe and DJG make. The \ / issue is easily (but clutteringly)
                [snip]
                >Yes, this only works on Unix. Just install some kind of Unix on a free
                >partition. Or run knoppix directly from CD. That's easier than trying
                >to make this Makefile portable!
                I did not recognise knoppix; Google quickly got me to
                http://www.knoppix.org This is a page in German which has links to
                corresponding pages in French, Spanish, and Japanese. I followed the
                English link and quickly got to a list of suppliers of knoppix by post
                (mail in US English). I selected "the linux emporium" and bought knoppix
                and a "SUSE Linux 8.1 live evaluation CD" for 7UKP (about 10 euros)
                including 2UKP postage (shipping in US English?). It looks like an easy
                road into Linux.

                >
                >I'll make an A-A-P recipe for this some day, that will work whereever
                >Python is available.
                >
                I suspect one will emerge! I must look. Not for several weeks as a
                holiday is planned.
                --
                Walter Briscoe
              • Walter Briscoe
                In message of Mon, 7 Apr 2003 13:34:28 in , Walter Briscoe writes ... Knoppix Linux 3.2
                Message 7 of 13 , Apr 9, 2003
                • 0 Attachment
                  In message <UBqyG0CUBXk+EwzS@...> of Mon, 7 Apr 2003
                  13:34:28 in , Walter Briscoe <wbriscoe@...> writes
                  >In message <200304030919.h339JSF00948@...> of Thu, 3 Apr 2003
                  >11:19:28 in , Bram Moolenaar <Bram@...> writes
                  >>
                  >>Walter Briscoe wrote:
                  >>
                  >>> >The Makefile at the toplevel of the sources generates these archives.
                  >>> >Check the comments to find out what extra requirements there are.
                  >>> >
                  >>> Thanks for that. I found it impossible to make that portable to W2K
                  >>> cmd.exe and DJG make. The \ / issue is easily (but clutteringly)
                  >[snip]
                  >>Yes, this only works on Unix. Just install some kind of Unix on a free
                  >>partition. Or run knoppix directly from CD. That's easier than trying
                  >>to make this Makefile portable!
                  Knoppix Linux 3.2 arrived today. I booted from it and found a "UNIX"
                  with a Windows XP look and feel. /usr/bin/vim was Vim 6.1.48.
                  I found my way into sh and that ./mnt/hda1/wfb/vim/bld/vim61/src
                  corresponded to C:\wfb\vim\bld\vim61\src. make failed and I could
                  proceed no further as the file system was mounted read only; I have no
                  knowledge of configuring knoppix or other "UNIX" or Linux. There must be
                  a FAQ and a better forum than this to answer my questions. When I find
                  more, I shall post again.
                  --
                  Walter Briscoe
                • Bram Moolenaar
                  ... I m glad Knoppix works for you. I have heard quite a few positive remarks on it. I don t know the easy way to make a partition writable. mount will do
                  Message 8 of 13 , Apr 9, 2003
                  • 0 Attachment
                    Walter Briscoe wrote:

                    > >>Yes, this only works on Unix. Just install some kind of Unix on a free
                    > >>partition. Or run knoppix directly from CD. That's easier than trying
                    > >>to make this Makefile portable!
                    >
                    > Knoppix Linux 3.2 arrived today. I booted from it and found a "UNIX"
                    > with a Windows XP look and feel. /usr/bin/vim was Vim 6.1.48.
                    > I found my way into sh and that ./mnt/hda1/wfb/vim/bld/vim61/src
                    > corresponded to C:\wfb\vim\bld\vim61\src. make failed and I could
                    > proceed no further as the file system was mounted read only;

                    I'm glad Knoppix works for you. I have heard quite a few positive
                    remarks on it. I don't know the easy way to make a partition writable.
                    "mount" will do it if you give it the right arguments. Something like:

                    mount /dev/hda3 /mnt/hda3

                    > I have no knowledge of configuring knoppix or other "UNIX" or Linux.
                    > There must be a FAQ and a better forum than this to answer my
                    > questions. When I find more, I shall post again.

                    A good starting point is: http://www.knoppix.net/docs/

                    --
                    FROG: How you English say: I one more time, mac, I unclog my nose towards
                    you, sons of a window-dresser, so, you think you could out-clever us
                    French fellows with your silly knees-bent creeping about advancing
                    behaviour. (blows a raspberry) I wave my private parts at your aunties,
                    you brightly-coloured, mealy-templed, cranberry-smelling, electric
                    donkey-bottom biters.
                    "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

                    /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
                    /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
                    \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
                    \\\ Help AIDS victims, buy at Amazon -- http://ICCF.nl/click1.html ///
                  • Robert G. Werner
                    ... [snip] ... [snip] I think the problem is that there isn t a read/write driver in Linux for ntfs partitions. It sounded like you were reading the source
                    Message 9 of 13 , Apr 9, 2003
                    • 0 Attachment
                      Bram Moolenaar wrote:
                      > Walter Briscoe wrote:
                      [snip]
                      >>proceed no further as the file system was mounted read only;
                      >
                      >
                      > I'm glad Knoppix works for you. I have heard quite a few positive
                      > remarks on it. I don't know the easy way to make a partition writable.
                      > "mount" will do it if you give it the right arguments. Something like:
                      >
                      > mount /dev/hda3 /mnt/hda3
                      [snip]
                      I think the problem is that there isn't a read/write driver in Linux
                      for ntfs partitions. It sounded like you were reading the source from
                      a WinXP disk.

                      --
                      In Reach Technology: http://inreachtech.net/

                      Robert G. Werner
                      robert@...

                      Tel: 559.304.5122
                    • Walter Briscoe
                      In message of Wed, 9 Apr 2003 23:11:57 in , Robert G. Werner writes ... I am afraid it is not that
                      Message 10 of 13 , Apr 10, 2003
                      • 0 Attachment
                        In message <3E950B2D.6000702@...> of Wed, 9 Apr 2003
                        23:11:57 in , Robert G. Werner <robert@...> writes
                        >Bram Moolenaar wrote:
                        >> Walter Briscoe wrote:
                        >[snip]
                        >>>proceed no further as the file system was mounted read only;
                        >> I'm glad Knoppix works for you. I have heard quite a few positive
                        >> remarks on it. I don't know the easy way to make a partition writable.
                        >> "mount" will do it if you give it the right arguments. Something like:
                        >> mount /dev/hda3 /mnt/hda3
                        >[snip]
                        >I think the problem is that there isn't a read/write driver in Linux
                        >for ntfs partitions. It sounded like you were reading the source from
                        >a WinXP disk.
                        >
                        I am afraid it is not that problem - my partition is FAT32 for W9X
                        compatibility. I found an icon for my hard drive and unchecked the read-
                        only checkbox. I started sh; did a cd to /mnt/hda1/wfb/vim/bld/vim61 and
                        tried echo > hello. The response was: Read-only file system.
                        I looked at a lot of messages on the forums at
                        http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
                        question. I wait in hope!
                        --
                        Walter Briscoe
                      • Antoine J. Mechelynck
                        ... On my dual-boot W98/LinuxRedHat system I have no problem reading or writing the fat32 filesystems from RedHat; but they are mounted read-write by default
                        Message 11 of 13 , Apr 10, 2003
                        • 0 Attachment
                          Walter Briscoe <wbriscoe@...> wrote:
                          > In message <3E950B2D.6000702@...> of Wed, 9 Apr 2003
                          > 23:11:57 in , Robert G. Werner <robert@...> writes
                          > > Bram Moolenaar wrote:
                          > > > Walter Briscoe wrote:
                          > > [snip]
                          > > > > proceed no further as the file system was mounted read only;
                          > > > I'm glad Knoppix works for you. I have heard quite a few
                          > > > positive remarks on it. I don't know the easy way to make a
                          > > > partition writable. "mount" will do it if you give it the right
                          > > > arguments. Something like: mount /dev/hda3 /mnt/hda3
                          > > [snip]
                          > > I think the problem is that there isn't a read/write driver in Linux
                          > > for ntfs partitions. It sounded like you were reading the source
                          > > from
                          > > a WinXP disk.
                          > >
                          > I am afraid it is not that problem - my partition is FAT32 for W9X
                          > compatibility. I found an icon for my hard drive and unchecked the
                          > read- only checkbox. I started sh; did a cd to
                          > /mnt/hda1/wfb/vim/bld/vim61 and tried echo > hello. The response was:
                          > Read-only file system.
                          > I looked at a lot of messages on the forums at
                          > http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
                          > question. I wait in hope!
                          > --
                          > Walter Briscoe

                          On my dual-boot W98/LinuxRedHat system I have no problem reading or writing
                          the fat32 filesystems from RedHat; but they are mounted read-write by
                          default by means of /etc/fstab (log in as root and edit /etc/fstab to have
                          it mount your fat32 system read-write, then exit the editor with save, and
                          *then* type "init 6" [without the quotes] to reboot). To see what can go in
                          the fstab file, do: man fstab

                          HTH,
                          Tony.
                        • Robert G. Werner
                          Walter Briscoe wrote: [snip] ... Try mount -o remount rw /dev/hda1 /mnt/hda1 remount allows you to remount an already mounted filesystem with different flags
                          Message 12 of 13 , Apr 11, 2003
                          • 0 Attachment
                            Walter Briscoe wrote:
                            [snip]
                            > I am afraid it is not that problem - my partition is FAT32 for W9X
                            > compatibility. I found an icon for my hard drive and unchecked the read-
                            > only checkbox. I started sh; did a cd to /mnt/hda1/wfb/vim/bld/vim61 and
                            > tried echo > hello. The response was: Read-only file system.
                            > I looked at a lot of messages on the forums at
                            > http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
                            > question. I wait in hope!

                            Try mount -o remount rw /dev/hda1 /mnt/hda1

                            remount allows you to remount an already mounted filesystem with
                            different flags and the rw makes the partition read/write. Try that
                            and let me know if it helps.

                            --
                            In Reach Technology: http://inreachtech.net/

                            Robert G. Werner
                            robert@...

                            Tel: 559.304.5122
                          • Walter Briscoe
                            I am sorry that I took so long to respond to advice from Tony and Robert. I was on holiday for nearly two weeks and have been playing with the vim62 alphas. In
                            Message 13 of 13 , Apr 29, 2003
                            • 0 Attachment
                              I am sorry that I took so long to respond to advice from Tony and
                              Robert. I was on holiday for nearly two weeks and have been playing with
                              the vim62 alphas.

                              In message <036901c2ffed$bb1765c0$cd31c950@tonymec> of Fri, 11 Apr 2003
                              07:46:42 in , Antoine J. Mechelynck <antoine.mechelynck@...>
                              writes
                              >Walter Briscoe <wbriscoe@...> wrote:
                              >> In message <3E950B2D.6000702@...> of Wed, 9 Apr 2003
                              >> 23:11:57 in , Robert G. Werner <robert@...> writes
                              >> > Bram Moolenaar wrote:
                              [snip]
                              >> > I think the problem is that there isn't a read/write driver in Linux
                              >> > for ntfs partitions. It sounded like you were reading the source
                              >> > from
                              >> > a WinXP disk.
                              >> >
                              >> I am afraid it is not that problem - my partition is FAT32 for W9X
                              >> compatibility. I found an icon for my hard drive and unchecked the
                              >> read- only checkbox. I started sh; did a cd to
                              >> /mnt/hda1/wfb/vim/bld/vim61 and tried echo > hello. The response was:
                              >> Read-only file system.
                              >> I looked at a lot of messages on the forums at
                              >> http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
                              >> question. I wait in hope!
                              >> --
                              >> Walter Briscoe
                              >
                              >On my dual-boot W98/LinuxRedHat system I have no problem reading or writing
                              >the fat32 filesystems from RedHat; but they are mounted read-write by
                              >default by means of /etc/fstab (log in as root and edit /etc/fstab to have
                              >it mount your fat32 system read-write, then exit the editor with save, and
                              >*then* type "init 6" [without the quotes] to reboot). To see what can go in
                              >the fstab file, do: man fstab

                              I think I have a chicken and egg situation which stops me trying this
                              advice. I run from a CD; I guess /etc is on the CD and I can't write it.

                              In message <3E966AD5.8070504@...> of Fri, 11 Apr 2003
                              00:12:21 in , Robert G. Werner <robert@...> writes
                              >Walter Briscoe wrote:
                              >[snip]
                              >> I am afraid it is not that problem - my partition is FAT32 for W9X
                              >> compatibility. I found an icon for my hard drive and unchecked the read-
                              >> only checkbox. I started sh; did a cd to /mnt/hda1/wfb/vim/bld/vim61 and
                              >> tried echo > hello. The response was: Read-only file system.
                              >> I looked at a lot of messages on the forums at
                              >> http://www.knoppix.net/forum/ I found nothing, subscribed, and asked a
                              >> question. I wait in hope!
                              >
                              >Try mount -o remount rw /dev/hda1 /mnt/hda1
                              >
                              >remount allows you to remount an already mounted filesystem with
                              >different flags and the rw makes the partition read/write. Try that
                              >and let me know if it helps.
                              >
                              Tried mount -o remount rw /dev/hda1 /mnt/hda1 and was told to use root.
                              sudo mount -o remount rw /dev/hda1 /mnt/hda1 gave some man mount data.
                              I started man 8 mount and quickly got bored.

                              I then had an inspiration.
                              My desktop had a "Hard Disk Partition (hda1)" icon.
                              "Change read/write mode" was available as a right click option.
                              I selected it and a dialog was opened -
                              Title: Make partition /dev/hda1 writable
                              Text: Do you really want to change partition /dev/hda1 (vfat) to be
                              writable
                              Buttons: Yes and No
                              Default: Yes

                              That worked!!!

                              I was then able to build deliverables.
                              One minor problem - Knoppix thinks I have a US keyboard; I have a UK
                              one; Dell agreed to give me a US keyboard when it was last replaced but
                              failed to do so!
                              --
                              Walter Briscoe
                            Your message has been successfully submitted and would be delivered to recipients shortly.