Loading ...
Sorry, an error occurred while loading the content.

RE: Linux Newbie

Expand Messages
  • Daniel Elstner
    ... If you can t, you can always use this work-around: alias buggyapp= LC_ALL=C buggyapp This way you don t have to downgrade the whole system. Be sure to
    Message 1 of 11 , Feb 28, 2003
    • 0 Attachment
      On Fre, 2003-02-28 at 19:29, Bowie Bailey wrote:
      > > From: Daniel Elstner [mailto:daniel.elstner@...]
      > >
      > > On Fre, 2003-02-28 at 10:43, A. S. Budden wrote:
      > > > * Bowie Bailey (Bowie_Bailey@...) wrote:
      > > > >
      > > > > The RedHat 8.0 system that I setup defaulted my language
      > > > > settings to "en_US.UTF-8". This has caused me a few
      > > > > headaches. Check to see if you have the same or a similar
      > > > > setting. Once I dropped the "UTF-8" and changed
      > > > > the environment variable to "en_US", things worked much better.
      > >
      > > This is not a problem but a feature. If some apps don't work
      > > with this
      > > setting I suggest fixing those apps rather than going back to the
      > > seventies for the sake of buggy software.
      >
      > I agree...if I can get things to work properly.

      If you can't, you can always use this work-around:

      alias buggyapp='LC_ALL=C buggyapp'

      This way you don't have to downgrade the whole system. Be sure to use
      "C" and not "en_US" or something since only pure ASCII is compatible to
      UTF-8. (Actually LC_CTYPE=C should be sufficient but not all apps
      handle that correctly.)

      > > Besides, it certainly won't cause any compilation problems. As Benji
      > > Fisher already suggested, get the lastest Vim with all
      > > patches applied.
      > > I think the relevant patches are 6.1.080 + 6.1.084, but better get all
      > > of them anyway.
      >
      > I think the compilation problems I ran into were with CPAN modules for Perl.
      > Everything died until I changed the LANG setting.

      Urgh. Is this still true? It'd really be a shame if installing CPAN
      modules breaks in a UTF-8 environment even though Perl itself supports
      UTF-8 just fine.

      > Also, my Windows terminal
      > program (TeraTerm Pro + TTSSH) gets completely screwed up if I try to
      > display a man page with LANG set to en_US.UTF-8. Do you know of any SSH
      > programs for Windows that supports UTF-8?

      Nope sorry. Try the LC_ALL=C workaround for now.

      ­-Daniel
    • Antoine J. Mechelynck
      ... [...] Note: To get a current version of gvim binaries for redhat or w32, follow the links at http://cream.sourceforge.net/vim.html . At the time of this
      Message 2 of 11 , Feb 28, 2003
      • 0 Attachment
        Daniel Elstner <daniel.elstner@...> wrote:
        > On Fre, 2003-02-28 at 10:43, A. S. Budden wrote:
        > > * Bowie Bailey (Bowie_Bailey@...) wrote:
        > > > > From: A. S. Budden [mailto:vim.mail@...]
        > > > >
        > > > Two observations.
        > > >
        > > > The RedHat 8.0 system that I setup defaulted my language settings
        > > > to "en_US.UTF-8". This has caused me a few headaches. Check to
        > > > see if you have the same or a similar setting. Once I dropped
        > > > the "UTF-8" and changed the environment variable to "en_US",
        > > > things worked much better.
        >
        > This is not a problem but a feature. If some apps don't work with
        > this setting I suggest fixing those apps rather than going back to the
        > seventies for the sake of buggy software.
        >
        > Besides, it certainly won't cause any compilation problems. As Benji
        > Fisher already suggested, get the lastest Vim with all patches
        > applied.
        > I think the relevant patches are 6.1.080 + 6.1.084, but better get all
        > of them anyway.
        [...]

        Note: To get a current version of gvim binaries for redhat or w32, follow
        the links at http://cream.sourceforge.net/vim.html . At the time of this
        writing the versions available from there appear to be 6.1.317 -arabic for
        redhat, 6.1.284 +arabic for redhat, or 6.1.362 +arabic for w32.

        HTH,
        Tony.
      • Dan Sharp
        ... PuTTY (at least as of version 0.53b) has an option under Window Translation called Character set translation on received data that lists UTF-8 as a
        Message 3 of 11 , Feb 28, 2003
        • 0 Attachment
          Bowie Bailey wrote:
          >
          > I think the compilation problems I ran into were with CPAN modules for Perl.
          > Everything died until I changed the LANG setting. Also, my Windows terminal
          > program (TeraTerm Pro + TTSSH) gets completely screwed up if I try to
          > display a man page with LANG set to en_US.UTF-8. Do you know of any SSH
          > programs for Windows that supports UTF-8?

          PuTTY (at least as of version 0.53b) has an option under
          Window\Translation called "Character set translation on received data"
          that lists UTF-8 as a possible option. You can get it from
          http://www.chiark.greenend.org.uk/~sgtatham/putty/

          Dan Sharp
        Your message has been successfully submitted and would be delivered to recipients shortly.