Loading ...
Sorry, an error occurred while loading the content.
 

abbreviations not working

Expand Messages
  • Sandip P Deshmukh
    hello all i am editing a tex file. i do :iab 12 twelve type 12 in insert mode. nothing happens. am i doing something wrong? tia -- regards, sandip p deshmukh
    Message 1 of 19 , Jan 29, 2003
      hello all

      i am editing a tex file.

      i do :iab 12 twelve

      type 12 in insert mode. nothing happens.

      am i doing something wrong?

      tia

      --
      regards,
      sandip p deshmukh
      ------***--------
      They are called computers simply because computation is the only significant
      job that has so far been given to them.
    • Naveen Chandra
      ... from the docs i found that... Abbreviations are disabled if the paste option is on. so check if paste option is set? hth -ncr ... -- Calvin: There s
      Message 2 of 19 , Jan 30, 2003
        > i am editing a tex file.
        >
        > i do :iab 12 twelve
        >
        > type 12 in insert mode. nothing happens.
        >
        > am i doing something wrong?

        from the docs i found that...

        Abbreviations are disabled if the 'paste' option is on.

        so check if 'paste' option is set?

        hth
        -ncr

        >
        > tia
        >
        > --
        > regards,
        > sandip p deshmukh
        > ------***--------
        > They are called computers simply because computation is the only significant
        > job that has so far been given to them.

        --
        Calvin: There's never enough time to do all the nothing you want.
        -- Calvin and Hobbes

        ---o0o---

        Naveen Chandra R
        Validation Technologies Group, PNP,
        Sun Microsystems,
        Bangalore, India.

        Homepage: http://www.geocities.com/ncr_10/
        Ph: 91-80-2298989, ext:27461

        ---o0o---
      • Sandip P Deshmukh
        ... paste default is off. i have not set it on manually. i am also enclosing my .vimrc so you know what all i have set. -- regards, sandip p deshmukh ... The
        Message 3 of 19 , Jan 30, 2003
          On Thu, Jan 30, 2003 at 02:07:08PM +0530, Naveen Chandra wrote:
          >
          > > i am editing a tex file.
          > >
          > > i do :iab 12 twelve
          > >
          > > type 12 in insert mode. nothing happens.
          > >
          > > am i doing something wrong?
          >
          > from the docs i found that...
          >
          > Abbreviations are disabled if the 'paste' option is on.
          >
          > so check if 'paste' option is set?

          paste default is off. i have not set it on manually.

          i am also enclosing my .vimrc so you know what all i have set.

          --
          regards,
          sandip p deshmukh
          ------***--------
          "The sixties were good to you, weren't they?"
          -- George Carlin
        • Benji Fisher
          ... Did you type 12 or 12 ? ... HTH --Benji Fisher
          Message 4 of 19 , Jan 30, 2003
            Sandip P Deshmukh wrote:
            > hello all
            >
            > i am editing a tex file.
            >
            > i do :iab 12 twelve
            >
            > type 12 in insert mode. nothing happens.
            >
            > am i doing something wrong?
            >
            > tia
            >

            Did you type "12" or "12 "?

            :help :iab

            HTH --Benji Fisher
          • Sandip P Deshmukh
            ... for sake of clarity i will use word space to indicate a space. here is ... then in insert mode, i type 12 space and nothing happens. for further clarity, i
            Message 5 of 19 , Jan 31, 2003
              On Thu, Jan 30, 2003 at 09:00:12AM -0500, Benji Fisher wrote:
              > Sandip P Deshmukh wrote:
              > >hello all
              > >
              > >i am editing a tex file.
              > >
              > >i do :iab 12 twelve
              > >
              > >type 12 in insert mode. nothing happens.
              > >
              > >am i doing something wrong?
              > >
              > >tia
              > >
              >
              > Did you type "12" or "12 "?

              for sake of clarity i will use word space to indicate a space. here is
              what i did:

              :iab space 12 space twelve enter

              then in insert mode, i type 12 space and nothing happens.

              for further clarity, i am enclosing my .vimrc file:

              --
              regards,
              sandip p deshmukh
              ------***--------
            • Geoffrey Mann
              Benji, ab 12 twelve works for him but not iab 12 twelve Do you know the reason why? I certainly don t. Geoff -- regards, sandip p deshmukh ... There is no
              Message 6 of 19 , Jan 31, 2003
                Benji,
                ab 12 twelve
                works for him but not
                iab 12 twelve

                Do you know the reason why? I certainly don't.

                Geoff

                --
                regards,
                sandip p deshmukh
                ------***--------
                There is no time like the present for postponing what you ought to be doing.

                -----Original Message-----
                From: Benji Fisher [mailto:benji@...]
                Sent: Friday, January 31, 2003 9:06 AM
                To: Sandip P Deshmukh
                Cc: vim@...
                Subject: Re: abbreviations not working


                Sandip P Deshmukh wrote:
                >
                > for sake of clarity i will use word space to indicate a space. here is
                > what i did:
                >
                > :iab space 12 space twelve enter
                >
                > then in insert mode, i type 12 space and nothing happens.

                When I try this, I get "twelve " or, in your representation,
                twelve space. Was there anything before the "12"? Perhaps you have a
                conflicting map or abbreviation.

                :iab 1
                :iab 2
                :imap 1
                :imap 2
                :imap <Space>

                > for further clarity, i am enclosing my .vimrc file:
                [snip]
                >
                > " Make p in Visual mode replace the selected text with the "" register.
                > vnoremap p <Esc>:let current_reg = @"<CR>gvdi<C-R>=current_reg<CR><Esc>

                This is obsolete, since p now does the same thing by default.
                :help v_p

                > if has("autocmd")
                > " Enabled file type detection
                > " Use the default filetype settings. If you also want to load indent files
                > " to automatically do language-dependent indenting add 'indent' as well.
                > filetype plugin on
                > filetype indent on
                > endif " has ("autocmd")

                Plugins (global and filetype) can be doing almost anything. What
                plugins are you using? Does your :iab work if you disable them? Try
                changing "on" to "off" above and read
                :help --noplugin

                > "This is for Latex editing
                > set sw=2
                > set iskeyword+=:

                If you only want these settings for LaTeX, you could put them in
                $HOME/.vim/ftplugin/latex.vim

                HTH --Benji Fisher
              • Sandip P Deshmukh
                ... let me correct. either of these commands in .vimrc work well none of these commands typed on the fly do!! (i meant :iab etc.) -- regards, sandip p deshmukh
                Message 7 of 19 , Jan 31, 2003
                  On Fri, Jan 31, 2003 at 08:54:57AM -0500, Geoffrey Mann wrote:
                  > Benji,
                  > ab 12 twelve
                  > works for him but not
                  > iab 12 twelve

                  let me correct. either of these commands in .vimrc work well

                  none of these commands typed on the fly do!! (i meant :iab etc.)

                  --
                  regards,
                  sandip p deshmukh
                  ------***--------
                  Q: How does a hacker fix a function which
                  doesn't work for all of the elements in its domain?
                  A: He changes the domain.
                • Benji Fisher
                  ... When I try this, I get twelve or, in your representation, twelve space. Was there anything before the 12 ? Perhaps you have a conflicting map or
                  Message 8 of 19 , Jan 31, 2003
                    Sandip P Deshmukh wrote:
                    >
                    > for sake of clarity i will use word space to indicate a space. here is
                    > what i did:
                    >
                    > :iab space 12 space twelve enter
                    >
                    > then in insert mode, i type 12 space and nothing happens.

                    When I try this, I get "twelve " or, in your representation,
                    twelve space. Was there anything before the "12"? Perhaps you have a
                    conflicting map or abbreviation.

                    :iab 1
                    :iab 2
                    :imap 1
                    :imap 2
                    :imap <Space>

                    > for further clarity, i am enclosing my .vimrc file:
                    [snip]
                    >
                    > " Make p in Visual mode replace the selected text with the "" register.
                    > vnoremap p <Esc>:let current_reg = @"<CR>gvdi<C-R>=current_reg<CR><Esc>

                    This is obsolete, since p now does the same thing by default.
                    :help v_p

                    > if has("autocmd")
                    > " Enabled file type detection
                    > " Use the default filetype settings. If you also want to load indent files
                    > " to automatically do language-dependent indenting add 'indent' as well.
                    > filetype plugin on
                    > filetype indent on
                    > endif " has ("autocmd")

                    Plugins (global and filetype) can be doing almost anything. What
                    plugins are you using? Does your :iab work if you disable them? Try
                    changing "on" to "off" above and read
                    :help --noplugin

                    > "This is for Latex editing
                    > set sw=2
                    > set iskeyword+=:

                    If you only want these settings for LaTeX, you could put them in
                    $HOME/.vim/ftplugin/latex.vim

                    HTH --Benji Fisher
                  • Sandip P Deshmukh
                    ... well 1 2 was being typed at the beginning of the line. there was nothing before it ... okay ... latex-vim (vim-latex?) and html plugins ... just these two
                    Message 9 of 19 , Jan 31, 2003
                      On Fri, Jan 31, 2003 at 09:05:48AM -0500, Benji Fisher wrote:
                      > Sandip P Deshmukh wrote:
                      > >
                      > >for sake of clarity i will use word space to indicate a space. here is
                      > >what i did:
                      > >
                      > >:iab space 12 space twelve enter
                      > >
                      > >then in insert mode, i type 12 space and nothing happens.
                      >
                      > When I try this, I get "twelve " or, in your representation,
                      > twelve space. Was there anything before the "12"? Perhaps you have a
                      > conflicting map or abbreviation.

                      well 1 2 was being typed at the beginning of the line. there was nothing
                      before it

                      > >" Make p in Visual mode replace the selected text with the "" register.
                      > >vnoremap p <Esc>:let current_reg = @"<CR>gvdi<C-R>=current_reg<CR><Esc>
                      >
                      > This is obsolete, since p now does the same thing by default.
                      > :help v_p

                      okay


                      > >if has("autocmd")
                      > > " Enabled file type detection
                      > > " Use the default filetype settings. If you also want to load indent files
                      > > " to automatically do language-dependent indenting add 'indent' as well.
                      > > filetype plugin on
                      > > filetype indent on
                      > >endif " has ("autocmd")
                      >
                      > Plugins (global and filetype) can be doing almost anything. What
                      > plugins are you using? Does your :iab work if you disable them? Try
                      > changing "on" to "off" above and read

                      latex-vim (vim-latex?) and html plugins

                      > :help --noplugin
                      >
                      > >"This is for Latex editing
                      > >set sw=2
                      > >set iskeyword+=:
                      >
                      > If you only want these settings for LaTeX, you could put them in
                      > $HOME/.vim/ftplugin/latex.vim

                      just these two lines?

                      --
                      regards,
                      sandip p deshmukh
                      ------***--------
                      The more they over-think the plumbing the easier it is to stop up the drain.
                    • Sandip P Deshmukh
                      ... geoffrey introduced ab. i had been trying iab all along. anyway, i have deleted my .vimrc and .vim folder. doing everything from scratch i also realized
                      Message 10 of 19 , Jan 31, 2003
                        On Fri, Jan 31, 2003 at 09:29:44AM -0500, Benji Fisher wrote:
                        > Geoffrey Mann wrote:
                        > >Benji,
                        > > ab 12 twelve
                        > > works for him but not
                        > > iab 12 twelve
                        > >
                        > > Do you know the reason why? I certainly don't.
                        >
                        > If the :ab works in Command mode but not Insert mode, it is
                        > probably a problem with conflicting maps or abbreviations, as I
                        > suggested in my last note. If :ab but not :iab works in Insert mode, I
                        > am stumped, too.
                        >
                        > I re-read the thread, and I do not see any mention of :ab instead
                        > of :iab . Did I miss something?

                        geoffrey introduced ab. i had been trying iab all along. anyway, i have
                        deleted my .vimrc and .vim folder. doing everything from scratch

                        i also realized that my latex commands were not doing as expected. main
                        reason for restarting my vim experience.

                        will surely come back to group if i get problems again.
                        >
                        > HTH --Benji Fisher
                        >
                        >
                        >

                        --
                        regards,
                        sandip p deshmukh
                        ------***--------
                        One Page Principle:
                        A specification that will not fit on one page of 8.5x11 inch
                        paper cannot be understood.
                        -- Mark Ardis
                      • Benji Fisher
                        ... If the :ab works in Command mode but not Insert mode, it is probably a problem with conflicting maps or abbreviations, as I suggested in my last note. If
                        Message 11 of 19 , Jan 31, 2003
                          Geoffrey Mann wrote:
                          > Benji,
                          > ab 12 twelve
                          > works for him but not
                          > iab 12 twelve
                          >
                          > Do you know the reason why? I certainly don't.

                          If the :ab works in Command mode but not Insert mode, it is
                          probably a problem with conflicting maps or abbreviations, as I
                          suggested in my last note. If :ab but not :iab works in Insert mode, I
                          am stumped, too.

                          I re-read the thread, and I do not see any mention of :ab instead
                          of :iab . Did I miss something?

                          HTH --Benji Fisher
                        • Benji Fisher
                          ... In that case, I still want to know the answers to the questions I asked last time. HTH --Benji Fisher
                          Message 12 of 19 , Jan 31, 2003
                            Sandip P Deshmukh wrote:
                            > On Fri, Jan 31, 2003 at 08:54:57AM -0500, Geoffrey Mann wrote:
                            >
                            >>Benji,
                            >> ab 12 twelve
                            >> works for him but not
                            >> iab 12 twelve
                            >
                            >
                            > let me correct. either of these commands in .vimrc work well
                            >
                            > none of these commands typed on the fly do!! (i meant :iab etc.)

                            In that case, I still want to know the answers to the questions I
                            asked last time.

                            HTH --Benji Fisher
                          • Benji Fisher
                            ... You snipped, and did not answer, the rest of my question. What do you get from these? ... That might be the source of the problems. Try updating
                            Message 13 of 19 , Jan 31, 2003
                              Sandip P Deshmukh wrote:
                              > On Fri, Jan 31, 2003 at 09:05:48AM -0500, Benji Fisher wrote:
                              >
                              >> When I try this, I get "twelve " or, in your representation,
                              >>twelve space. Was there anything before the "12"? Perhaps you have a
                              >>conflicting map or abbreviation.
                              >
                              > well 1 2 was being typed at the beginning of the line. there was nothing
                              > before it

                              You snipped, and did not answer, the rest of my question. What do
                              you get from these?

                              :iab 1
                              :iab 2
                              :imap 1
                              :imap 2
                              :imap <Space>

                              >> Plugins (global and filetype) can be doing almost anything. What
                              >>plugins are you using? Does your :iab work if you disable them? Try
                              >>changing "on" to "off" above and read
                              >
                              > latex-vim (vim-latex?) and html plugins

                              That might be the source of the problems. Try updating vim-latex.
                              I also use it, and still cannot reproduce your problem. If that is
                              causing the problems, you might try posting to
                              vim-latex-devel@...

                              >>>"This is for Latex editing
                              >>>set sw=2
                              >>>set iskeyword+=:
                              >>
                              >> If you only want these settings for LaTeX, you could put them in
                              >>$HOME/.vim/ftplugin/latex.vim
                              >
                              > just these two lines?

                              Why not?

                              > [snip] anyway, i have
                              > deleted my .vimrc and .vim folder. doing everything from scratch
                              >
                              > i also realized that my latex commands were not doing as expected. main
                              > reason for restarting my vim experience.

                              That seems rather drastic, but of course it is up to you.

                              HTH --Benji Fisher
                            • Sandip P Deshmukh
                              ... apologies. frankly, i did not understand you wanted me to do this. ... well, i always thought plugins need to be large complex files! ... well, i agree. i
                              Message 14 of 19 , Jan 31, 2003
                                On Fri, Jan 31, 2003 at 11:00:39AM -0500, Benji Fisher wrote:
                                > Sandip P Deshmukh wrote:
                                > >On Fri, Jan 31, 2003 at 09:05:48AM -0500, Benji Fisher wrote:
                                > >
                                > >> When I try this, I get "twelve " or, in your representation,
                                > >>twelve space. Was there anything before the "12"? Perhaps you have a
                                > >>conflicting map or abbreviation.
                                > >
                                > >well 1 2 was being typed at the beginning of the line. there was nothing
                                > >before it
                                >
                                > You snipped, and did not answer, the rest of my question. What do
                                > you get from these?

                                apologies. frankly, i did not understand you wanted me to do this.
                                >
                                > :iab 1
                                > :iab 2
                                > :imap 1
                                > :imap 2
                                > :imap <Space>
                                >
                                > >>>"This is for Latex editing
                                > >>>set sw=2
                                > >>>set iskeyword+=:
                                > >>
                                > >> If you only want these settings for LaTeX, you could put them in
                                > >>$HOME/.vim/ftplugin/latex.vim
                                > >
                                > >just these two lines?
                                >
                                > Why not?

                                well, i always thought plugins need to be large complex files!

                                > >[snip] anyway, i have
                                > >deleted my .vimrc and .vim folder. doing everything from scratch
                                > >
                                > >i also realized that my latex commands were not doing as expected. main
                                > >reason for restarting my vim experience.
                                >
                                > That seems rather drastic, but of course it is up to you.

                                well, i agree. i think i am still carrying windows legacy - reinstall if
                                there is trouble!

                                actually, i had not tweaked the vimrc much. so did not hesitate much.

                                my apologies again for snipping. did not intend to. and thanx for all
                                help. i surely will need more of it as i proceed.

                                --
                                regards,
                                sandip p deshmukh
                                ------***--------
                                Bubble Memory, n.:
                                A derogatory term, usually referring to a person's intelligence.
                                See also "vacuum tube".
                              • Srinath Avadhanula
                                Hello Sandip, From your .vimrc, I am guessing that you are using vim-latex. In this case, that is what is causing the problem... Vim-latex maps the
                                Message 15 of 19 , Feb 1, 2003
                                  Hello Sandip,

                                  From your .vimrc, I am guessing that you are using vim-latex. In this
                                  case, that is what is causing the problem... Vim-latex maps the <space>
                                  key, which breaks abbreviations. I might fix this in the future if I
                                  find a good way of doing it (Its not really just vim-latex. If you had
                                  mapped say \ to something, then 12\ wouldn't have expanded to twelve\).
                                  In the meanwhile, here's what I suggest you can try doing in case you
                                  use want to use vim-latex:

                                  Put the line:

                                  call IMAP('12 ', 'twleve ', '')

                                  in ~/.vim/ftplugin/tex.vim

                                  and

                                  iab 12 twelve

                                  in your ~/.vimrc. If in a vim session, you invoke latex-suite, it will
                                  restore some functionality... Specifically, it will make 12<space>
                                  expand to twelve<space>... Its not quite a vim abbreviation because 12\
                                  will not expand to twelve\... but its a start anyway... If you never
                                  edit a tex file in a vim session, the iab in your ~/.vimrc will do the
                                  job a little better.

                                  Let me know if this works....

                                  Sorry to hear that you had to scrap all of your ~/.vim folder. Hopefully
                                  it isn't too much work to set up again... (Hopefully you just moved it
                                  or something).

                                  > i also realized that my latex commands were not doing as expected. main
                                  > reason for restarting my vim experience.

                                  Could you explain what you mean by this? I would like to hear about
                                  vim-latex bugs...

                                  > will surely come back to group if i get problems again.

                                  From next time on, a valuable debugging technique is to first find out
                                  if you still have problems by starting vim with
                                  vim -u NONE -U NONE
                                  This basically starts off vim without sourcing the .vimrc. If it works,
                                  then you know the problem is in the .vimrc. Then you can be a bit more
                                  brave and do:
                                  vim --noplugin
                                  Finally, comment out
                                  filetype plugin on
                                  in your ~/.vimrc... All these things will get you to the root of the
                                  problem much faster.

                                  Srinath
                                • Dave Rahardja
                                  Did you type a space after the 12 ? - Dave Rahardja
                                  Message 16 of 19 , Feb 1, 2003
                                    Did you type a space after the "12"?

                                    - Dave Rahardja

                                    > -----Original Message-----
                                    > From: sandip [mailto:deshmukh@...]
                                    > Sent: Thursday, January 30, 2003 12:23 AM
                                    > To: vim@...
                                    > Subject: abbreviations not working
                                    >
                                    >
                                    > hello all
                                    >
                                    > i am editing a tex file.
                                    >
                                    > i do :iab 12 twelve
                                    >
                                    > type 12 in insert mode. nothing happens.
                                    >
                                    > am i doing something wrong?
                                    >
                                    > tia
                                    >
                                    > --
                                    > regards,
                                    > sandip p deshmukh
                                    > ------***--------
                                    > They are called computers simply because computation is the
                                    > only significant
                                    > job that has so far been given to them.
                                    >
                                  • Neil Watson
                                    I have a strange problem that I can t seem to narrow down. The abbreviations that I ve been using for years have suddenly stopped working at random times.
                                    Message 17 of 19 , Sep 14, 2004
                                      I have a strange problem that I can't seem to narrow down. The
                                      abbreviations that I've been using for years have suddenly stopped
                                      working at random times. I'm not sure what the problem is or how to
                                      debug it.

                                      .gvimrc:
                                      "set guioptions
                                      colorscheme neilwatson

                                      "font
                                      set guifont=luxi\ mono\ bold\ 14

                                      "window size
                                      set guiheadroom=20
                                      set columns=176
                                      set lines=999

                                      " remove menus, icons and scrollbars
                                      set guioptions-=m
                                      set guioptions-=T
                                      set guioptions-=R
                                      set guioptions-=r

                                      .vimrc:
                                      set history=50
                                      set ruler
                                      set expandtab
                                      set tabstop=4
                                      set shiftwidth=4
                                      set smartindent
                                      set autoindent
                                      set undolevels=100
                                      set showmatch
                                      set showcmd
                                      set number

                                      "for scp
                                      set nocp
                                      if version >= 600
                                      filetype plugin indent on
                                      endif

                                      :syntax on

                                      "spell check
                                      "map ,fs :w<CR>:!ispell %<CR>:e %<CR>
                                      map ,fs :w<CR>:!aspell -x -d canadian -c %<CR>:e %<CR>
                                      map ,fsf :w<CR>:!aspell -x -d french -c %<CR>:e %<CR>

                                      "open my gvimrc file
                                      map ,r :edit! ~/.gvimrc<CR>

                                      "my signature and date
                                      map ,sd :read !date<CR>kddi# Neil H Watson on <ESC><Home>

                                      "date stamp
                                      map ,d :read !date<CR>

                                      "set syntax to mason for dir
                                      au BufRead,BufNewFile */htdocs/* set syntax=mason

                                      "===================================
                                      "HTML SECTION
                                      "===================================

                                      set matchpairs+=<:>
                                      :syntax match xComment /<!.*/

                                      "html comment current line
                                      map ,hc I<!--<ESC>A--><ESC>

                                      "html header
                                      map ,hh i<html><CR><head><CR><meta name="keywords" content=""><CR><meta name="Author" content="Neil H Watson"><CR><title></title><CR></head><CR><body><CR><ESC>:3>3<CR>

                                      "html footer
                                      map ,hf :i</body><CR></html><C-C>

                                      "create html header lines (h1 to h6)
                                      nmap ,h1 <HOME>v$"zdi<h1><ESC>"zp$a</h1><ESC>
                                      nmap ,h2 <HOME>v$"zdi<h2><ESC>"zp$a</h2><ESC>
                                      nmap ,h3 <HOME>v$"zdi<h3><ESC>"zp$a</h3><ESC>
                                      nmap ,h4 <HOME>v$"zdi<h4><ESC>"zp$a</h4><ESC>
                                      nmap ,h5 <HOME>v$"zdi<h5><ESC>"zp$a</h5><ESC>
                                      nmap ,h6 <HOME>v$"zdi<h6><ESC>"zp$a</h6><ESC>

                                      "add html bold tags
                                      vmap ,hb "zdi<b><ESC>"zpgviw<ESC>a</b><ESC>

                                      "add html code tags
                                      vmap ,hc "zdi<code><ESC>"zpgv$<ESC>a</code><ESC>

                                      "add html name tags
                                      vmap ,hn "zdi<name="<ESC>"zpgv$<ESC>a"></a><ESC>

                                      "add html paragraph tags
                                      nmap ,hp <HOME>v$"zdi<p><ESC>"zp$a</p><ESC>

                                      "create html table from ;; delimited table
                                      nmap ,ht vip :s/^/<tr>/<CR> gv :s/$/<\/tr>/<CR> gv :s/<tr>/<tr>\r\t<td>/<CR> gvip :s/<\/tr>/<\/td>\r<\/tr>/<CR> gvip :s/;;/<\/td>\r\t<td>/g<CR><C-C>

                                      "create html list items
                                      nmap ,hl vip :s/^\(.*\)$/\t<li>\1<\/li>/g<CR><C-C>

                                      iab ht http://<C-R>=Eatchar('\s')<CR>
                                      iab ah <a href="<C-R>=Eatchar('\s')<CR>
                                      iab mailto <a href="mailto:"></a>


                                      "===================================
                                      "PERL SECTION
                                      "===================================

                                      :syntax match xComment /#.*/

                                      "create perl header
                                      map ,ph i!<ESC>:read !which perl<CR>kgJA<CR><CR>use strict;<CR>use warnings;<CR><CR><ESC>ggI#<ESC>G<C-C>

                                      "common DBI statements
                                      iab hashref while ($ref = $sth->fetchrow_hashref){
                                      "iab sth $sth = $dbh->prepare($statement) or die "Couldn't prepare statement: $statement ".$dbh->errstr;<CR>$sth->execute or die "Couldn't execute statement: $statement ".$dbh->errstr;

                                      "===================================
                                      "MASON SECTION
                                      "===================================

                                      "insert mason titles and names
                                      nmap ,mt GA<CR><%method title></%method><CR><%method header></%method><CR><%method author>Neil H Watson</%method><C-C>


                                      "===================================
                                      "TIMESHEET SECTION
                                      "===================================
                                      iab oa O&A.<C-R>=Eatchar('\s')<CR>
                                      iab oas O&A.sysadm =
                                      iab oass O&A.sales.sysadm =
                                      iab ws workstation support


                                      "===================================
                                      "SUBROUTINES
                                      "===================================

                                      "remove last character (space) after abbreviation
                                      fun! Eatchar(pat)
                                      let c = nr2char(getchar())
                                      return (c =~ a:pat) ? '' : c
                                      endfun

                                      --
                                      Neil Watson | Gentoo Linux
                                      Network Administrator | Uptime 12 days
                                      http://watson-wilson.ca | 2.6.8.1 AMD Athlon(tm) MP 2000+ x 2
                                    • Neil Watson
                                      Upon further investigation I can see that the abbreviations are stored (:ab will list them). However, the abbreviations do actually execute. Is there some
                                      Message 18 of 19 , Sep 14, 2004
                                        Upon further investigation I can see that the abbreviations are stored
                                        (:ab will list them). However, the abbreviations do actually execute.

                                        Is there some setting that prevents or delays abbreviation completion?

                                        --
                                        Neil Watson | Gentoo Linux
                                        Network Administrator | Uptime 12 days
                                        http://watson-wilson.ca | 2.6.8.1 AMD Athlon(tm) MP 2000+ x 2
                                      • Neil Watson
                                        I ve narrowed the problem down to the global rc files (gvimrc or vimrc). I can t determine what is causing the problem. Perhaps someone here can?
                                        Message 19 of 19 , Sep 14, 2004
                                          I've narrowed the problem down to the global rc files (gvimrc or vimrc).
                                          I can't determine what is causing the problem. Perhaps someone here
                                          can?

                                          /etc/vim/vimrc
                                          " Default configuration file for Vim
                                          " Written by Aron Griffis <agriffis@...>
                                          " Modified by Ryan Phillips <rphillips@...>
                                          " Added Redhat's vimrc info by Seemant Kulleen <seemant@...>

                                          " The following are some sensible defaults for Vim for most users.
                                          " We attempt to change as little as possible from Vim's defaults,
                                          " deviating only where it makes sense
                                          set nocompatible " Use Vim defaults (much better!)
                                          set bs=2 " Allow backspacing over everything in insert mode
                                          set ai " Always set auto-indenting on
                                          "set backup " Keep a backup file
                                          set viminfo='20,\"500 " read/write a .viminfo file -- limit regs to 500 lines
                                          set history=50 " keep 50 lines of command history
                                          set ruler " Show the cursor position all the time

                                          " Added to default to high security within Gentoo. Fixes bug #14088.
                                          " Modified 07 Oct 2003 by agriffis from "modelines=0" to "nomodeline"
                                          " according to conversation on vim devel ML:
                                          " http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=212696
                                          " http://article.gmane.org/gmane.editors.vim.devel/4410
                                          set nomodeline

                                          if v:lang =~ "^ko"
                                          set fileencodings=euc-kr
                                          set guifontset=-*-*-medium-r-normal--16-*-*-*-*-*-*-*
                                          elseif v:lang =~ "^ja_JP"
                                          set fileencodings=euc-jp
                                          set guifontset=-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*
                                          elseif v:lang =~ "^zh_TW"
                                          set fileencodings=big5
                                          set guifontset=-sony-fixed-medium-r-normal--16-150-75-75-c-80-iso8859-1,-taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0
                                          elseif v:lang =~ "^zh_CN"
                                          set fileencodings=gb2312
                                          set guifontset=*-r-*
                                          endif
                                          if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
                                          set fileencodings=utf-8,latin1
                                          endif

                                          " Don't use Ex mode, use Q for formatting
                                          map Q gq

                                          " Switch syntax highlighting on, when the terminal has colors
                                          " Also switch on highlighting the last used search pattern.
                                          if &t_Co > 2 || has("gui_running")
                                          syntax on
                                          set hlsearch
                                          endif

                                          if &term=="xterm"
                                          " Previously we would unset t_RV to prevent gnome-terminal from beeping as
                                          " vim started. These days it appears that gnome-terminal has been repaired,
                                          " so re-enable this, and don't restrict t_Co=8. (21 Jun 2004 agriffis)
                                          "set t_RV= " don't check terminal version
                                          "set t_Co=8
                                          set t_Sb=^[4%dm
                                          set t_Sf=^[3%dm
                                          set ttymouse=xterm2 " only works for >=xfree86-3.3.3, should be okay
                                          endif

                                          if has("autocmd")

                                          augroup gentoo
                                          au!

                                          " Gentoo-specific settings for ebuilds. These are the federally-mandated
                                          " required tab settings. See the following for more information:
                                          " http://www.gentoo.org/doc/en/xml/gentoo-howto.xml
                                          au BufRead,BufNewFile *.e{build,class} let is_bash=1|set ft=sh
                                          au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab

                                          " In text files, limit the width of text to 78 characters, but be careful
                                          " that we don't override the user's setting.
                                          autocmd BufNewFile,BufRead *.txt if &tw == 0 | set tw=78 | endif

                                          " When editing a file, always jump to the last cursor position
                                          autocmd BufReadPost *
                                          \ if line("'\"") > 0 && line ("'\"") <= line("$") |
                                          \ exe "normal g'\"" |
                                          \ endif

                                          " When editing a crontab file, set backupcopy to yes rather than auto. See
                                          " :help crontab and bug 53437.
                                          autocmd FileType crontab set backupcopy=yes

                                          augroup END

                                          endif " has("autocmd")

                                          /etc/vim/gvrimrc
                                          " Default configuration file for gvim
                                          " Written by Aron Griffis <agriffis@...>
                                          "
                                          " This file is read AFTER normal Vim initializations, like reading your .vimrc
                                          " file (and the default /usr/share/vim/vimrc). So there's no reason to
                                          " duplicate settings from vimrc. Red Hat has had this wrong for years, to the
                                          " great annoyance of users.

                                          " Pre-GUI settings
                                          set columns=80 lines=30 " don't inherit geometry from parent term
                                          set mousemodel=popup " right mouse button pops up a menu in the GUI

                                          " Use a sufficiently wide window automatically when started as "gvimdiff"
                                          if (&foldmethod == 'diff')
                                          set columns=165
                                          endif

                                          " For bug 33327, add a mapping which allows shift-insert to function
                                          " as expected in insert and command-line modes
                                          map! <s-insert> <c-r>*

                                          --
                                          Neil Watson | Gentoo Linux
                                          Network Administrator | Uptime 12 days
                                          http://watson-wilson.ca | 2.6.8.1 AMD Athlon(tm) MP 2000+ x 2
                                        Your message has been successfully submitted and would be delivered to recipients shortly.