Loading ...
Sorry, an error occurred while loading the content.

Re: Toggle 'modified' flag

Expand Messages
  • Klaus Bosau
    ... Hi Antoine, sorry for the delay! The buffers in question are wiped out afterwards, thus they didn t show up in the buffer listing. (To create the buffer
    Message 1 of 13 , Jan 1, 2003
    • 0 Attachment
      On Mon, 30 Dec 2002, Antoine J. Mechelynck wrote:

      > If you want to have buffer 3 become buffer 1, a recent discussion in
      > this ML told us, from highest authority :-), that it wasn't possible.
      > Note that :ls doesn't show 'unlisted' buffers, but :ls! does. What you
      > show means that initialization has opened three buffers and delisted
      > or wiped the first two (or maybe opened more than three and delisted
      > or wiped all of them except number 3).

      Hi Antoine,

      sorry for the delay! The buffers in question are wiped out afterwards,
      thus they didn't show up in the buffer listing. (To create the buffer
      listing I used ":ls!".)

      > I wonder wat caused buffer 3 (the current [NoFile] buffer) to be
      > marked as modified. To see where it comes from, it might be
      > instructive to do
      >
      > :verbose setlocal modified?
      >
      > in the buffer in question, with the question mark

      I entered

      set nomodified
      verbose setlocal modified? (resp. set verbose=20)
      redir! > c:\vim\log

      at the very bottom of the script, but 'log' didn't show any buffer
      related information. The buffer in question however again has been
      marked 'modified'.

      In the meantime I found out that scripts residing in the plugin/
      directory (it's the default collection) cannot be responsible for this.
      So I'm looking for a new candidate now. ":scrip" told me that it might
      be one of these: "filetype.vim", "menu.vim", "syntax.vim",
      "synload.vim", "syncolor.vim", "mail.vim"

      What do you think?

      Klaus
    • Antoine J. Mechelynck
      ... [...] ... I meant you to type :verbose setlocal modified? yourself as a Vim command, not enter it into a script; and if you put it before the redir
      Message 2 of 13 , Jan 1, 2003
      • 0 Attachment
        Klaus Bosau <kbosau@...> wrote:
        > On Mon, 30 Dec 2002, Antoine J. Mechelynck wrote:
        [...]
        > > I wonder wat caused buffer 3 (the current [NoFile] buffer) to be
        > > marked as modified. To see where it comes from, it might be
        > > instructive to do
        > >
        > > :verbose setlocal modified?
        > >
        > > in the buffer in question, with the question mark
        >
        > I entered
        >
        > set nomodified
        > verbose setlocal modified? (resp. set verbose=20)
        > redir! > c:\vim\log
        >
        > at the very bottom of the script, but 'log' didn't show any buffer
        > related information. The buffer in question however again has been
        > marked 'modified'.

        I meant you to type :verbose setlocal modified? yourself as a Vim command,
        not enter it into a script; and if you put it before the redir command, it
        won't be redirected, but its output (if any) will appear on the
        command-line. But apparently even if you get an answer it might be for a
        different buffer.
        >
        > In the meantime I found out that scripts residing in the plugin/
        > directory (it's the default collection) cannot be responsible for this.
        > So I'm looking for a new candidate now. ":scrip" told me that it might
        > be one of these: "filetype.vim", "menu.vim", "syntax.vim",
        > "synload.vim", "syncolor.vim", "mail.vim"
        >
        > What do you think?
        >
        > Klaus

        I'm not sure what I should think. Maybe there is something pertinent to your
        case under :help local-options, just before the *:setl* helptag.

        Tony.
      • Klaus Bosau
        ... Sorry, maybe I misunderstood. I thought you wanted me to trace what happens after the script referred to is done. ... Of course you re right. Must have
        Message 3 of 13 , Jan 1, 2003
        • 0 Attachment
          On Wed, 1 Jan 2003, Antoine J. Mechelynck wrote:

          > I meant you to type :verbose setlocal modified? yourself as a Vim
          > command, not enter it into a script;

          Sorry, maybe I misunderstood. I thought you wanted me to trace what
          happens after the script referred to is done.

          > and if you put it before the redir command, it won't be redirected,
          > but its output (if any) will appear on the command-line.

          Of course you're right. Must have messed it up when writing it down
          again. I took a look a few moments ago but the script showed me the
          right order... Sorry!

          > But apparently even if you get an answer it might be for a different
          > buffer.

          Well, I was interested in any kind of information related to this also
          cause I realized that restricting the answer on buffer related topics
          might be too strong.

          > I'm not sure what I should think. Maybe there is something pertinent
          > to your case under :help local-options, just before the *:setl*
          > helptag.

          Thanks! I'll take a look...

          Klaus
        Your message has been successfully submitted and would be delivered to recipients shortly.