Loading ...
Sorry, an error occurred while loading the content.

Re: Shouldn't ff=mac work for mac files ?

Expand Messages
  • Colin Keith
    ... It won t because that s not how the fileformat setting works: (from help fileformat) This gives the of the current buffer, which is used for
    Message 1 of 3 , Nov 28, 2002
    • 0 Attachment
      On Fri, Nov 29, 2002 at 03:21:28AM +0000, Sam Spade wrote:
      > I tried executing manually
      > :set ff=mac
      > but that does not imporove my display (which renders all the
      > file text as one long string).

      It won't because that's not how the fileformat setting works:
      (from help fileformat)

      This gives the <EOL> of the current buffer, which is used for
      reading/writing the buffer from/to a file:

      In otherwords Vim uses its default setting, slurps in the file thinking its
      one line, displays it as such, then you come along and change the ff setting.
      If you want to fix the display a quick ":%s/^M/^M/g" will fix it and you
      can then save the file as a unix ff.

      I'm curious about this as a setting somewhere is causing my copy to defualt
      to ff=unix, regardless of what I set, but here are a couple of ways to get
      it to open nicely:

      open vim with no filename, then open your file with:

      :e ++ff=mac CORPCHAR.TXT

      or from scratch:

      vim -u NONE --cmd 'ff=max' CORPCHAR.TXT

      I need to put the -u NONE so no cfg's are loaded. I've commented out every
      line in my .vimrc and it always defaults to unix unless I specify this.
      Very odd. Oh and you must use --cmd, not -c as -c operates after the file
      has loaded (say the docs :-)

      Col.

      --
      We are often told that the Chinese government restricts Internet access for its
      citizens by blocking e-mail and web site access. I find this somewhat ironic
      since the majority of my spam comes from Chinese open mail relays and proxy
      servers that aren't blocked, banned or filtered in the slightest...
    Your message has been successfully submitted and would be delivered to recipients shortly.