Loading ...
Sorry, an error occurred while loading the content.

Unable to disable menu translation.

Expand Messages
  • Pan
    I m using operating system with asian language and I don t like the automatic translation of menus and messages for gVim and want to use the default English
    Message 1 of 5 , Oct 31, 2002
    • 0 Attachment
      I'm using operating system with asian language and I don't like the
      automatic translation of menus and messages for gVim and want to use the
      default English text instead.

      I had managed to disable the message translation but I can't disable the
      menu translation, the menu seem always to show in the same language as
      the operating system.

      I'd use this two lines in my .vimrc:

      set langmenu=none
      language messages en

      the messages is ok, but the langmenu setting from :help 45.2 doesn't
      work.

      I checked from the document and found that when langmenu=none, vim will
      use "v:lang" variable instead.

      But I don't know whether "v:lang" applies only to the menu (I want only
      to change the menu translation but no others, vim should be able to read
      and process local language text file.), what shall I do now?

      Thanks very much.
    • Mikolaj Machowski
      ... [cut] ... Re_move_ directory with messages in your language? This the only solution which worked for me. Mikolaj
      Message 2 of 5 , Oct 31, 2002
      • 0 Attachment
        On Thu, Oct 31, 2002 at 08:05:02PM -0000, Pan wrote:
        > I'm using operating system with asian language and I don't like the
        > automatic translation of menus and messages for gVim and want to use the
        > default English text instead.
        [cut]
        > But I don't know whether "v:lang" applies only to the menu (I want
        > only
        > to change the menu translation but no others, vim should be able to read
        > and process local language text file.), what shall I do now?

        Re_move_ directory with messages in your language? This the only
        solution which worked for me.

        Mikolaj
      • Hiroshi Iwatani
        On Linux and at the bash prompt: export LANG=en export LC_CTYPE=en should work. On Windows, I believe equivalent commands should be written in AUTOEXEC.BAT or
        Message 3 of 5 , Oct 31, 2002
        • 0 Attachment
          On Linux and at the bash prompt:

          export LANG=en
          export LC_CTYPE=en

          should work.

          On Windows, I believe equivalent commands
          should be written in AUTOEXEC.BAT or set
          env's values at Win2K system GUI.

          As I am not a Windows user, I regret that
          I can't be specific about the GUI's name.

          Pan wrote:
          > I'm using operating system with asian language and I don't like the
          > automatic translation of menus and messages for gVim and want to use the
          > default English text instead.
          >
          > I had managed to disable the message translation but I can't disable the
          > menu translation, the menu seem always to show in the same language as
          > the operating system.
          >
          > I'd use this two lines in my .vimrc:
          >
          > set langmenu=none
          > language messages en
          >
          > the messages is ok, but the langmenu setting from :help 45.2 doesn't
          > work.
          >
          > I checked from the document and found that when langmenu=none, vim will
          > use "v:lang" variable instead.
          >
          > But I don't know whether "v:lang" applies only to the menu (I want only
          > to change the menu translation but no others, vim should be able to read
          > and process local language text file.), what shall I do now?
          >
          > Thanks very much.
          >
          >


          --
          Hiroshi Iwatani

          *stop cruelty* Annual number of institutionally euthanized cats and dogs
          including kittens and puppies: US 5 million, JP 500 thousand. How about your
          country? *for our better karma*
          ---------------------
        • Hiroshi Iwatani
          Or, you could write a script (a batch file in MS parlance) in which you set locale to en , invoke Vim, and restore original locale on the last line. I m
          Message 4 of 5 , Oct 31, 2002
          • 0 Attachment
            Or, you could write a script (a 'batch file' in MS parlance)
            in which you set locale to 'en', invoke Vim, and restore original
            locale on the last line.

            I'm afraid I don't know whether Win implements the concept of
            subshell in its executing architecture though.

            (If it doesn't, new locale would be applied to all of the
            current processes. If that hinders, then, write a C program
            instead of batch file. C runtime should support envs which
            are local to a particular process, that is the program itself.)

            Pan wrote:
            > I'm using operating system with asian language and I don't like the
            > automatic translation of menus and messages for gVim and want to use the
            > default English text instead.
            >
            > I had managed to disable the message translation but I can't disable the
            > menu translation, the menu seem always to show in the same language as
            > the operating system.
            >
            > I'd use this two lines in my .vimrc:
            >
            > set langmenu=none
            > language messages en
            >
            > the messages is ok, but the langmenu setting from :help 45.2 doesn't
            > work.
            >
            > I checked from the document and found that when langmenu=none, vim will
            > use "v:lang" variable instead.
            >
            > But I don't know whether "v:lang" applies only to the menu (I want only
            > to change the menu translation but no others, vim should be able to read
            > and process local language text file.), what shall I do now?
            >
            > Thanks very much.
            >
            >


            --
            Hiroshi Iwatani

            *stop cruelty* Annual number of institutionally euthanized cats and dogs
            including kittens and puppies: US 5 million, JP 500 thousand. How about your
            country? *for our better karma*
            ---------------------
          • Antoine J. Mechelynck
            Hiroshi Iwatani wrote: [...] ... [...] Let me reassure you: every console application (aka Dos box , but it can also run programs
            Message 5 of 5 , Oct 31, 2002
            • 0 Attachment
              Hiroshi Iwatani <HGA03630@...> wrote:
              [...]
              > I'm afraid I don't know whether Win implements the concept of
              > subshell in its executing architecture though.
              [...]

              Let me reassure you: every "console application" (aka "Dos box", but it can
              also run programs that depend on Windows) starts with a default environment,
              but any changes made to that environment inside the box are "local", i.e.,
              they are not seen by other processes and disappear when the console box
              closes (but of course when gvim forks, it keeps its environment settings as
              they were when it was loaded).

              HTH,
              Tony.
            Your message has been successfully submitted and would be delivered to recipients shortly.