Loading ...
Sorry, an error occurred while loading the content.

Re: vim 6.1.18 on debian woody switching between buffers on a .gz file

Expand Messages
  • Oliver Fuchs
    ... Great ... thank you for your help/answering. Oliver -- ... don t touch the bang-bang fruit
    Message 1 of 3 , Oct 2 12:26 AM
    • 0 Attachment
      On Tue, 01 Oct 2002, Bram Moolenaar wrote:

      > Oliver Fuchs wrote:
      > > I am using vim 6.1.18 on debian woody.
      > >
      > > I open/edit a file let's say bob.txt ... I want to add a passage from a file
      > > called /usr/share/sendmail/cf.README.gz, so I do
      > > :e /usr/share/sendmail/cf.README.gz.
      > > In the cf.README.gz file I yank some lines and now I try to switch
      > > back to bob.txt with Ctrl-^ and receive the following message:
      > > No alternative file
      > > So I close my cf.README.gz buffer and I receive the message:
      > > E162: No write since last change for buffer "bob.txt"
      > > HIT enter or type a command to continue
      > > Doing this brings me back to my first buffer "bob.txt".
      > > Now if I repeat the same command everything works o.k.
      > >
      > > Why isn't vim able to switch back to the first buffer.
      > This is caused by the gzip plugin. It uses a temporary file to
      > uncompress the file and deletes the buffers afterwards. The alternate
      > file gets lost in this. That can be avoided by temporarily removing the
      > 'a' and 'A' flags from the 'cpo' option. I'll make a patch.

      Great ... thank you for your help/answering.

      ... don't touch the bang-bang fruit
    Your message has been successfully submitted and would be delivered to recipients shortly.