Loading ...
Sorry, an error occurred while loading the content.

Re: Access permissions when editing in a PC

Expand Messages
  • Paul Y. Peng
    I tried to set up both backup and writeback options and they do not work. I am using VIM-5.6 which does not have an option backupcopy . I will give it a try
    Message 1 of 7 , Sep 27, 2002
    • 0 Attachment
      I tried to set up both backup and writeback options and they do not
      work. I am using VIM-5.6 which does not have an option "backupcopy".
      I will give it a try after I upgrade my VIM. Thanks.

      Paul.

      "Antoine J. Mechelynck" wrote:
      >
      > maybe you need to :set backupcopy in order to overwrite the original file
      > rather than copy it as a backup and write a new one? (see :h 'bkc')



      "Yegappan Lakshmanan" wrote:
      >
      > >From the Vim FAQ:
      >
      > http://vimdoc.sourceforge.net/cgi-bin/vimfaq2html3.pl
      >
      > --------------------------------------------------------------------------
      > 5.10. When I save a file with Vim, the file permissions are changed.
      > How do I configure Vim to save a file without chaging the file
      > permissions?
      >
      > This may happen, if the 'backupcopy' option is set to 'no' or 'auto'. Note
      > that the default value for this option is set in such a way that this will
      > correctly work in most of the cases. If the default doesn't work for you,
      > try setting the 'backupcopy' option to 'yes' to keep the file permission
      > when saving a file:
      >
      > :set backupcopy=yes
      >
      > This applies, only if you have configured Vim to make a backup whenever
      > overwriting a file. By default, Vim will not backup files.
      >
      > For more information, read
      >
      > :help 'backupcopy'
      > :help backup
      > :help 'backup'
      > :help 'writebackup'
      > --------------------------------------------------------------------------
      >
      >
      > __________________________________________________
      > Do you Yahoo!?
      > New DSL Internet Access from SBC & Yahoo!
      > http://sbc.yahoo.com
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.