Loading ...
Sorry, an error occurred while loading the content.
 

Perl syntax unwanted behavior

Expand Messages
  • Jorge O. Martinez
    Hi: When I have code like this: { #comment my $foo = bar; { #comment my $foo = bar; } } and I indent it (%=), I would like my comments to be indented too, but
    Message 1 of 3 , Sep 3, 2002
      Hi:

      When I have code like this:

      {
      #comment
      my $foo = bar;
      {
      #comment
      my $foo = bar;
      }
      }

      and I indent it (%=), I would like my comments to be indented too, but all
      indentation disappears for comments, and only code is indented correctly,
      looking like this.

      {
      #comment
      my $foo = bar;
      {
      #comment
      my $foo = bar;
      }
      }

      Don't know if it's a perl syntax feature or bug, but I'd like to change it in
      my syntax, what should I modify?

      TIA,

      Jorge M.

      --
      Jorge O. Martinez
      MIS Senior Associate
      FDCH-eMedia Inc.
      2400 Forbes Blvd., Suite 200
      Lanham, MD 20706
      E-mail => jmartinez@...
      Phone => (301)731-1228 ext. 105
      Fax => (301)731-0937
    • Gary Holloway
      Make sure your `cinkeys option does NOT contain a 0# . I ve got set cinkeys-=0# in my ftplugin/perl.vim (and sh.vim) ... -gary / FROM: Jorge O. Martinez
      Message 2 of 3 , Sep 3, 2002
        Make sure your `cinkeys' option does NOT contain a '0#'.

        I've got

        set cinkeys-=0#

        in my ftplugin/perl.vim (and sh.vim)

        :he 'cinkeys'

        -gary

        / FROM: "Jorge O. Martinez" <jmartinez@...>, Sep 3 10:41 2002
        | ABOUT: Perl syntax unwanted behavior
        |
        | Hi:
        |
        | When I have code like this:
        |
        | {
        | #comment
        | my $foo = bar;
        | {
        | #comment
        | my $foo = bar;
        | }
        | }
        |
        | and I indent it (%=), I would like my comments to be indented too, but all
        | indentation disappears for comments, and only code is indented correctly,
        | looking like this.
        |
        | {
        | #comment
        | my $foo = bar;
        | {
        | #comment
        | my $foo = bar;
        | }
        | }
        |
        | Don't know if it's a perl syntax feature or bug, but I'd like to change it in
        | my syntax, what should I modify?
        |
        | TIA,
        |
        | Jorge M.
        |
        | --
        | Jorge O. Martinez
        | MIS Senior Associate
        | FDCH-eMedia Inc.
        | 2400 Forbes Blvd., Suite 200
        | Lanham, MD 20706
        | E-mail => jmartinez@...
        | Phone => (301)731-1228 ext. 105
        | Fax => (301)731-0937
        |
        \ END: "Jorge O. Martinez"
      • Jorge O. Martinez
        Thanks, seems that s what I needed to do. Jorge M. ... -- Jorge O. Martinez MIS Senior Associate FDCH-eMedia Inc. 2400 Forbes Blvd., Suite 200 Lanham, MD 20706
        Message 3 of 3 , Sep 3, 2002
          Thanks, seems that's what I needed to do.

          Jorge M.

          Gary Holloway wrote:
          > Make sure your `cinkeys' option does NOT contain a '0#'.
          >
          > I've got
          >
          > set cinkeys-=0#
          >
          > in my ftplugin/perl.vim (and sh.vim)
          >
          > :he 'cinkeys'
          >
          > -gary
          >
          > / FROM: "Jorge O. Martinez" <jmartinez@...>, Sep 3 10:41 2002
          > | ABOUT: Perl syntax unwanted behavior
          > |
          > | Hi:
          > |
          > | When I have code like this:
          > |
          > | {
          > | #comment
          > | my $foo = bar;
          > | {
          > | #comment
          > | my $foo = bar;
          > | }
          > | }
          > |
          > | and I indent it (%=), I would like my comments to be indented too, but all
          > | indentation disappears for comments, and only code is indented correctly,
          > | looking like this.
          > |
          > | {
          > | #comment
          > | my $foo = bar;
          > | {
          > | #comment
          > | my $foo = bar;
          > | }
          > | }
          > |
          > | Don't know if it's a perl syntax feature or bug, but I'd like to change it in
          > | my syntax, what should I modify?
          > |
          > | TIA,
          > |
          > | Jorge M.
          > |
          > | --
          > | Jorge O. Martinez
          > | MIS Senior Associate
          > | FDCH-eMedia Inc.
          > | 2400 Forbes Blvd., Suite 200
          > | Lanham, MD 20706
          > | E-mail => jmartinez@...
          > | Phone => (301)731-1228 ext. 105
          > | Fax => (301)731-0937
          > |
          > \ END: "Jorge O. Martinez"
          >
          >


          --
          Jorge O. Martinez
          MIS Senior Associate
          FDCH-eMedia Inc.
          2400 Forbes Blvd., Suite 200
          Lanham, MD 20706
          E-mail => jmartinez@...
          Phone => (301)731-1228 ext. 105
          Fax => (301)731-0937
        Your message has been successfully submitted and would be delivered to recipients shortly.