Loading ...
Sorry, an error occurred while loading the content.

Re: [Q] Lazy startup of vim

Expand Messages
  • Peter Wright
    ... It would probably help if you also mentioned what C compiler (and the version) you used to compile Vim, as well as the hardware specs you re running it on.
    Message 1 of 3 , Sep 2, 2002
    • 0 Attachment
      On 02/09 15:26:52, ÃÖ°øÈÆ wrote:
      > I compiled vim 6.1 on Solaris 2.8
      > I didn't change configuration except for "--prefix".

      It would probably help if you also mentioned what C compiler (and the
      version) you used to compile Vim, as well as the hardware specs you're
      running it on. ;-)

      > After compiling vim , when I run vim, it took about 7~10 seconds
      > to start up. Why dose it take a long time ?

      It could just be that you're running Vim on a slow machine! *shrug*.
      Or that the machine is already heavily loaded running other stuff.

      You also haven't mentioned if you're running the "graphical" version
      of Vim[0] or the console version - though I presume it's probably the
      graphical version.

      Do you have any reason to believe that Vim _should_ start up faster on
      your machine? For example, have you run another version of Vim on the
      same machine and it started up much quicker? Does your current Vim
      _always_ take at least 7 seconds to start up?

      There are probably some compile-time options you can try to build an
      optimised executable - and if you remove the GUI options, eg:

      ./configure --enable-gui=no

      ...the resulting executable will certainly start up faster. :]

      If you post the results from doing

      :version

      in your current Vim into another email, people will probably be able to
      offer some more helpful suggestions.

      Pete.

      [0] And if you're running the GUI version, whether it's the GTK or
      Motif version... I think the configure script will pick GTK if it's
      available, otherwise Motif if it's available, otherwise I don't know.
      I don't think that it should make _much_ difference whether it's GTK
      or Motif, though.
      --
      http://akira.apana.org.au/~pete/
      Contrary to popular belief, Unix is user friendly.
      It just happens to be selective about who it makes friends with.
      -- Dave Parnas
    • Matt Kunze
      ... my bet would be that this is an x windows timeout. try: $ DISPLAY= vim or the like for your shell. i think this is because vim attempts to contact x for
      Message 2 of 3 , Sep 3, 2002
      • 0 Attachment
        최공훈 wrote:
        > I compiled vim 6.1 on Solaris 2.8
        > I didn't change configuration except for "--prefix".
        >
        > After compiling vim , when I run vim, it took about 7~10 seconds to start up.
        > Why dose it take a long time ?
        >
        my bet would be that this is an x windows timeout. try:

        $ DISPLAY='' vim

        or the like for your shell. i think this is because vim attempts to
        contact x for the clipboard. someone posted a message about a
        commandline switch to turn this off a couple of weeks ago

        --

        .o0O0o.__.o0O0o.__.o0O0o.__.o0O0o.__.o0O0o.__.o0O0o.__.o0O0o.
        | Matt Kunze There is a fine line |
        | Build Master Fooly Fool between sayings that |
        | 970.484.0841 x 2205 make sense. |
        =============================================================
      Your message has been successfully submitted and would be delivered to recipients shortly.