Loading ...
Sorry, an error occurred while loading the content.

Re: [vim] To Dr. Chip: Comments on engspchk.vim plugin

Expand Messages
  • Charles E. Campbell
    ... I don t know why either address is bouncing mail; I was unaware that it was doing so. I know that if you send attachments to
    Message 1 of 2 , Aug 2, 2002
    • 0 Attachment
      Thus saith yahoogroups@...:
      > charles.campbell.1@... is bouncing back. cec@... is
      > also bouncing! what is a good email address for you?
      > ---x---

      I don't know why either address is bouncing mail; I was unaware that it
      was doing so. I know that if you send attachments to
      charles.campbell.1@... that the email reflector will bounce
      messages (Goddard no longer trusts attachments) if they end in a binary
      or script suffix (*.exe *.com *.vbs etc) to prevent viruses.

      Hmm -- I see that the email reflector somehow thinks that
      Charles.Campbell.1@... is ambiguous, but
      Charles.Campbell@... isn't. The full address is

      The cec@... email should work. I don't know why
      email to it would have bounced (of course, its an old SGI so it doesn't
      grok attachments anyway).

      > Your engspchk.vim plugin looks very cool. Few comments:

      Thank you!

      > 1. I don't see the Webster 1913 dictionary wb1913_engspchk.vim file in your
      > latest tarball. Where can I get this? Is this no longer needed?

      Sorry 'bout that! I'm planning on a new release of <engspchk.vim>
      soon so I'll make sure its included.

      > 2. I put engspchk.vim in my plugin folder.
      > Now when I :bd! my buffer and start to edit a new buffer, your plugin
      > stops working. Even the menu entry has changed to EngSpchk (ie.. the
      > Load dictionary entry is gone). What is going on? How can I make this
      > is a global always-active plugin?

      Engspchk is a syntax highlighting-based spelling checker. Syntax is
      associated with buffers (read a new buffer, get new syntax
      highlighting). Most syntax highlighting files contain a "syn clear"
      instruction which removes any previous syntax highlighting, including

      One way to keep the syntax highlighting loaded is to use

      :0r (filename goes here)

      You could make a map for :wq and :bd to do that instead (the writer of
      the Hebrew version of engspchk did that) but having unexpected things
      happen from the user's viewpoint makes me nervous.

      > When I re-load it manually using \ec ,I get 'No menu by that name'.
      > Presumably I get this because the plugin tries to aunmenu DrChip.Load
      > Dictionary item?

      I've now added an extra line to the DrChip menu that says "Reload
      Engspchk". Its actually an "unmenu", but your presumption is
      otherwise correct. I've preceded the unmenu with a "silent!" which
      should at least suppress the error message.

      > 3. Related to (2) above, if I want to temporarily disable the
      > spell-checking for a particular buffer (because I am typing technical
      > words or typing in a non-English language or whatever), how can I do
      > it?

      Here are several approaches:

      1) type your technical words, but use \et to temporarily or
      \es to permanently save the word into your personal

      2) syn clear (will need to re-load via \ec)

      3) hi link BadWord None (use "hi link BadWord Error" to

      In the email to my Charles.Campbell@... (which goes to my PC)
      you asked how to set up your personal dictionary. Other than setting
      CVIMSYN (or let $CVIMSYN=... in your <.vimrc>) to specify a path, the
      "\es" map will handle things. Engspchk itself will check if the user
      dictionary is present and if so will automatically load it.

      Chip Campbell

      Charles E Campbell, Jr, PhD _ __ __
      Goddard Space Flight Center / /_/\_\_/ /
      cec@... /_/ \/_//_/
      PGP public key: http://www.erols.com/astronaut/pgp.html
    Your message has been successfully submitted and would be delivered to recipients shortly.