Loading ...
Sorry, an error occurred while loading the content.
 

Re: behave xterm problem with win32 gvim 6.1

Expand Messages
  • Benji Fisher
    ... One thing that changed in vim 6.0 is the interaction with the X11 buffers. Are you using vim on Linux? If so, have a look at ... I am not sure what the
    Message 1 of 5 , Jul 31, 2002
      Tim Preece wrote:
      >
      > I mean using the mouse to select and then middle button to paste.
      > >
      > > Is there a problem with behave xterm in 6.1 ?
      > >
      > > I have just upgraded, and have set up my _vimrc as before in 5.8, however
      > > the visual mode ( cut and paste ) fails unless I select cut and paste from
      > > the menu.

      One thing that changed in vim 6.0 is the interaction with the X11 buffers.
      Are you using vim on Linux? If so, have a look at

      :help x11-selection

      I am not sure what the recommended solution is, but as a work-around, you might
      try

      :map <MiddleMouse> "+gP

      because I think the problem is that <MiddleMouse> uses the "* register by
      default, and the Edit.Paste manu item uses "+ .

      :menu Edit.Paste

      HTH --Benji Fisher
    • Tim Preece
      Thanks, I looked into the registers bit folowed it through to the windows clipboard and hey presto found the answer in options.txt.... set guioptions+=a
      Message 2 of 5 , Jul 31, 2002
        Thanks,

        I looked into the registers bit folowed it through to the windows clipboard
        and hey presto found the answer in options.txt....

        set guioptions+=a

        Everything is back to normal, I think that this may have been a default
        before.

        Tim

        -----Original Message-----
        From: Benji Fisher [mailto:benji@...]
        Sent: 31 July 2002 14:27
        To: Tim Preece
        Cc: vim@...
        Subject: Re: behave xterm problem with win32 gvim 6.1


        Tim Preece wrote:
        >
        > I mean using the mouse to select and then middle button to paste.
        > >
        > > Is there a problem with behave xterm in 6.1 ?
        > >
        > > I have just upgraded, and have set up my _vimrc as before in 5.8,
        however
        > > the visual mode ( cut and paste ) fails unless I select cut and paste
        from
        > > the menu.

        One thing that changed in vim 6.0 is the interaction with the X11
        buffers.
        Are you using vim on Linux? If so, have a look at

        :help x11-selection

        I am not sure what the recommended solution is, but as a work-around, you
        might
        try

        :map <MiddleMouse> "+gP

        because I think the problem is that <MiddleMouse> uses the "* register by
        default, and the Edit.Paste manu item uses "+ .

        :menu Edit.Paste

        HTH --Benji Fisher
      Your message has been successfully submitted and would be delivered to recipients shortly.