Loading ...
Sorry, an error occurred while loading the content.
 

[Fwd: Vim/Cygwin/Windows 2000]

Expand Messages
  • Benji Fisher
    Subject: Re: Vim/Cygwin/Windows 2000 Date: Tue, 2 Jul 2002 11:02:57 -0700 (PDT) From: Hari Krishna Dara To: Benji Fisher
    Message 1 of 2 , Jul 2, 2002
      Subject:
      Re: Vim/Cygwin/Windows 2000
      Date:
      Tue, 2 Jul 2002 11:02:57 -0700 (PDT)
      From:
      Hari Krishna Dara <hari_vim@...>
      To:
      Benji Fisher <fisherbb@...>




      --- Benji Fisher <fisherbb@...> wrote:
      > On Monday, July 1, 2002, at 11:44 AM, Scott LaBounty wrote:
      >
      > > Since I've moved to Windows 2000 when I do a :cd /xyz (i.e. I change to
      > > a new directory) the directory shown by bash through a :!ls is not the
      > > same as the vim directory. In other words the vim directory and the bash
      > > directory are out of sync with each other. With both Windows 98 and
      > > Windows NT, I don't recall having to do anything special to get this to
      > > work. Any ideas?
      >
      > Here is a stab in the dark. Maybe the W2K shell has something like
      > a .cshrc file that makes every new (interactive?) shell start up in the
      > home directory? Look it up in the MS documentation. ;)
      >
      > HTH --Benji Fisher
      >

      On the same lines,

      - check if you have vim shell setting to start bash in login mode (or
      interactive mode).
      - if so, check if you have your .bashrc if it has a cd command.

      Hari
    • Scott LaBounty
      Benji, You got it. I was doing a cd / in my .bashrc file which was the problem. For anyone else doing this my solution was to set my shell thus (there are
      Message 2 of 2 , Jul 3, 2002
        Benji,

        You got it. I was doing a cd / in my .bashrc file which was the problem.
        For anyone else doing this my solution was to set my shell thus (there
        are probably other ways) :

        set shell=bash\ --norc " Use the bash shell without reading a .bashrc
        file

        Thanks to all,

        Scott LaBounty
        Nexa Technologies

        -----Original Message-----
        From: Benji Fisher [mailto:benji@...]
        Sent: Tuesday, July 02, 2002 7:59 PM
        To: Vim mailing list
        Subject: [Fwd: Vim/Cygwin/Windows 2000]


        Subject:
        Re: Vim/Cygwin/Windows 2000
        Date:
        Tue, 2 Jul 2002 11:02:57 -0700 (PDT)
        From:
        Hari Krishna Dara <hari_vim@...>
        To:
        Benji Fisher <fisherbb@...>




        --- Benji Fisher <fisherbb@...> wrote:
        > On Monday, July 1, 2002, at 11:44 AM, Scott LaBounty wrote:
        >
        > > Since I've moved to Windows 2000 when I do a :cd /xyz (i.e. I change

        > > to a new directory) the directory shown by bash through a :!ls is
        > > not the same as the vim directory. In other words the vim directory
        > > and the bash directory are out of sync with each other. With both
        > > Windows 98 and Windows NT, I don't recall having to do anything
        > > special to get this to work. Any ideas?
        >
        > Here is a stab in the dark. Maybe the W2K shell has something
        > like
        > a .cshrc file that makes every new (interactive?) shell start up in
        the
        > home directory? Look it up in the MS documentation. ;)
        >
        > HTH --Benji Fisher
        >

        On the same lines,

        - check if you have vim shell setting to start bash in login mode (or
        interactive mode).
        - if so, check if you have your .bashrc if it has a cd command.

        Hari
      Your message has been successfully submitted and would be delivered to recipients shortly.