Loading ...
Sorry, an error occurred while loading the content.

Re: Trying to compile vim and gvim on Solaris

Expand Messages
  • P. Alejandro Lopez-Valencia
    ... From: Walter Usyk To: Sent: Tuesday, July 02, 2002 11:07 AM Subject: Trying to compile vim and gvim on Solaris
    Message 1 of 5 , Jul 2, 2002
    • 0 Attachment
      ----- Original Message -----
      From: "Walter Usyk" <wusyk@...>
      To: <vim@...>
      Sent: Tuesday, July 02, 2002 11:07 AM
      Subject: Trying to compile vim and gvim on Solaris


      > I have a Solaris 2.8 OS and I'm trying to compile a gvim version of
      vim
      > 6.1. I was successful for HP 10.20 with just running the './configure'
      > which created the vim and gvim executables.
      >
      > I would like to do the same for Sun. I have tried just running
      > './configure' and it only creates the vim executable.
      >
      > Can someone help me and tell me which options I need to specify for
      > configure to get a gvim executable.
      >

      If using the default CDE desktop:

      If using SunPro/Forte

      bash-1.25a-$ CC=cc CFLAGS="-xO2 -xtarget=native \
      -I/usr/include -I/usr/openwin/include -I/usr/dt/include \
      -I/usr/local/include" LDFAGS="-s -L/usr/lib -L/usr/openwin/lib \
      -L/usr/dt/lib -L/usr/local/lib \
      -R/usr/lib:/usr/openwin/lib:/usr/dt/lib:/usr/local/lib" \
      ./configure --with-features=big --enable-gui=motif


      If using gcc:

      bash-1.25a-$ CC=gcc CFLAGS="-O2 -fexpensive-optimizations \
      -fno-strength-reduce \
      -I/usr/include -I/usr/openwin/include -I/usr/dt/include \
      -I/usr/local/include" LDFAGS="-s -L/usr/lib -L/usr/openwin/lib \
      -L/usr/dt/lib -L/usr/local/lib \
      -R/usr/lib:/usr/openwin/lib:/usr/dt/lib:/usr/local/lib" \
      ./configure --with-features=big --enable-gui=motif


      unless you are using GNU binutils, where you use a different syntax:

      bash-1.25a-$ CC=gcc CFLAGS="-O2 -fexpensive-optimizations \
      -fno-strength-reduce \
      -I/usr/include -I/usr/openwin/include -I/usr/dt/include \
      -I/usr/local/include" LDFAGS="-s -L/usr/lib -L/usr/openwin/lib \
      -L/usr/dt/lib -L/usr/local/lib \
      -rpath /usr/lib -rpath /usr/openwin/lib \
      -rpath /usr/dt/lib -rpath /usr/local/lib" \
      ./configure --with-features=big --enable-gui=motif

      If using gcc, prepare yourself for a bunch of warnings in the X11
      headers, they are harmless, I know there is a compiler option to turn
      off the noise but I never remember which one.
    Your message has been successfully submitted and would be delivered to recipients shortly.