Loading ...
Sorry, an error occurred while loading the content.

Re: Trying to compile vim and gvim on Solaris

Expand Messages
  • Colin Keith
    ... ./configure uses --with-gui=auto by default: openbox% ( cd /usr/local/src/vim61/ ; ./configure --help ) |grep gui --enable-gui[=OPTS] X11 GUI
    Message 1 of 5 , Jul 2, 2002
    View Source
    • 0 Attachment
      On Tue, Jul 02, 2002 at 12:07:44PM -0400, Walter Usyk wrote:
      > './configure' and it only creates the vim executable.

      ./configure uses --with-gui=auto by default:


      openbox% ( cd /usr/local/src/vim61/ ; ./configure --help ) |grep gui
      --enable-gui[=OPTS] X11 GUI [default=auto] [OPTS=auto/no/gtk/gnome/motif/athena/beos/photon]

      If you're not getting the GUI built, it didn't find the right components.
      Re-run ./configure and look at the output to see what its searching for
      and what it isn't finding. IIRC if you force the GUI then configure will
      die if it can't find the necessary libraries (as opposed to just ignoring
      it if you leave it set on auto). config.log is in src/auto, if you want
      the verbose output, look in there.

      --
      Then graphics games came along and the computer using portion of the human race
      forgot all about 500,000 years of language evolution and went straight back to
      the electronic equivalent of banging rocks together - the point'n'click game
      - http://www.douglasadams.com/creations/infocomjava.html
    • Walter Usyk
      I have a Solaris 2.8 OS and I m trying to compile a gvim version of vim 6.1. I was successful for HP 10.20 with just running the ./configure which created
      Message 2 of 5 , Jul 2, 2002
      View Source
      • 0 Attachment
        I have a Solaris 2.8 OS and I'm trying to compile a gvim version of vim
        6.1. I was successful for HP 10.20 with just running the './configure'
        which created the vim and gvim executables.

        I would like to do the same for Sun. I have tried just running
        './configure' and it only creates the vim executable.

        Can someone help me and tell me which options I need to specify for
        configure to get a gvim executable.

        Thanks for your help

        --
        Walter Usyk - Tools Developer
        Software Development Environment Tools (1P67)
        email: wusyk@...
        ESN: 398-4603
        Tel: (613) 768-4603
      • Antoine J. Mechelynck
        On some platforms you can use a single executable and it will try to start in the GUI if it s called vim -g or gvim so you can setup a symlink from gvim to
        Message 3 of 5 , Jul 2, 2002
        View Source
        • 0 Attachment
          On some platforms you can use a single executable and it will try to start
          in the GUI if it's called "vim -g" or "gvim" so you can setup a symlink from
          gvim to vim and have both for the price of one.

          HTH,
          Tony.
          ----- Original Message -----
          From: "Colin Keith" <vim@...>
          To: <vim@...>
          Sent: Tuesday, July 02, 2002 6:06 PM
          Subject: Re: Trying to compile vim and gvim on Solaris


          > On Tue, Jul 02, 2002 at 12:07:44PM -0400, Walter Usyk wrote:
          > > './configure' and it only creates the vim executable.
          >
          > ./configure uses --with-gui=auto by default:
          >
          >
          > openbox% ( cd /usr/local/src/vim61/ ; ./configure --help ) |grep gui
          > --enable-gui[=OPTS] X11 GUI [default=auto]
          [OPTS=auto/no/gtk/gnome/motif/athena/beos/photon]
          >
          > If you're not getting the GUI built, it didn't find the right components.
          > Re-run ./configure and look at the output to see what its searching for
          > and what it isn't finding. IIRC if you force the GUI then configure will
          > die if it can't find the necessary libraries (as opposed to just ignoring
          > it if you leave it set on auto). config.log is in src/auto, if you want
          > the verbose output, look in there.
          >
          > --
          > Then graphics games came along and the computer using portion of the human
          race
          > forgot all about 500,000 years of language evolution and went straight
          back to
          > the electronic equivalent of banging rocks together - the point'n'click
          game
          > - http://www.douglasadams.com/creations/infocomjava.html
          >
        • Douglas L . Potts
          ... Yes, this is the case. And if you run make install , it will set it up this way for you. HTH, -Doug --
          Message 4 of 5 , Jul 2, 2002
          View Source
          • 0 Attachment
            On Tue, Jul 02, 2002 at 06:23:14PM +0200 Antoine J. Mechelynck wrote:
            > On some platforms you can use a single executable and it will try to start
            > in the GUI if it's called "vim -g" or "gvim" so you can setup a symlink from
            > gvim to vim and have both for the price of one.

            Yes, this is the case. And if you run 'make install', it will set it up
            this way for you.

            HTH,
            -Doug

            --
            *=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
            Douglas L. Potts
            So when I saw the post to comp.editors, I rushed over to the FTP site to
            grab it. So I yank apart the tarball, light x candles, where x= the
            vim version multiplied by the md5sum of the source divided by the MAC of
            my NIC (8A3FA78155A8A1D346C3C4A), put on black robes, dim the lights,
            wave a dead chicken over the hard drive, and summon the power of GNU GCC
            with the magic words "make config ; make!".
            [Jason Spence, compiling Vim 5.0]
            GPG Fingerprint: 768A EEF8 197A 4C9A 5EF7 DA5B 464C 97DF DCD5 68C2
            *=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
          • P. Alejandro Lopez-Valencia
            ... From: Walter Usyk To: Sent: Tuesday, July 02, 2002 11:07 AM Subject: Trying to compile vim and gvim on Solaris
            Message 5 of 5 , Jul 2, 2002
            View Source
            • 0 Attachment
              ----- Original Message -----
              From: "Walter Usyk" <wusyk@...>
              To: <vim@...>
              Sent: Tuesday, July 02, 2002 11:07 AM
              Subject: Trying to compile vim and gvim on Solaris


              > I have a Solaris 2.8 OS and I'm trying to compile a gvim version of
              vim
              > 6.1. I was successful for HP 10.20 with just running the './configure'
              > which created the vim and gvim executables.
              >
              > I would like to do the same for Sun. I have tried just running
              > './configure' and it only creates the vim executable.
              >
              > Can someone help me and tell me which options I need to specify for
              > configure to get a gvim executable.
              >

              If using the default CDE desktop:

              If using SunPro/Forte

              bash-1.25a-$ CC=cc CFLAGS="-xO2 -xtarget=native \
              -I/usr/include -I/usr/openwin/include -I/usr/dt/include \
              -I/usr/local/include" LDFAGS="-s -L/usr/lib -L/usr/openwin/lib \
              -L/usr/dt/lib -L/usr/local/lib \
              -R/usr/lib:/usr/openwin/lib:/usr/dt/lib:/usr/local/lib" \
              ./configure --with-features=big --enable-gui=motif


              If using gcc:

              bash-1.25a-$ CC=gcc CFLAGS="-O2 -fexpensive-optimizations \
              -fno-strength-reduce \
              -I/usr/include -I/usr/openwin/include -I/usr/dt/include \
              -I/usr/local/include" LDFAGS="-s -L/usr/lib -L/usr/openwin/lib \
              -L/usr/dt/lib -L/usr/local/lib \
              -R/usr/lib:/usr/openwin/lib:/usr/dt/lib:/usr/local/lib" \
              ./configure --with-features=big --enable-gui=motif


              unless you are using GNU binutils, where you use a different syntax:

              bash-1.25a-$ CC=gcc CFLAGS="-O2 -fexpensive-optimizations \
              -fno-strength-reduce \
              -I/usr/include -I/usr/openwin/include -I/usr/dt/include \
              -I/usr/local/include" LDFAGS="-s -L/usr/lib -L/usr/openwin/lib \
              -L/usr/dt/lib -L/usr/local/lib \
              -rpath /usr/lib -rpath /usr/openwin/lib \
              -rpath /usr/dt/lib -rpath /usr/local/lib" \
              ./configure --with-features=big --enable-gui=motif

              If using gcc, prepare yourself for a bunch of warnings in the X11
              headers, they are harmless, I know there is a compiler option to turn
              off the noise but I never remember which one.
            Your message has been successfully submitted and would be delivered to recipients shortly.