Loading ...
Sorry, an error occurred while loading the content.

GVIM no longer starts remotely

Expand Messages
  • Kevin Cosgrove
    I used to be able to use gvim on a remote host and view it within X on a local host. Then I changed from an Ultra10 running Solaris 8 and it s version of X to
    Message 1 of 1 , Feb 26, 2002
    • 0 Attachment
      I used to be able to use gvim on a remote host and view it
      within X on a local host. Then I changed from an Ultra10 running
      Solaris 8 and it's version of X to a Compaq running Solaris and
      XFree86. Initially I couldn't run gvim on the remote host. Then
      I set the Xconfig for the remote machine to have the same screen
      resolution as the local machine. After doing this, I could run
      gvim remotely. I'm not sure if what I did actually was the cause
      of making it work. Now it doesn't work again.

      The error I get is:

      BadMatch (invalid parameter attributes)
      Vim: Got X error
      Vim: Finished.

      I looked through the VIM FAQ -- nothing there.
      I looked through the VIM mailing list archives -- nothing there.
      I looked through google -- it seems there was a problem in
      relation with Exceed, which I'm not using, and a problem with
      $WINDOWID being set badly, which doesn't seem to be my problem.
      That's all I can find on the subject.

      Does anyone have any ideas as to how to debug this or get it to
      work? It would be cool if vim would spit out debugging info that
      I could look at.

      I'm running XFree86 4.1.0 on both systems, vim 6.0 on the remote
      system, and vim 5.7 on the local system. I can run gvim on the local
      system and have it export to the remote system via X just fine. It's
      the other way around that's busted.

      Thanks in advance....
    Your message has been successfully submitted and would be delivered to recipients shortly.