Loading ...
Sorry, an error occurred while loading the content.
 

opening files in win NT

Expand Messages
  • John Kilbourne
    I have set the Windows Explorer settings (View- Options- FileTypes- ... file extensions, but when I double click on such files I get a blank gvim window. I
    Message 1 of 5 , Jan 1, 2002
      I have set the Windows Explorer settings (View->Options->FileTypes-
      >etc.) to use GVim as the default file opener for C,cpp and other
      file extensions, but when I double click on such files I get a blank
      gvim window. I must go to File-Open and manually open the file to be
      able to edit in GVim. I don't know if this is a Windows problem or a
      vim problem, but it is *my* problem. How can I make it so I can
      double click on a file to edit it in Windows?

      Thank you.

      John
    • dman
      ... It s a windows problem (but can appear on unices as well). There are 2 solutions : 1) don t put spaces in the path name! 2) quote the argument (you know
      Message 2 of 5 , Jan 1, 2002
        On Tue, Jan 01, 2002 at 05:14:04PM -0500, John Kilbourne wrote:
        | I have set the Windows Explorer settings (View->Options->FileTypes-
        | >etc.) to use GVim as the default file opener for C,cpp and other
        | file extensions, but when I double click on such files I get a blank
        | gvim window. I must go to File-Open and manually open the file to be
        | able to edit in GVim. I don't know if this is a Windows problem or a
        | vim problem, but it is *my* problem. How can I make it so I can
        | double click on a file to edit it in Windows?

        It's a windows problem (but can appear on unices as well). There are
        2 solutions :
        1) don't put spaces in the path name!
        2) quote the argument (you know where you said to use
        'c:\blah\gvim.exe' to open the files? instead tell
        windows to use 'c:\blah\gvim.exe "%1"')

        -D

        --

        Failure is not an option. It is bundled with the software.
      • John Kilbourne
        I don t know if i messed up somehting in doing this, but I do not have a gvim.exe %1 file, just a gvim.exe, which I have set as the executable. How
        Message 3 of 5 , Jan 2, 2002
          I don't know if i messed up somehting in doing this, but I do not
          have a "gvim.exe" "%1" file, just a gvim.exe, which I have set as the
          executable. How important is the -space_percent_1 part, and how do I
          get that file back?

          Thanks.
          John




          ------------------ Reply Separator --------------------
          Originally From: "Alex Angelopoulos" <alex@...>
          Subject: Re: opening files in win NT
          Date: 01/01/2002 05:54pm


          Make sure GVim is set as the registered handler for openiong those,
          of course. To get it to open correctly, if you go and check the
          file types, you shuld have something like this defined as the command
          for opening -

          "C:\apps\Alt_Edit\Vim\vim60\gvim.exe" "%1"

          A simple trick I always do is put a shortcut to vim into my "SendTo"
          folder - this opens things correctly even if there are spaces
          in the path, since Windows correctly interprets it.


          ----- Original Message -----
          From: "John Kilbourne" <jkilbour@...>
          To: <vim@...>
          Sent: Tuesday/2002 January 01 17:14
          Subject: opening files in win NT


          : I have set the Windows Explorer settings (View->Options->FileTypes-
          : >etc.) to use GVim as the default file opener for C,cpp and other
          : file extensions, but when I double click on such files I get a blank
          : gvim window. I must go to File-Open and manually open the file to be
          : able to edit in GVim. I don't know if this is a Windows problem or a
          : vim problem, but it is *my* problem. How can I make it so I can
          : double click on a file to edit it in Windows?
          :
          : Thank you.
          :
          : John
        • Carson Wilcox
          Any chance this group could be split into M$ and a *nix groups? ... _____________________________________________________________ Want a new web-based email
          Message 4 of 5 , Jan 2, 2002
            Any chance this group could be split into M$ and a *nix groups?


            --- John Kilbourne <jkilbour@...> wrote:
            >I don't know if i messed up somehting in doing this, but I do not
            >have a "gvim.exe" "%1" file, just a gvim.exe, which I have set as the
            >executable. How important is the -space_percent_1 part, and how do I
            >get that file back?
            >
            >Thanks.
            >John
            >
            >
            >
            >
            >------------------ Reply Separator --------------------
            >Originally From: "Alex Angelopoulos" <alex@...>
            >Subject: Re: opening files in win NT
            >Date: 01/01/2002 05:54pm
            >
            >
            >Make sure GVim is set as the registered handler for openiong those,
            >of course. To get it to open correctly, if you go and check the
            >file types, you shuld have something like this defined as the command
            >for opening -
            >
            >"C:\apps\Alt_Edit\Vim\vim60\gvim.exe" "%1"
            >
            >A simple trick I always do is put a shortcut to vim into my "SendTo"
            >folder - this opens things correctly even if there are spaces
            >in the path, since Windows correctly interprets it.
            >
            >
            >----- Original Message -----
            >From: "John Kilbourne" <jkilbour@...>
            >To: <vim@...>
            >Sent: Tuesday/2002 January 01 17:14
            >Subject: opening files in win NT
            >
            >
            >: I have set the Windows Explorer settings (View->Options->FileTypes-
            >: >etc.) to use GVim as the default file opener for C,cpp and other
            >: file extensions, but when I double click on such files I get a blank
            >: gvim window. I must go to File-Open and manually open the file to be
            >: able to edit in GVim. I don't know if this is a Windows problem or a
            >: vim problem, but it is *my* problem. How can I make it so I can
            >: double click on a file to edit it in Windows?
            >:
            >: Thank you.
            >:
            >: John

            _____________________________________________________________
            Want a new web-based email account ? ---> http://www.firstlinux.net
          • dman
            ... If you leave out that %1, then gvim gets no arguments and doesn t have any clue that you double-clicked on a file or that you want to open it. The %1 is a
            Message 5 of 5 , Jan 2, 2002
              On Wed, Jan 02, 2002 at 11:49:16AM -0500, John Kilbourne wrote:
              | I don't know if i messed up somehting in doing this, but I do not
              | have a "gvim.exe" "%1" file, just a gvim.exe, which I have set as the
              | executable. How important is the -space_percent_1 part,

              If you leave out that %1, then gvim gets no arguments and doesn't have
              any clue that you double-clicked on a file or that you want to open
              it. The %1 is a placeholder for the first argument (the file name).
              Just putting <space>%1 is a problem though if you put spaces in a file
              name because space separates arguments. Thus you need to quote the
              argument to keep the spaces where they belong.

              -D

              --

              Only two things are infinite, the universe and human stupidity, and I'm
              not sure about the former.
              Albert Einstein
            Your message has been successfully submitted and would be delivered to recipients shortly.