Loading ...
Sorry, an error occurred while loading the content.

Re: win32 env variables

Expand Messages
  • Bram Moolenaar
    ... This is probably not a Vim problem, but caused by the DOS command.com using the initial environment instead of the one from the program it was started by.
    Message 1 of 2 , Dec 28, 2001
    • 0 Attachment
      Benoit Cerrina wrote:

      > it seems that when I set an environment variable using
      > let $toto='titi'
      > it is not set for the child process launched with :!
      > (I guess this is true for other ways of launching a subprocess).
      > This looks like a bug and in any case is bothersome when
      > using an external tool (like cvs when using the excelent cvsmenu.vim
      > plugin)

      This is probably not a Vim problem, but caused by the DOS command.com
      using the initial environment instead of the one from the program it was
      started by. The help files mention something about the difference
      between a child shell and a startup shell, but it's not clear how
      command.com decides what to do.

      You might get better behavior by setting 'shell' to
      something else than command.com (e.g., a Unix-like shell). But then
      other things might break...

      --
      hundred-and-one symptoms of being an internet addict:
      251. You've never seen your closest friends who usually live WAY too far away.

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
    Your message has been successfully submitted and would be delivered to recipients shortly.