Loading ...
Sorry, an error occurred while loading the content.
 

Re: Indents in Java Source files...

Expand Messages
  • Bram Moolenaar
    Will Rutherdale wrote: [please send messages as plain text, not base64] ... It will probably work a lot better if you delete Vim 6.0z and install Vim 6.0.
    Message 1 of 7 , Dec 28, 2001
      Will Rutherdale wrote:

      [please send messages as plain text, not base64]

      > Vim 6.0 Bug Alert!!!!!
      >
      > I tried adding this to my vimrc file:
      >
      > :filetype on
      > :filetype plugin indent off
      >
      > as recommended in the help pages.
      >
      > Vim didn't complain about these entries as such. However, these
      > changes did sniff out a bug in the startup .vim files. The editor
      > complained bitterly as follows:
      >
      > Error detected while processing /usr/share/vim/vim60z/ftplugof.vim:
      > line 11:
      > No such event: filetypeplugin *
      > Error detected while processing /usr/share/vim/vim60z/indoff.vim:
      > line 11:
      > No such event: filetypeindent *
      >
      > Furthermore, it didn't achieve the intended effect. When I tried
      > editing a C++ file, I was still thrown into cindent mode for the local
      > buffer.

      It will probably work a lot better if you delete Vim 6.0z and install
      Vim 6.0. 6.0z was only an alpha version.

      --
      hundred-and-one symptoms of being an internet addict:
      247. You use www.switchboard.com instead of dialing 411 and 555-12-12
      for directory assistance.

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
    • Will Rutherdale
      Vim 6.0 Bug Alert!!!!! ... as recommended in the help pages. Vim didn t complain about these entries as such. However, these changes did sniff out a bug in
      Message 2 of 7 , Dec 28, 2001
        Vim 6.0 Bug Alert!!!!!

        I tried adding this to my vimrc file:

        :filetype on
        :filetype plugin indent off

        as recommended in the help pages.

        Vim didn't complain about these entries as such. However, these changes did sniff
        out a bug in the startup .vim files. The editor complained bitterly as follows:

        Error detected while processing /usr/share/vim/vim60z/ftplugof.vim:
        line 11:
        No such event: filetypeplugin *
        Error detected while processing /usr/share/vim/vim60z/indoff.vim:
        line 11:
        No such event: filetypeindent *

        Furthermore, it didn't achieve the intended effect. When I tried editing a C++ file,
        I was still thrown into cindent mode for the local buffer.

        -Will

        Benji Fisher wrote:

        > By default, vim runs in compatible mode. Like plain old vi, it has one
        > level of undo, no syntax highlighting, no automatic indenting. Blame the
        > read-only, system-wide vimrc file for turning on the extra features.
        >
        > To turn off automatic indenting, try adding
        >
        > :filetype indent off
        >
        > to your vimrc file. For further options, read
        >
        > :help :filetype-overview
        >
        > or, for a more complete explanation, start reading above that,
        >
        > :help filetypes
        >
        > For other changes introduced with vim 6.0, read
        >
        > :help version6
        >
        > This leads you (after following a couple of links) to
        >
        > :help 30.3
        >
        > in the users' manual, which also explains the :filetype command. (I think
        > that there will be additional, more descriptive, tags in the users' manual for
        > vim 6.1.)
        >
        > HTH --Benji Fisher
      • Justin James
        ... using :set shiftwidth=4 fixed my issue w/java source files. ... Have you tried :set nosmartindent? - Justin
        Message 3 of 7 , Dec 28, 2001
          >I've spent several hours messing around with it
          >and haven't got it straightened out yet.

          using :set shiftwidth=4 fixed my issue w/java
          source files.

          >I tried this line in my .vimrc to no avail:
          >:set nocindent

          Have you tried :set nosmartindent?

          - Justin
        Your message has been successfully submitted and would be delivered to recipients shortly.