Loading ...
Sorry, an error occurred while loading the content.

copying to selection register fails

Expand Messages
  • vipin aravind
    folks, I am noticing something unusual with cygwin:- my file is like this:- aaabbb aaa bbb I go to the first line do 1) +y$. I can see that it
    Message 1 of 4 , Nov 27, 2001
    • 0 Attachment
      folks,
      I  am noticing  something  unusual  with  cygwin:-
      my file  is like  this:-
       
      aaabbb
      aaa bbb
       
       
      I  go to the  first line  do
      1)"+y$.   I  can  see  that it is in the  register +. 
      2):g/aaa/d
      3) "+p.   
      aaa  is getting  pasted  and not  aaabbb.
       
      same  thing  works  properly  on the  win32 build.
      vipin
       
       
       
    • Benji Fisher
      ... I am not sure exactly what is happening, but it looks as though the + register is used for the :d operation in your :global line. Probably the different
      Message 2 of 4 , Nov 28, 2001
      • 0 Attachment
        > vipin aravind wrote:
        >
        > folks,
        > I am noticing something unusual with cygwin:-
        > my file is like this:-
        >
        > aaabbb
        > aaa bbb
        >
        >
        > I go to the first line do
        > 1)"+y$. I can see that it is in the register +.
        > 2):g/aaa/d
        > 3) "+p.
        > aaa is getting pasted and not aaabbb.
        >
        > same thing works properly on the win32 build.
        > vipin

        I am not sure exactly what is happening, but it looks as though the "+
        register is used for the :d operation in your :global line. Probably the
        different versions of vim have different defaults for the 'clipboard' option.
        Try fiddling with that, and see whether you can get the same behavior with
        both platforms.

        HTH --Benji Fisher
      • Strohhaecker, Bernd
        ... + ... option. ... Cygwin s vim - at least my one - is compiled with -clipboard . This seems to behave like setting clipboard=unnamed in win32 s
        Message 3 of 4 , Nov 29, 2001
        • 0 Attachment
          > -----Urspr√ľngliche Nachricht-----
          > Von: Benji Fisher [SMTP:benji@...]
          > Gesendet am: Donnerstag, 29. November 2001 03:02
          > An: vipin aravind
          > Cc: vim@...
          > Betreff: Re: copying to selection register fails
          >
          > > vipin aravind wrote:
          > >
          > > folks,
          > > I am noticing something unusual with cygwin:-
          > > my file is like this:-
          > >
          > > aaabbb
          > > aaa bbb
          > >
          > >
          > > I go to the first line do
          > > 1)"+y$. I can see that it is in the register +.
          > > 2):g/aaa/d
          > > 3) "+p.
          > > aaa is getting pasted and not aaabbb.
          > >
          > > same thing works properly on the win32 build.
          > > vipin
          >
          > I am not sure exactly what is happening, but it looks as though the
          "+
          > register is used for the :d operation in your :global line. Probably the
          > different versions of vim have different defaults for the 'clipboard'
          option.
          > Try fiddling with that, and see whether you can get the same behavior with
          > both platforms.
          >
          > HTH --Benji Fisher
          >

          Cygwin's vim - at least my one - is compiled with '-clipboard'.
          This seems to behave like setting 'clipboard=unnamed' in win32's vim/gvim.

          For me ":g/aaa/d" sets the "+ register with the last deleteted line.
          This occurs in all three vim-versions.

          Bernd
        • Strohhaecker, Bernd
          ... Did you try setting clipboard to unnamed in your win32-versions ? Bernd
          Message 4 of 4 , Nov 29, 2001
          • 0 Attachment
            > -----Urspr√ľngliche Nachricht-----
            > Von: vipin aravind [SMTP:vipin.aravind@...]
            > Gesendet am: Donnerstag, 29. November 2001 11:22
            > An: Strohhaecker, Bernd
            > Cc: vim@...
            > Betreff: Fw: copying to selection register fails
            >
            > sorry to include you guys. message below.
            > vipin
            > ----- Original Message -----
            > From: "vipin aravind" <vipin.aravind@...>
            > To: <fisherbb@...>
            > Sent: Thursday, November 29, 2001 12:37 PM
            > Subject: Re: copying to selection register fails
            >
            >
            > > sorry for having not provided the features built.
            > > it is -clipboard in the cygwin-build and +clipboard in the win32
            > > build. probably it is because of it.
            > > modifying the features stuff doesn't look easy.
            > > clipboard is forced undefined.
            > > thanks
            > > vipin

            Did you try setting clipboard to 'unnamed' in your win32-versions ?

            Bernd
          Your message has been successfully submitted and would be delivered to recipients shortly.