Loading ...
Sorry, an error occurred while loading the content.

Re: copen vs. preview and wincmd p

Expand Messages
  • Gary Holloway
    Try setting splitbelow I turned splitbelow off, and it did work; when the preview window is at the top, and the quickfix window is at the bottom. Sorry bout
    Message 1 of 7 , Nov 1, 2001
    • 0 Attachment
      Try setting splitbelow

      I turned splitbelow off, and it did work; when the preview window is at the
      top, and the quickfix window is at the bottom.

      Sorry 'bout leaving that tidbit out. :)

      With splitbelow on, the C source is on top, below that is the preview window,
      and below that the quickfix window.

      -gary

      / FROM: Bram Moolenaar <Bram@...>, Nov 1 11:04 2001
      | ABOUT: Re: copen vs. preview and wincmd p
      |
      |
      | Gary Holloway wrote:
      |
      | > I'm in a C source file (current window).
      | > I've got a preview window displaying a tag.
      | >
      | > I type :copen, which opens the quickfix window, and makes it my
      | > current window.
      | >
      | > Why does <C-W>p jump to the preview window, and not the C source?
      | >
      | > Seems like a bug, since my previous window was the C source, not the
      | > preview window.
      |
      | It doesn't happen for me, CTRL-W p jumps back to the C source. Any idea
      | what could be different for you?
      |
      | --
      | (letter from Mark to Mike, about the film's probable certificate)
      | For an 'A' we would have to: Lose as may shits as possible Take Jesus
      | Christ out, if possible Loose "I fart in your general direction" Lose
      | "the oral sex" Lose "oh, fuck off" Lose "We make castanets out of your
      | testicles"
      | "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD
      |
      | /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      | ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
      | \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      |
      \ END: Bram Moolenaar
    • Benji Fisher
      ... Are you sure you typed p and not P ? Perhaps CAPS LOCK was on? HTH --Benji Fisher
      Message 2 of 7 , Nov 1, 2001
      • 0 Attachment
        Gary Holloway wrote:
        >
        > I'm in a C source file (current window).
        > I've got a preview window displaying a tag.
        >
        > I type :copen, which opens the quickfix window, and makes it my current window.
        >
        > Why does <C-W>p jump to the preview window, and not the C source?
        >
        > Seems like a bug, since my previous window was the C source, not the preview
        > window.

        Are you sure you typed <C-W>p and not <C-W>P ? Perhaps CAPS LOCK was on?

        HTH --Benji Fisher
      • Gary Holloway
        I haven t had a chance to look at the latest beta release...does anyone know if this was fixed? -gary / FROM: Gary Holloway , Nov 1
        Message 3 of 7 , Mar 8, 2002
        • 0 Attachment
          I haven't had a chance to look at the latest beta release...does anyone know if
          this was fixed?

          -gary

          / FROM: Gary Holloway <gary@...>, Nov 1 10:20 2001
          | ABOUT: Re: copen vs. preview and wincmd p
          |
          | Try setting splitbelow
          |
          | I turned splitbelow off, and it did work; when the preview window is at the
          | top, and the quickfix window is at the bottom.
          |
          | Sorry 'bout leaving that tidbit out. :)
          |
          | With splitbelow on, the C source is on top, below that is the preview window,
          | and below that the quickfix window.
          |
          | -gary
          |
          | / FROM: Bram Moolenaar <Bram@...>, Nov 1 11:04 2001
          | | ABOUT: Re: copen vs. preview and wincmd p
          | |
          | |
          | | Gary Holloway wrote:
          | |
          | | > I'm in a C source file (current window).
          | | > I've got a preview window displaying a tag.
          | | >
          | | > I type :copen, which opens the quickfix window, and makes it my
          | | > current window.
          | | >
          | | > Why does <C-W>p jump to the preview window, and not the C source?
          | | >
          | | > Seems like a bug, since my previous window was the C source, not the
          | | > preview window.
          | |
          | | It doesn't happen for me, CTRL-W p jumps back to the C source. Any idea
          | | what could be different for you?
          | |
          | | --
          | | (letter from Mark to Mike, about the film's probable certificate)
          | | For an 'A' we would have to: Lose as may shits as possible Take Jesus
          | | Christ out, if possible Loose "I fart in your general direction" Lose
          | | "the oral sex" Lose "oh, fuck off" Lose "We make castanets out of your
          | | testicles"
          | | "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD
          | |
          | | /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
          | | ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
          | | \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
          | |
          | \ END: Bram Moolenaar
          |
          \ END: Gary Holloway
        • Gary Holloway
          Using v6.1 now, and this is still a problem (bug, right?)... / FROM: Gary Holloway , Nov 1 10:20 2001 ... END: Gary Holloway
          Message 4 of 7 , Jun 17, 2002
          • 0 Attachment
            Using v6.1 now, and this is still a problem (bug, right?)...

            / FROM: Gary Holloway <gary@...>, Nov 1 10:20 2001
            | ABOUT: Re: copen vs. preview and wincmd p
            |
            | Try setting splitbelow
            |
            | I turned splitbelow off, and it did work; when the preview window is at the
            | top, and the quickfix window is at the bottom.
            |
            | Sorry 'bout leaving that tidbit out. :)
            |
            | With splitbelow on, the C source is on top, below that is the preview window,
            | and below that the quickfix window.
            |
            | -gary
            |
            | / FROM: Bram Moolenaar <Bram@...>, Nov 1 11:04 2001
            | | ABOUT: Re: copen vs. preview and wincmd p
            | |
            | |
            | | Gary Holloway wrote:
            | |
            | | > I'm in a C source file (current window).
            | | > I've got a preview window displaying a tag.
            | | >
            | | > I type :copen, which opens the quickfix window, and makes it my
            | | > current window.
            | | >
            | | > Why does <C-W>p jump to the preview window, and not the C source?
            | | >
            | | > Seems like a bug, since my previous window was the C source, not the
            | | > preview window.
            | |
            | | It doesn't happen for me, CTRL-W p jumps back to the C source. Any idea
            | | what could be different for you?
            | |
            | | --
            | | (letter from Mark to Mike, about the film's probable certificate)
            | | For an 'A' we would have to: Lose as may shits as possible Take Jesus
            | | Christ out, if possible Loose "I fart in your general direction" Lose
            | | "the oral sex" Lose "oh, fuck off" Lose "We make castanets out of your
            | | testicles"
            | | "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD
            | |
            | | /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
            | | ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
            | | \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
            | |
            | \ END: Bram Moolenaar
            |
            \ END: Gary Holloway
          • Bram Moolenaar
            ... I can reproduce it. It s a tiny bug. -- Hear about the guy who played a blank tape at full blast? The mime next door went nuts. /// Bram Moolenaar --
            Message 5 of 7 , Jun 18, 2002
            • 0 Attachment
              Gary Holloway wrote:

              > Using v6.1 now, and this is still a problem (bug, right?)...
              >
              > / FROM: Gary Holloway <gary@...>, Nov 1 10:20 2001
              > | ABOUT: Re: copen vs. preview and wincmd p
              > |
              > | Try setting splitbelow
              > |
              > | I turned splitbelow off, and it did work; when the preview window is at the
              > | top, and the quickfix window is at the bottom.
              > |
              > | Sorry 'bout leaving that tidbit out. :)
              > |
              > | With splitbelow on, the C source is on top, below that is the
              > | preview window, and below that the quickfix window.

              I can reproduce it. It's a tiny bug.

              --
              Hear about the guy who played a blank tape at full blast?
              The mime next door went nuts.

              /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
              /// Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim \\\
              \\\ Project leader for A-A-P -- http://www.a-a-p.org ///
              \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
            Your message has been successfully submitted and would be delivered to recipients shortly.