Loading ...
Sorry, an error occurred while loading the content.

problems making vim in AIX

Expand Messages
  • Brian Nowak
    I am having problems making vim in AIX. Have looked at the list Archive but didn t find any related questions. I have tried both cc and gcc compilers with no
    Message 1 of 2 , Jul 1, 2001
    • 0 Attachment
      I am having problems making vim in AIX. Have looked at the list Archive but
      didn't find any related questions. I have tried both cc and gcc compilers
      with no success. From other emails I assume cc works better for AIX.

      I uncommented these lines in the Make file:
      CC = cc
      CFLAGS = -qsrcmsg -O2 -qmaxmem=8192 -D__STR31__

      Then after running the make I recieved these errors:

      .../vim-5.8/src> make
      cc -c -I. -Iproto -DHAVE_CONFIG_H -D_ALL_SOURCE -qsrcmsg -O2
      -qmaxmem=8192 -D__STR31__ buffer.c

      "vim.h", line 29.5: 1506-166 (S) Definition of function
      Error requires parentheses.
      "vim.h", line 29.10: 1506-276 (S) Syntax error: possible
      missing '{'?
      "/usr/include/stdio.h", line 153.3: 1506-273 (E) Missing type
      in declaration of FILE.
      "/usr/include/stdio.h", line 158.8: 1506-166 (S) Definition of
      function FILE requires parentheses.
      "/usr/include/stdio.h", line 158.17: 1506-276 (S) Syntax error:
      possible missing '{'?
      "/usr/include/sys/types.h", line 236.3: 1506-273 (E) Missing
      type in declaration of sigset_t.
      "/usr/include/sys/vm_types.h", line 45.9: 1506-166 (S)
      Definition of function ulong_t requires parentheses.
      "/usr/include/sys/vm_types.h", line 45.25: 1506-276 (S) Syntax
      error:possible missing '{'?
      "/usr/include/sys/vm_types.h", line 94.9: 1506-045 (S)
      Undeclared identifier vmhandle_t.

      It continues on with these same errors but I stopped listing them. If
      anyone knows how to fix this or has a compiled vim with gui that can be run
      out of my home directory that would be great.

      Brian Nowak
      _________________________________________________________________
      Get your FREE download of MSN Explorer at http://explorer.msn.com
    • Dan Sharp
      ... Did you modify the supplied makefile directly, or did you run ./configure first? It compiles for me just fine by doing ./configure
      Message 2 of 2 , Jul 2, 2001
      • 0 Attachment
        At 11:10 AM 7/1/2001 -0400, Brian Nowak wrote:
        >I am having problems making vim in AIX. Have looked at the list Archive
        >but didn't find any related questions. I have tried both cc and gcc
        >compilers with no success. From other emails I assume cc works better for AIX.
        >
        >I uncommented these lines in the Make file:
        > CC = cc
        > CFLAGS = -qsrcmsg -O2 -qmaxmem=8192 -D__STR31__
        >
        >Then after running the make I recieved these errors:
        <snip>

        Did you modify the supplied makefile directly, or did you run ./configure
        first? It compiles for me just fine by doing

        ./configure --enable-max-features
        make

        >It continues on with these same errors but I stopped listing them. If
        >anyone knows how to fix this or has a compiled vim with gui that can be
        >run out of my home directory that would be great.

        I have some at http://sites.netscape.net/sharppeople/vim/bin that you can
        use. I have console-only and one compiled with the Motif GUI.

        Dan Sharp
      Your message has been successfully submitted and would be delivered to recipients shortly.