Loading ...
Sorry, an error occurred while loading the content.

Re: Vim version 5.8 has been released

Expand Messages
  • Freudenberger Joerg
    Hallo Bram hallo Vimmers I detect a new essential change in behaviour of vim from version 5.7 to 5.8 under Windows NT 4.0 SP6. Vim 5.8 need the aquivalent of
    Message 1 of 10 , Jun 1, 2001
    • 0 Attachment
      Hallo Bram
      hallo Vimmers

      I detect a new essential change in behaviour of vim
      from version 5.7 to 5.8 under Windows NT 4.0 SP6.

      Vim 5.8 need the aquivalent of $VIMRUNTIME to added
      to the environment variable PATH to start vim with
      the selected file via right mouse popup menu.
      The error box is:
      gvimext.dll error
      Error creating process: Check if gvim.exe is in your path!
      [ OK ]

      This subject is only for individual or special interest.

      This difficulty bites people that have got some
      vim versions in parallel for testing _and_ users
      which are not permitted to add something to the
      environment variables or using tool which are
      modifiing the environment dynamically during
      runtime.

      I appreciate your answer also
      if there is nothing to get rid of this.

      Yours
      Jörg
    • "Welraeds, Grégoire"
      Hello, This is not new to vim 5.8. I had this problem when installing vim5.7 a month ago. This is easy to fix by going in the control panel, then click to
      Message 2 of 10 , Jun 1, 2001
      • 0 Attachment
        Hello,

        This is not new to vim 5.8. I had this "problem" when installing vim5.7 a
        month ago.
        This is easy to fix by going in the control panel, then click to system,
        choose environment and add something like D:\Programs\vim\vim57 to the PATH
        variable.

        regards,

        Grégoire Welraeds
        Logica Belgium
        Developer
        Tel. : + 32 (0)2 745 08 41
        E-mail: welraedsg@...
        http://www.logica.com


        -----Original Message-----
        From: Freudenberger Joerg [mailto:Joerg.Freudenberger@...]
        Sent: Friday, June 01, 2001 11:13 AM
        To: 'Bram Moolenaar'
        Cc: 'vim@...'
        Subject: Re: Vim version 5.8 has been released


        Hallo Bram
        hallo Vimmers

        I detect a new essential change in behaviour of vim
        from version 5.7 to 5.8 under Windows NT 4.0 SP6.

        Vim 5.8 need the aquivalent of $VIMRUNTIME to added
        to the environment variable PATH to start vim with
        the selected file via right mouse popup menu.
        The error box is:
        gvimext.dll error
        Error creating process: Check if gvim.exe is in your path!
        [ OK ]

        This subject is only for individual or special interest.

        This difficulty bites people that have got some
        vim versions in parallel for testing _and_ users
        which are not permitted to add something to the
        environment variables or using tool which are
        modifiing the environment dynamically during
        runtime.

        I appreciate your answer also
        if there is nothing to get rid of this.

        Yours
        Jörg
      • Bram Moolenaar
        ... I don t think this changed. In 5.7 it worked the same way. Perhaps you didn t re-install Vim to update for the new position of the executable? The idea
        Message 3 of 10 , Jun 1, 2001
        • 0 Attachment
          Joerg Freudenberger wrote:

          > I detect a new essential change in behaviour of vim
          > from version 5.7 to 5.8 under Windows NT 4.0 SP6.
          >
          > Vim 5.8 need the aquivalent of $VIMRUNTIME to added
          > to the environment variable PATH to start vim with
          > the selected file via right mouse popup menu.
          > The error box is:
          > gvimext.dll error
          > Error creating process: Check if gvim.exe is in your path!
          > [ OK ]

          I don't think this changed. In 5.7 it worked the same way. Perhaps you
          didn't re-install Vim to update for the new position of the executable? The
          idea is that unpacking the .zip archives doesn't change which Vim executable
          is used. Only by running install.exe (or manually moving the files) will they
          start to be used.

          --
          hundred-and-one symptoms of being an internet addict:
          62. If your doorbell rings, you think hat new mail has arrived. And then
          you're disappointed that it's only someone at the door.

          /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
          ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
          \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
        • Freudenberger Joerg
          Thank you Bram. I did some checks and tests and now I m totally confused. I found a difference in the registry I m unable to explain what caused this
          Message 4 of 10 , Jun 1, 2001
          • 0 Attachment
            Thank you Bram.

            I did some checks and tests
            and now I'm totally confused.

            I found a difference in the registry
            I'm unable to explain what caused this
            difference.


            Machine 1: that I used this morning,
            and both versions are setting this value
            [HKEY_LOCAL_MACHINE\Software\Vim\Gvim]
            "path"="gvim.exe"

            On a longer not touched computer I found
            Machine 2:
            [HKEY_LOCAL_MACHINE\Software\Vim\Gvim]
            "path"="c:\tool\vim\vim57\gvim.exe"

            I'm definitly sure that I fully did the same
            install procedure (and the vim57 packages
            were the same).

            After changing aquivalently and booting
            it functions fine. But I don't know
            why this difference was caused.

            Please excuse ...
            I'll add a hint to the install guide which
            I pass on to my friends and colleagues.

            Yours
            Jörg

            PS: Grégoire, You are definitely right for clean systems.
            But there are systems where ugly software have got
            to run (Some programmers have strange opinions about
            doing twisting the whole system during runtime.
            I think they believe in being like gods) ;-)
          • Ondrejko, David
            ... I just installed vim on Windows NT 4.0, SP5 yesterday. I was having a bit of trouble getting everything to point to the new version of Vim. What I
            Message 5 of 10 , Jun 1, 2001
            • 0 Attachment
              RE: Vim version 5.8 has been released

              > > I detect a new essential change in behaviour of vim
              > > from version 5.7 to 5.8 under Windows NT 4.0 SP6.
              > >
              > > Vim 5.8 need the aquivalent of $VIMRUNTIME to added
              > > to the environment variable PATH to start vim with
              > > the selected file via right mouse popup menu.
              > > The error box is:
              > >     gvimext.dll error
              > >     Error creating process: Check if gvim.exe is in your path!
              > >                             [  OK  ]
              >
              > I don't think this changed.  In 5.7 it worked the same
              > way. Perhaps you didn't re-install Vim to update for
              > the new position of the executable?  The idea is that
              > unpacking the .zip archives doesn't change which
              > Vim executable is used.  Only by running install.exe
              > (or manually moving the files) will they
              > start to be used.

              I just installed vim on Windows NT 4.0, SP5 yesterday.  I was having a bit of trouble getting everything to point to the "new" version of Vim.

              What I eventually did was to (1) go to the "\Winnt\Profiles\<myusername>\Start Menu" directory and manually change any shortcuts to point to the new program, (2) in Windows NT Explorer, go to the View->Options "File Types" tab and manually change any file types which brought up Vim to point to the new program, and (3) go into the Registry Editor (type "regedit" as an MS-DOS prompt), and under HKEY_CLASSES_ROOT->*->shell->Vim->command, change the setting there to point to the new program.

              Now, I know next to nothing about the Registry Editor, BUT I suspect that #3 needs to be done only if you have or want the new version of VIM to be the default editor for files that have no other file associations set up (as in #2).  (If somebody who knows about this could confirm whether I'm right or wrong about this, I'd appreciate it!)

              -- Davyd

            • Nagle, Adrian
              ... What I always do is install gvim (uncompress in a vim directory like F: apps vim), and then copy gvim.exe and vimrun.exe from the new installation
              Message 6 of 10 , Jun 1, 2001
              • 0 Attachment
                > > I detect a new essential change in behaviour of vim
                > > from version 5.7 to 5.8 under Windows NT 4.0 SP6.
                > >
                > > Vim 5.8 need the aquivalent of $VIMRUNTIME to added
                > > to the environment variable PATH to start vim with
                > > the selected file via right mouse popup menu.
                > > The error box is:
                > > gvimext.dll error
                > > Error creating process: Check if gvim.exe is in your path!
                > > [ OK ]
                >
                > I don't think this changed. In 5.7 it worked the same
                > way. Perhaps you didn't re-install Vim to update for
                > the new position of the executable? The idea is that
                > unpacking the .zip archives doesn't change which
                > Vim executable is used. Only by running install.exe
                > (or manually moving the files) will they
                > start to be used.

                What I always do is install gvim (uncompress in a vim directory like
                F:\apps\vim), and then copy gvim.exe and vimrun.exe from the new
                installation (F:\apps\vim\vim58) to the $VIM directory (again F:\apps\vim).
                Any shortcuts I make or batch files, are linked to $VIM/gvim.exe. This way,
                I can install a new version of VIM and not force everyone on the network to
                use it. But it is available for anyone to try it out. Then, when
                everything works right (always has!), I just copy the two files to $VIM.
                This would work also if you put $VIM in your path. No need to change for
                each new installation.

                The only other change is if you use the menu feature. I have to run that on
                each computer I use to update the registry to the correct new version of
                VIM.

                Adrian
                --
                Adrian Nagle anagle@...
                Thermal Engineer TEL: 303-939-6518
                Ball Aerospace & Technologies Corp. FAX: 303-939-5166
                Boulder, CO http://www.ballaerospace.com



                > -----Original Message-----
                > From: Ondrejko, David [SMTP:david.ondrejko@...]
                > Sent: Friday, June 01, 2001 08:47
                > To: 'Bram Moolenaar'; Freudenberger Joerg
                > Cc: 'vim@...'
                > Subject: RE: Vim version 5.8 has been released
                >
                >
                > I just installed vim on Windows NT 4.0, SP5 yesterday. I was having a bit
                > of trouble getting everything to point to the "new" version of Vim.
                >
                > What I eventually did was to (1) go to the
                > "\Winnt\Profiles\<myusername>\Start Menu" directory and manually change
                > any shortcuts to point to the new program, (2) in Windows NT Explorer, go
                > to the View->Options "File Types" tab and manually change any file types
                > which brought up Vim to point to the new program, and (3) go into the
                > Registry Editor (type "regedit" as an MS-DOS prompt), and under
                > HKEY_CLASSES_ROOT->*->shell->Vim->command, change the setting there to
                > point to the new program.
                >
                > Now, I know next to nothing about the Registry Editor, BUT I suspect that
                > #3 needs to be done only if you have or want the new version of VIM to be
                > the default editor for files that have no other file associations set up
                > (as in #2). (If somebody who knows about this could confirm whether I'm
                > right or wrong about this, I'd appreciate it!)
                >
                > -- Davyd
                >
              • Freudenberger Joerg
                Hallo Vimmers My difficulty is solved. I have got one suspect. But I have no fresh system available at this location so this issue have got to wait ... I will
                Message 7 of 10 , Jun 1, 2001
                • 0 Attachment
                  Hallo Vimmers

                  My difficulty is solved.
                  I have got one suspect.

                  But I have no fresh system available
                  at this location so this issue have
                  got to wait ...

                  I will tell you all as soon as i get
                  the real answer.

                  I wish you a pleasant weekend.

                  Yours
                  Jörg
                • Bram Moolenaar
                  ... You must have selected another choice about where to put Vim. You can adjust $PATH to include the location of gvim.exe, causing gvim.exe to be used in
                  Message 8 of 10 , Jun 1, 2001
                  • 0 Attachment
                    Joerg Freudenberger wrote:

                    > I did some checks and tests
                    > and now I'm totally confused.
                    >
                    > I found a difference in the registry I'm unable to explain what caused this
                    > difference.
                    >
                    >
                    > Machine 1: that I used this morning,
                    > and both versions are setting this value
                    > [HKEY_LOCAL_MACHINE\Software\Vim\Gvim]
                    > "path"="gvim.exe"
                    >
                    > On a longer not touched computer I found
                    > Machine 2:
                    > [HKEY_LOCAL_MACHINE\Software\Vim\Gvim]
                    > "path"="c:\tool\vim\vim57\gvim.exe"
                    >
                    > I'm definitly sure that I fully did the same install procedure (and the
                    > vim57 packages were the same).

                    You must have selected another choice about where to put Vim. You can adjust
                    $PATH to include the location of gvim.exe, causing "gvim.exe" to be used in
                    the registry entry. Or you can select "copy gvim.exe to a directory in $PATH"
                    or not do anything", in which case the full path is used for the registry
                    entry.

                    In Vim 6.0 this will work different, since these choices were confusing.
                    And uninstall doesn't really work.

                    --
                    hundred-and-one symptoms of being an internet addict:
                    70. ISDN lines are added to your house on a hourly basis

                    /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                    ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                    \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
                  • Ondrejko, David
                    Interesting. I checked My registry and I don t even *have* that value defined. The only one I ve been able to find in reference to VIM is the one I mentioned
                    Message 9 of 10 , Jun 1, 2001
                    • 0 Attachment
                      RE: Vim version 5.8 has been released

                      Interesting.  I checked My registry and I don't even *have* that value defined.  The only one I've been able to find in reference to VIM is the one I mentioned in My previous email: [HKEY_CLASSES_ROOT\*\shell\Vim\command].  Of course, I upgraded from 5.3 to 5.8, and had the install process fail (don't recall the message).  Could that be why I don't have the key?  Should I go in and manually add it?  What is it for?

                       
                      >> I found a difference in the registry I'm unable to
                      >> explain what caused this difference.
                      >>
                      >> Machine 1: that I used this morning,
                      >>      and both versions are setting this value
                      >> [HKEY_LOCAL_MACHINE\Software\Vim\Gvim]
                      >> "path"="gvim.exe"
                      >>
                      >> On a longer not touched computer I found
                      >> Machine 2:
                      >> [HKEY_LOCAL_MACHINE\Software\Vim\Gvim]
                      >> "path"="c:\tool\vim\vim57\gvim.exe"
                      >>
                      >> I'm definitly sure that I fully did the same install
                      >> procedure (and the vim57 packages were the same).
                      >
                      > You must have selected another choice about where to
                      > put Vim.  You can adjust $PATH to include the location
                      > of gvim.exe, causing "gvim.exe" to be used in
                      > the registry entry.  Or you can select "copy gvim.exe
                      > to a  directory in $PATH" or not do anything", in
                      > which case the full path is used for the registry
                      > entry.
                      >
                      > In Vim 6.0 this will work different, since these
                      > choices were confusing. And uninstall doesn't really
                      > work.

                    Your message has been successfully submitted and would be delivered to recipients shortly.