Loading ...
Sorry, an error occurred while loading the content.
 

vim syntax highlighting

Expand Messages
  • Sebastian Helms
    Hi, I have compiled and installed vim 6.0o, which runs quite well. Syntaxhighlighting is on and running.. with one exception. vim doesn t recognize mutt mails.
    Message 1 of 4 , May 25, 2001
      Hi,

      I have compiled and installed vim 6.0o, which runs quite well.
      Syntaxhighlighting is on and running.. with one exception. vim
      doesn't recognize mutt mails. slrn postings do work.

      From /usr/local/vim/share/vim/vim60o/filetype.vim:

      " Mail (for Elm, trn, mutt, rn, slrn)
      au BufNewFile,BufRead snd.\d\+,.letter,.letter.\d\+,.followup,.article,.article.\d\+,pico.\d\+,mutt-*,mutt\w\{6\},ae\d\+.txt,/tmp/SLRN[0-9A-Z.]\+ setf mail

      The mail files are calles .tmp/mutt-narya-21826-1045 (this one).

      Any ideas why? slrn postings are correctly set to filetype mail.

      Regards,

      Sebastian

      --
      Do not meddle in the affairs of Wizards,
      for they are subtle and quick to anger.

      Sebastian Helms - http://www.helms.sh - mailto:mail@... (PGP welcome)
    • S M.C Butler
      Hi, can someone tell me how to change my vim syntx highlighting to make strings displayed in an italic font rather than being underlined… all those
      Message 2 of 4 , May 2, 2005
        Hi, can someone tell me how to change my vim syntx highlighting to make
        strings displayed in an italic font rather than being underlined… all those
        underlines are sending me cross-eyed, too busy!!
         
         
        Rgds,
      • A. J. Mechelynck
        ... The official way to do it would be to define a colorscheme, changing the :highlight commands for all the groups which are now underlined in order to
        Message 3 of 4 , May 2, 2005
          S M.C Butler wrote:
          > Hi, can someone tell me how to change my vim syntx highlighting to make
          > strings displayed in an italic font rather than being underlined… all those
          > underlines are sending me cross-eyed, too busy!!
          >
          >
          > Rgds,
          >
          >
          >
          >
          >
          The "official" way to do it would be to define a colorscheme, changing
          the ":highlight" commands for all the groups which are now underlined in
          order to make them italic (or something; maybe you would still want to
          distinguish HtmlItalic, HtmlUnderline, and HtmlItalicUnderline from each
          other?).

          There might also be a "hack" in non-GUI VIM, changing the termcap
          settings so that when Vim thinks it is setting underlines, it actually
          sets italics on the terminal. (see ":help :set-termcap")


          Best regards,
          Tony.
        • Eric Arnold
          I ve changed the highlighting bits that I didn t like by sticking these changes at the end of my .gvimrc. Changing the nasty dim blue highlighting:
          Message 4 of 4 , May 2, 2005
            I've changed the highlighting bits that I didn't like by sticking these
            changes at the end of my .gvimrc.


            " Changing the nasty dim blue highlighting:
            " Default:
            " Special xxx term=bold ctermfg=12 guifg=#0000ff
            " NonText xxx term=bold ctermfg=9 gui=bold guifg=Blue
            autocmd GUIEnter * hi nontext guifg=magenta
            autocmd GUIEnter * hi special guifg=magenta
            " Other existing magenta entries:
            " Title xxx term=bold ctermfg=13 gui=bold guifg=Magenta
            " DiffChange xxx term=bold ctermbg=5 guibg=DarkMagenta
            "
            " hightlight group user1 is for statusline hightlighting
            autocmd GUIEnter * hi user1 gui=reverse guifg=magenta guibg=fg
            "
            " For re-executing:
            " hi nontext guifg=magenta
            " hi special guifg=magenta
            " hi user1 gui=reverse guifg=magenta guibg=fg



            " old:
            " highlight Folded guibg=grey guifg=blue
            " highlight FoldColumn guibg=darkgrey guifg=white
            autocmd GUIEnter * highlight Folded term=standout ctermfg=11 ctermbg=8
            guifg=white guibg=darkgreen
            autocmd GUIEnter * highlight FoldColumn term=standout ctermfg=11 ctermbg=8
            guifg=white guibg=darkgreen


            --- "A. J. Mechelynck" <antoine.mechelynck@...> wrote:
            > S M.C Butler wrote:
            > > Hi, can someone tell me how to change my vim syntx highlighting to make
            > > strings displayed in an italic font rather than being underlined� all those
            > > underlines are sending me cross-eyed, too busy!!
            > >
            > >
            > > Rgds,
            > >
            > >
            > >
            > >
            > >
            > The "official" way to do it would be to define a colorscheme, changing
            > the ":highlight" commands for all the groups which are now underlined in
            > order to make them italic (or something; maybe you would still want to
            > distinguish HtmlItalic, HtmlUnderline, and HtmlItalicUnderline from each
            > other?).
            >
            > There might also be a "hack" in non-GUI VIM, changing the termcap
            > settings so that when Vim thinks it is setting underlines, it actually
            > sets italics on the terminal. (see ":help :set-termcap")
            >
            >
            > Best regards,
            > Tony.
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.