Loading ...
Sorry, an error occurred while loading the content.
 

viminfo file / file marks

Expand Messages
  • Schuttberg@aol.com
    Hello, I d like to understand how to save and re-use file marks in the _viminfo file. If I i.e. open a file C: Texte castalia.txt and mark 2 lines with ma and
    Message 1 of 2 , Apr 2 12:47 PM
      Hello,

      I d like to understand how to save and re-use file marks in the _viminfo file.
      If I i.e. open a file C:\Texte\castalia.txt and mark 2 lines with ma and mb,
      doing ":wv" esults in the entry
      ...
      # File marks:
      '0 7 4 C:\Texte\castalia.txt
      '1 6 0 C:\Texte\castalia.txt
      ...

      If I open C:\Texte\castalia.txt again, doing :rv and try 'a or 'b, I only get
      the message
      "Mark not set". The same with trying '0 or '1.
      (gvim Win32 5.6)

      How can I use the file marks again?

      Thank you

      Achim
    • Benji Fisher
      ... Have you tried mA and mB, then A and B? Re-read ... You seem to have missed the distinction between a and A. The only thing I do not understand is
      Message 2 of 2 , Apr 2 6:33 PM
        Schuttberg@... wrote:

        > Hello,
        >
        > I d like to understand how to save and re-use file marks in the _viminfo file.
        > If I i.e. open a file C:\Texte\castalia.txt and mark 2 lines with ma and mb,
        > doing ":wv" esults in the entry
        > ...
        > # File marks:
        > '0 7 4 C:\Texte\castalia.txt
        > '1 6 0 C:\Texte\castalia.txt
        > ...
        >
        > If I open C:\Texte\castalia.txt again, doing :rv and try 'a or 'b, I only get
        > the message
        > "Mark not set". The same with trying '0 or '1.
        > (gvim Win32 5.6)
        >
        > How can I use the file marks again?
        >
        > Thank you
        >
        > Achim

        Have you tried mA and mB, then 'A and 'B? Re-read

        :help marks

        You seem to have missed the distinction between 'a and 'A. The only thing
        I do not understand is why '0 and '1 do not work. Do you have a viminfo
        file? How is the 'viminfo' option set? If you do

        :marks

        are '0 and '1 and so on listed?

        HTH
        --Benji Fisher
      Your message has been successfully submitted and would be delivered to recipients shortly.