Loading ...
Sorry, an error occurred while loading the content.

highlighting on search.

Expand Messages
  • Anand
    Hi. All these days I used to use my own hand rolled syntax files (back from the day) for syntax highlighting. Since the syntax files that come with vim these
    Message 1 of 3 , Mar 1, 2001
    • 0 Attachment
      Hi. All these days I used to use my own hand rolled syntax files (back
      from the day) for syntax highlighting. Since the syntax files that come
      with vim these days are far more sophisticated, I switched ot them
      recently. But, there seems to be a problem. Every time I do a
      search/replace operation, every instance of the match for that
      search/replace is highlighted. I never used to have this. I hate this,
      and I'm wondering what it is that is turning this on. I would like to
      turn it off by default and enable it whenever I need it. Can somebody
      point me in the right direction?
      Thanks a lot.
      Anand
      --
      Anand Ranganathan anand@...
    • Janakiraman .S
      Message 2 of 3 , Mar 1, 2001
      • 0 Attachment
        * Anand (anand@...) wrote thusly :

        > Hi. All these days I used to use my own hand rolled syntax files (back
        > from the day) for syntax highlighting. Since the syntax files that
        > come with vim these days are far more sophisticated, I switched to
        > them recently. But, there seems to be a problem. Every time I do a
        > search/replace operation, every instance of the match for that
        > search/replace is highlighted. I never used to have this. I hate
        > this, and I'm wondering what it is that is turning this on. I would
        > like to turn it off by default and enable it whenever I need it. Can
        > somebody point me in the right direction?

        :help hls
        :help noh

        > Thanks a lot.
        > Anand
      • Niklas Lindström
        Hi Anand, ... which is then reactivated if you press e.g. n . regards Niklas ... From: Anand [mailto:anand@blandings.com] Sent: Friday, March 02, 2001 3:36 AM
        Message 3 of 3 , Mar 2, 2001
        • 0 Attachment
          Hi Anand,

          try:
          :set nohlsearch

          I prefer this though; the current search-highlight can be deactivated with:
          :nohlsearch (in its shortest :noh)

          which is then reactivated if you press e.g. 'n'.

          regards
          Niklas


          -----Original Message-----
          From: Anand [mailto:anand@...]
          Sent: Friday, March 02, 2001 3:36 AM
          To: vim@...
          Subject: highlighting on search.


          Hi. All these days I used to use my own hand rolled syntax files (back
          from the day) for syntax highlighting. Since the syntax files that come
          with vim these days are far more sophisticated, I switched ot them
          recently. But, there seems to be a problem. Every time I do a
          search/replace operation, every instance of the match for that
          search/replace is highlighted. I never used to have this. I hate this,
          and I'm wondering what it is that is turning this on. I would like to
          turn it off by default and enable it whenever I need it. Can somebody
          point me in the right direction?
          Thanks a lot.
          Anand
          --
          Anand Ranganathan anand@...
        Your message has been successfully submitted and would be delivered to recipients shortly.