Loading ...
Sorry, an error occurred while loading the content.

set breakat

Expand Messages
  • Alan G. Isaac
    I m running gvim 5.7 under Win95. i. If I try to set breakat, it is set to an empty string. E.g., after starting Vim I check and breakat has its default value.
    Message 1 of 3 , Mar 1, 2001
    • 0 Attachment
      I'm running gvim 5.7 under Win95.

      i. If I try to set breakat, it is set
      to an empty string. E.g., after starting
      Vim I check and breakat has its default value.
      Then I type
      :set breakat=" ,./"
      and breakat is then set to an empty string.
      What am I overlooking?

      ii. The default value of breakat is listed as
      " ^I!@*-+_;:,./?"
      Is ^I something special or just two characters?
      If the latter, why `I'?

      Thanks,
      Alan Isaac
    • David Reviejo
      ... without quotes and escaping the space. HTH, -- David
      Message 2 of 3 , Mar 1, 2001
      • 0 Attachment
        * Alan G. Isaac <aisaac@...> [010301 20:26]:
        > i. If I try to set breakat, it is set
        > to an empty string. E.g., after starting
        > Vim I check and breakat has its default value.
        > Then I type
        > :set breakat=" ,./"
        > and breakat is then set to an empty string.
        > What am I overlooking?

        Try:
        :set breakat=\ ,./
        without quotes and escaping the space.

        HTH,
        --
        David
      • Benji Fisher
        ... ii. The ^I is a tab, as you can check with ... --Benji Fisher
        Message 3 of 3 , Mar 1, 2001
        • 0 Attachment
          "Alan G. Isaac" wrote:
          >
          > I'm running gvim 5.7 under Win95.
          >
          > i. If I try to set breakat, it is set
          > to an empty string. E.g., after starting
          > Vim I check and breakat has its default value.
          > Then I type
          > :set breakat=" ,./"
          > and breakat is then set to an empty string.
          > What am I overlooking?
          >
          > ii. The default value of breakat is listed as
          > " ^I!@*-+_;:,./?"
          > Is ^I something special or just two characters?
          > If the latter, why `I'?
          >
          > Thanks,
          > Alan Isaac

          i. Try escaping the space and leaving off the quotation marks:
          :set breakat=\ ,./
          :help :set
          :help option-backslash

          ii. The ^I is a tab, as you can check with

          :echo char2nr(&breakat[1]) char2nr("\<Tab>")

          --Benji Fisher
        Your message has been successfully submitted and would be delivered to recipients shortly.