Loading ...
Sorry, an error occurred while loading the content.
 

Re: cmdheight = and press any key to continue

Expand Messages
  • Timothy Grant
    ... Thanks for the valuable input. I am using auto-commands to source my python configuration files any time that I load a python buffer, or change to a python
    Message 1 of 7 , Feb 26, 2001
      On Tue, Feb 27, 2001 at 09:25:05AM +0530, Janakiraman .S wrote:
      > * Timothy Grant (tjg@...) wrote thusly :
      >
      > > Thanks for the info.
      > >
      > > Yes, it looks like it should help, but I must be doing
      > > something wrong as is doesn't seem to work as I think I expect.
      > >
      > > set cmdheight=2
      > > set shortmess=ao
      > >
      > > :w
      > >
      > > "wlautoconf.py" 354L, 14104C [w]
      > > "wlautoconf.py" 354L, 14104C [w]
      > > Press RETURN or enter command to continue
      > >
      > > As I look at those messages, I have to wonder why it is writing
      > > the file twice!
      >
      > I suspect you have some auto-commands that are causing this. In that
      > case, I would suggest you put those commands into a function. Set
      > cmdheight to something large at the start of the function, do all that
      > you want to and restore cmdheight when you are done.
      >
      > au BufWritePost *.py call Some_changes()
      >
      > func! Some_changes()
      > let old_cmd = &cmdheight
      > let &cmdheight=10
      > " set cmdheight to some number that exceeds the no: of messages you
      > " expect to see
      > execute "!something <afile>"
      > e!
      > let &cmdheight=old_cmd
      > endfunction
      >
      > In principle you can put all those commands in one line with |'s in
      > between.
      >
      Thanks for the valuable input. I am using auto-commands to
      source my python configuration files any time that I load a
      python buffer, or change to a python buffer.
      >
      > > I'm guessing it has something to do with the fact that my
      > > python settings are sourced in a different file, but I don't
      > > know.
      >
      > I guess not.

      Well, if i'm using auto-commands to source the files maybe I'm
      half right<wink>.

      >
      > > Also, I have hidden turned on so that I can flip from buffer to buffer
      > > quickly and easily, but it also appears that now that I've done that
      > > help buffers never go away when I close them. I'll do a :ls and see
      > > all sorts of help buffers open along with the buffers that I'm really
      > > editing.
      >
      > That's been solved in vim6.0.

      Cool. Is 6.0 usable, or should I, as a complete vim newbie,
      stay away from it?

      --
      Stand Fast,
      tjg.

      Timothy Grant tjg@...
      Red Hat Certified Engineer www.exceptionalminds.com
      Avalon Technology Group, Inc. <>< (503) 246-3630
      >>>>>>>>>>>>>Linux, because rebooting is *NOT* normal<<<<<<<<<
      >>>>This machine was last rebooted: 41 days 8:29 hours ago<<
    Your message has been successfully submitted and would be delivered to recipients shortly.