Loading ...
Sorry, an error occurred while loading the content.

"vim.org" fails to redirect to "www.vim.org" for Chrome users

Expand Messages
  • Andrew Pennebaker
    When I enter vim.org into the address bar in Firefox, it successfully redirects to www.vim.org . But when I enter vim.org in Chrome, no redirect happens.
    Message 1 of 11 , Aug 19, 2014
    • 0 Attachment
      When I enter "vim.org" into the address bar in Firefox, it successfully redirects to "www.vim.org". But when I enter "vim.org" in Chrome, no redirect happens. Maybe check the Apache config?

      Observed with Google Chrome 36 in Mac OS X and Ubuntu.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Markus Osterhoff
      ... From what I see (dig vim.org vs. dig www.vim.org), vim.org does not hold an A record, and it is Firefox, that just tries another URL. So it would be the
      Message 2 of 11 , Aug 20, 2014
      • 0 Attachment
        * Andrew Pennebaker <andrew.pennebaker@...> [140819 23:24]:
        > When I enter "vim.org" into the address bar in Firefox, it
        > successfully redirects to "www.vim.org". But when I enter "vim.org" in
        > Chrome, no redirect happens. Maybe check the Apache config?
        From what I see (dig vim.org vs. dig www.vim.org), vim.org does not hold
        an A record, and it is Firefox, that just tries another URL. So it would
        be the dns zone file that needs care, if this behaviour is wanted.

        > Observed with Google Chrome 36 in Mac OS X and Ubuntu.
        Greetings,
        Markus
      • John Beckett
        ... That has been discussed a couple of times in the past. The person who provides the DNS for Vim does so in an extremely reliable and efficient manner, so
        Message 3 of 11 , Aug 20, 2014
        • 0 Attachment
          Andrew Pennebaker wrote:
          > When I enter "vim.org" into the address bar in Firefox, it
          > successfully redirects to "www.vim.org". But when I enter
          > "vim.org" in Chrome, no redirect happens.

          That has been discussed a couple of times in the past. The
          person who provides the DNS for Vim does so in an extremely
          reliable and efficient manner, so what they say goes. The issue
          is that vim.org is a domain and should not be expected to work
          in a browser. A browser has to connect to a host (www.vim.org).

          Some browsers try adding "www." when plain "vim.org" does not
          resolve to a host name, so vim.org works in some browsers.

          John


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Andrew Pennebaker
          Could we please setup a basic Apache redirection, so that users trying to get to vim.org will be successfully redirected to www.vim.org? This procedure is
          Message 4 of 11 , Aug 20, 2014
          • 0 Attachment
            Could we please setup a basic Apache redirection, so that users trying to get to vim.org will be successfully redirected to www.vim.org?

            This procedure is commonly used by many websites, and it helps a lot of users get to the home page more easily--they shouldn't have to see 404 for the domain!

            An example Apache configuration that would quickly accomplish this:


            On Wed, Aug 20, 2014 at 5:54 AM, John Beckett <johnb.beckett@...> wrote:
            Andrew Pennebaker wrote:
            > When I enter "vim.org" into the address bar in Firefox, it
            > successfully redirects to "www.vim.org". But when I enter
            > "vim.org" in Chrome, no redirect happens.

            That has been discussed a couple of times in the past. The
            person who provides the DNS for Vim does so in an extremely
            reliable and efficient manner, so what they say goes. The issue
            is that vim.org is a domain and should not be expected to work
            in a browser. A browser has to connect to a host (www.vim.org).

            Some browsers try adding "www." when plain "vim.org" does not
            resolve to a host name, so vim.org works in some browsers.

            John


            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
            To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/1FuUXdqIiGM/unsubscribe.
            To unsubscribe from this group and all its topics, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.



            --
            Cheers,

            Andrew Pennebaker

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Павлов Николай Алекса
            ... Hash: SHA512 ... AFAIK vim.org is hosted on sourceforge and there is no access to web server settings. This question was already raised before here or in
            Message 5 of 11 , Aug 20, 2014
            • 0 Attachment
              -----BEGIN PGP SIGNED MESSAGE-----
              Hash: SHA512

              On August 20, 2014 11:42:59 PM GMT+03:00, Andrew Pennebaker <andrew.pennebaker@...> wrote:
              >Could we please setup a basic Apache redirection, so that users trying
              >to
              >get to vim.org will be successfully redirected to www.vim.org?
              >
              >This procedure is commonly used by many websites, and it helps a lot of
              >users get to the home page more easily--they shouldn't have to see 404
              >for
              >the domain!
              >
              >An example Apache configuration that would quickly accomplish this:
              >
              >http://stackoverflow.com/questions/1157255/how-to-redirect-non-www-to-www-urls-using-htaccess/11990168#11990168
              >
              >
              >On Wed, Aug 20, 2014 at 5:54 AM, John Beckett <johnb.beckett@...>
              >wrote:
              >
              >> Andrew Pennebaker wrote:
              >> > When I enter "vim.org" into the address bar in Firefox, it
              >> > successfully redirects to "www.vim.org". But when I enter
              >> > "vim.org" in Chrome, no redirect happens.
              >>
              >> That has been discussed a couple of times in the past. The
              >> person who provides the DNS for Vim does so in an extremely
              >> reliable and efficient manner, so what they say goes. The issue
              >> is that vim.org is a domain and should not be expected to work
              >> in a browser. A browser has to connect to a host (www.vim.org).
              >>
              >> Some browsers try adding "www." when plain "vim.org" does not
              >> resolve to a host name, so vim.org works in some browsers.
              >>
              >> John
              >>
              >>
              >> --
              >> --
              >> You received this message from the "vim_use" maillist.
              >> Do not top-post! Type your reply below the text you are replying to.
              >> For more information, visit http://www.vim.org/maillist.php
              >>
              >> ---
              >> You received this message because you are subscribed to a topic in
              >the
              >> Google Groups "vim_use" group.
              >> To unsubscribe from this topic, visit
              >> https://groups.google.com/d/topic/vim_use/1FuUXdqIiGM/unsubscribe.
              >> To unsubscribe from this group and all its topics, send an email to
              >> vim_use+unsubscribe@....
              >> For more options, visit https://groups.google.com/d/optout.
              >>
              >
              >
              >
              >--
              >Cheers,
              >
              >Andrew Pennebaker
              >www.yellosoft.us
              >
              >--
              >--
              >You received this message from the "vim_use" maillist.
              >Do not top-post! Type your reply below the text you are replying to.
              >For more information, visit http://www.vim.org/maillist.php
              >
              >---
              >You received this message because you are subscribed to the Google
              >Groups "vim_use" group.
              >To unsubscribe from this group and stop receiving emails from it, send
              >an email to vim_use+unsubscribe@....
              >For more options, visit https://groups.google.com/d/optout.

              AFAIK vim.org is hosted on sourceforge and there is no access to web server settings.

              This question was already raised before here or in vim-dev and relevant topic contained an explanation why with the current hosting it is not possible to do what you request. I did not save a link though.
              -----BEGIN PGP SIGNATURE-----
              Version: APG v1.1.1

              iQI1BAEBCgAfBQJT9Ps1GBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
              HhHSvl/lD/9MxXT6JzvR+R+PmtY3aignQcX0UiNHmw4nSQC9QB3Lq5X3w+MF7rhh
              jx+aPtzoXj4k1Fz2d0ODy/NnqEkmWbeCRqOcFGY6UTO2HZ2s5SjYFqXkDvf1NkWG
              ySYJuC14fmwMSE52muaddIvJCX5UU+k5Al/FH7Ke4Jl3ADk58wI1Cf2Wb775fWp+
              Ew0JT4gSUr9rlMLJG8m3GwltCoSmidbLhu5CuqK7s8U2jweE63wXjch/9lgP83n8
              +TDYazJPXJLcsMVt4nfgkySWv1x5B+gLyEkz9DtQdrAIJHysZuPMzuckrGBBf9kE
              GlGECVGwbF2Nv6TtGC+aomQiDbPiAvMnc5ggdGPScvvrkFAAAu79NNKjSdmN9v46
              ZffzZduDe4zJ6ArVdRnqM7XCLGgdX93BeidW3MKww92W3DPGyacCx3D+lP4+6O7f
              RZV9OFpeDQH1odn3WoPQnzYXV6tfzOZpRSeUr14KPgbHXYDS0ip4guiZVWY3Ol2p
              FZSaYAUGBv6svp7jyjg1x8fjo5iOI3BApvQdhwog8w9DhIFj39/tkp77knYMlaJj
              OgpA17CNsCwNyYMuYMoiFc2YAnz/4h8qqx5azkLx4GUQrUoBQbwbivhDuPldhc4R
              Ew4D+so3R20gKMHuzdQigmkhygZIIKNzvV5vYU7WvIRVPfWwHVfyPA==
              =FPWb
              -----END PGP SIGNATURE-----

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Benjamin R. Haskell
              This issue has been raised and rejected (stubbornly and misguidedly, IMO) multiple times in the past: A recent summary:
              Message 6 of 11 , Aug 20, 2014
              • 0 Attachment
                This issue has been raised and rejected (stubbornly and misguidedly, IMO) multiple times in the past:

                A recent summary:


                On Wed, Aug 20, 2014 at 3:42 PM, Andrew Pennebaker <andrew.pennebaker@...> wrote:
                Could we please setup a basic Apache redirection, so that users trying to get to vim.org will be successfully redirected to www.vim.org?

                This procedure is commonly used by many websites, and it helps a lot of users get to the home page more easily--they shouldn't have to see 404 for the domain!

                An example Apache configuration that would quickly accomplish this:


                On Wed, Aug 20, 2014 at 5:54 AM, John Beckett <johnb.beckett@...> wrote:
                Andrew Pennebaker wrote:
                > When I enter "vim.org" into the address bar in Firefox, it
                > successfully redirects to "www.vim.org". But when I enter
                > "vim.org" in Chrome, no redirect happens.

                That has been discussed a couple of times in the past. The
                person who provides the DNS for Vim does so in an extremely
                reliable and efficient manner, so what they say goes. The issue
                is that vim.org is a domain and should not be expected to work
                in a browser. A browser has to connect to a host (www.vim.org).

                Some browsers try adding "www." when plain "vim.org" does not
                resolve to a host name, so vim.org works in some browsers.

                John


                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
                To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/1FuUXdqIiGM/unsubscribe.
                To unsubscribe from this group and all its topics, send an email to vim_use+unsubscribe@....

                For more options, visit https://groups.google.com/d/optout.



                --
                Cheers,

                Andrew Pennebaker

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Andrew Pennebaker
                If we can t control htaccess settings, we can still add an index.html file that redirects to www.vim.org. Example: http://stackoverflow.com/a/5411567/350106
                Message 7 of 11 , Aug 20, 2014
                • 0 Attachment
                  If we can't control htaccess settings, we can still add an index.html file that redirects to www.vim.org.

                  Example:

                  http://stackoverflow.com/a/5411567/350106

                  Given that vim.org is hosted on SourceForge, we could even redirect to the SourceForge project page. That would still be better than 404'ing.


                  On Wed, Aug 20, 2014 at 2:47 PM, Павлов Николай Александрович <zyx.vim@...> wrote:
                  -----BEGIN PGP SIGNED MESSAGE-----
                  Hash: SHA512

                  On August 20, 2014 11:42:59 PM GMT+03:00, Andrew Pennebaker <andrew.pennebaker@...> wrote:
                  >Could we please setup a basic Apache redirection, so that users trying
                  >to
                  >get to vim.org will be successfully redirected to www.vim.org?
                  >
                  >This procedure is commonly used by many websites, and it helps a lot of
                  >users get to the home page more easily--they shouldn't have to see 404
                  >for
                  >the domain!
                  >
                  >An example Apache configuration that would quickly accomplish this:
                  >
                  >http://stackoverflow.com/questions/1157255/how-to-redirect-non-www-to-www-urls-using-htaccess/11990168#11990168
                  >
                  >
                  >On Wed, Aug 20, 2014 at 5:54 AM, John Beckett <johnb.beckett@...>
                  >wrote:
                  >
                  >> Andrew Pennebaker wrote:
                  >> > When I enter "vim.org" into the address bar in Firefox, it
                  >> > successfully redirects to "www.vim.org". But when I enter
                  >> > "vim.org" in Chrome, no redirect happens.
                  >>
                  >> That has been discussed a couple of times in the past. The
                  >> person who provides the DNS for Vim does so in an extremely
                  >> reliable and efficient manner, so what they say goes. The issue
                  >> is that vim.org is a domain and should not be expected to work
                  >> in a browser. A browser has to connect to a host (www.vim.org).
                  >>
                  >> Some browsers try adding "www." when plain "vim.org" does not
                  >> resolve to a host name, so vim.org works in some browsers.
                  >>
                  >> John
                  >>
                  >>
                  >> --
                  >> --
                  >> You received this message from the "vim_use" maillist.
                  >> Do not top-post! Type your reply below the text you are replying to.
                  >> For more information, visit http://www.vim.org/maillist.php
                  >>
                  >> ---
                  >> You received this message because you are subscribed to a topic in
                  >the
                  >> Google Groups "vim_use" group.
                  >> To unsubscribe from this topic, visit
                  >> https://groups.google.com/d/topic/vim_use/1FuUXdqIiGM/unsubscribe.
                  >> To unsubscribe from this group and all its topics, send an email to
                  >> vim_use+unsubscribe@....
                  >> For more options, visit https://groups.google.com/d/optout.
                  >>
                  >
                  >
                  >
                  >--
                  >Cheers,
                  >
                  >Andrew Pennebaker
                  >www.yellosoft.us
                  >
                  >--
                  >--
                  >You received this message from the "vim_use" maillist.
                  >Do not top-post! Type your reply below the text you are replying to.
                  >For more information, visit http://www.vim.org/maillist.php
                  >
                  >---
                  >You received this message because you are subscribed to the Google
                  >Groups "vim_use" group.
                  >To unsubscribe from this group and stop receiving emails from it, send
                  >an email to vim_use+unsubscribe@....
                  >For more options, visit https://groups.google.com/d/optout.

                  AFAIK vim.org is hosted on sourceforge and there is no access to web server settings.

                  This question was already raised before here or in vim-dev and relevant topic contained an explanation why with the current hosting it is not possible to do what you request. I did not save a link though.
                  -----BEGIN PGP SIGNATURE-----
                  Version: APG v1.1.1

                  iQI1BAEBCgAfBQJT9Ps1GBxaeVggPHp5eC52aW1AZ21haWwuY29tPgAKCRCf3UKj
                  HhHSvl/lD/9MxXT6JzvR+R+PmtY3aignQcX0UiNHmw4nSQC9QB3Lq5X3w+MF7rhh
                  jx+aPtzoXj4k1Fz2d0ODy/NnqEkmWbeCRqOcFGY6UTO2HZ2s5SjYFqXkDvf1NkWG
                  ySYJuC14fmwMSE52muaddIvJCX5UU+k5Al/FH7Ke4Jl3ADk58wI1Cf2Wb775fWp+
                  Ew0JT4gSUr9rlMLJG8m3GwltCoSmidbLhu5CuqK7s8U2jweE63wXjch/9lgP83n8
                  +TDYazJPXJLcsMVt4nfgkySWv1x5B+gLyEkz9DtQdrAIJHysZuPMzuckrGBBf9kE
                  GlGECVGwbF2Nv6TtGC+aomQiDbPiAvMnc5ggdGPScvvrkFAAAu79NNKjSdmN9v46
                  ZffzZduDe4zJ6ArVdRnqM7XCLGgdX93BeidW3MKww92W3DPGyacCx3D+lP4+6O7f
                  RZV9OFpeDQH1odn3WoPQnzYXV6tfzOZpRSeUr14KPgbHXYDS0ip4guiZVWY3Ol2p
                  FZSaYAUGBv6svp7jyjg1x8fjo5iOI3BApvQdhwog8w9DhIFj39/tkp77knYMlaJj
                  OgpA17CNsCwNyYMuYMoiFc2YAnz/4h8qqx5azkLx4GUQrUoBQbwbivhDuPldhc4R
                  Ew4D+so3R20gKMHuzdQigmkhygZIIKNzvV5vYU7WvIRVPfWwHVfyPA==
                  =FPWb
                  -----END PGP SIGNATURE-----




                  --
                  Cheers,

                  Andrew Pennebaker

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • Benjamin R. Haskell
                  On Wed, Aug 20, 2014 at 3:50 PM, Andrew Pennebaker ... Without a DNS A record pointing to *something*, there s no way to serve anything for `vim.org` without
                  Message 8 of 11 , Aug 20, 2014
                  • 0 Attachment
                    On Wed, Aug 20, 2014 at 3:50 PM, Andrew Pennebaker
                    <andrew.pennebaker@...> wrote:
                    >
                    > If we can't control htaccess settings, we can still add an index.html file that redirects to www.vim.org.
                    >
                    > Example:
                    >
                    > http://stackoverflow.com/a/5411567/350106

                    Without a DNS A record pointing to *something*, there's no way to
                    serve anything for `vim.org` without client-side modifications.


                    > Given that vim.org is hosted on SourceForge, we could even redirect to the SourceForge project page. That would still be better than 404'ing.

                    I haven't checked, but presumably SourceForge's hosting has the same
                    issue as Heroku at this point with hosting apex domains (i.e. there's
                    probably not a stable IP or set of IPs to point to¹, and you can't
                    CNAME an apex domain²).

                    I forgot that I did this last time the issue came up (three years ago,
                    uggh), but I still have a redirector set up and ready to go. Point
                    `vim.org` to 64.130.10.15 and it'll work. There's nothing to say an
                    apex domain has to be hosted at the same server as `www`.

                    e.g.

                    ```
                    $ curl --resolve vim.org:80:64.130.10.15 -i
                    'http://vim.org/whatever?with-params'
                    HTTP/1.1 301 Moved Permanently
                    Date: Wed, 20 Aug 2014 20:08:37 GMT
                    Server: Apache/2.2.27
                    Location: http://www.vim.org/whatever?with-params
                    Content-Length: 247
                    Content-Type: text/html; charset=iso-8859-1

                    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
                    <html><head>
                    <title>301 Moved Permanently</title>
                    </head><body>
                    <h1>Moved Permanently</h1>
                    <p>The document has moved <a
                    href="http://www.vim.org/whatever?with-params">here</a>.</p>
                    </body></html>
                    ```

                    --
                    Best,
                    Ben

                    ¹: https://devcenter.heroku.com/articles/apex-domains - can't use A
                    records for apex domains on Heroku
                    ²: http://blog.dnsimple.com/2011/11/introducing-alias-record/ - why
                    ALIAS/ANAME records were created
                    https://support.cloudflare.com/hc/en-us/articles/200169056-Does-CloudFlare-support-CNAME-APEX-at-the-root-
                    - CloudFlare handles apex CNAMEs (in opposition to RFCs)

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • Andrew Pennebaker
                    ... Good solution! By the way, from my machine that IP seems to be acting like a pairLite ISP parking site. Maybe my DNS cache is old? -- Cheers, Andrew
                    Message 9 of 11 , Aug 20, 2014
                    • 0 Attachment

                      I still have a redirector set up and ready to go.  Point
                      `vim.org` to 64.130.10.15 and it'll work.  There's nothing to say an
                      apex domain has to be hosted at the same server as `www`.

                      Good solution!

                      By the way, from my machine that IP seems to be acting like a pairLite ISP parking site. Maybe my DNS cache is old?

                      --
                      Cheers,

                      Andrew Pennebaker

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    • Bart Schouten
                      Incidentally, if I may be allowed to chime in... My own host doesn t allow for a 301 moved but it does offer a 302 redirect and it works flawlessly. Here
                      Message 10 of 11 , Aug 20, 2014
                      • 0 Attachment
                        Incidentally, if I may be allowed to chime in...

                        My own host doesn't allow for a 301 "moved" but it does offer a 302 "redirect" and it works flawlessly.

                        Here is a good read on it though:

                        http://www.greenhills.co.uk/2011/06/12/www-or-bare-domain.html

                        Personally (at least for my own purposes) I feel the bare domain is a matter of convenience, but I prefer to use a full domain (as in, the www prefix) as the canonical url.

                        When I access my own website, I do not type the "www" I just start with the domain and that autocompletes. Ever since "autocompletion" so to speak I have not really been using any bookmarks for anything regular ;-).

                        Regards, and good luck with this (I think you should have this redirect, I agree with that) and I hope it can work out.



                        Andrew Pennebaker schreef op 20-8-2014 om 22:32:

                        I still have a redirector set up and ready to go.  Point
                        `vim.org` to 64.130.10.15 and it'll work.  There's nothing to say an
                        apex domain has to be hosted at the same server as `www`.

                        Good solution!

                        By the way, from my machine that IP seems to be acting like a pairLite ISP parking site. Maybe my DNS cache is old?

                        --
                        Cheers,

                        Andrew Pennebaker
                        --
                        --

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/d/optout.
                      • Benjamin R. Haskell
                        On Wed, Aug 20, 2014 at 4:32 PM, Andrew Pennebaker ... If you access it by IP, yes, that s what it should serve. It s name-based virtual hosting, as
                        Message 11 of 11 , Aug 20, 2014
                        • 0 Attachment
                          On Wed, Aug 20, 2014 at 4:32 PM, Andrew Pennebaker
                          <andrew.pennebaker@...> wrote:
                          >
                          >> I still have a redirector set up and ready to go. Point
                          >> `vim.org` to 64.130.10.15 and it'll work. There's nothing to say an
                          >> apex domain has to be hosted at the same server as `www`.
                          >
                          >
                          > Good solution!
                          >
                          > By the way, from my machine that IP seems to be acting like a pairLite ISP
                          > parking site. Maybe my DNS cache is old?

                          If you access it by IP, yes, that's what it should serve. It's
                          name-based virtual hosting, as (virtually?) everything is these days,
                          so the default page is the hosting provider's site.

                          As another example, accessing
                          http://raptorize-rails-demo.herokuapp.com/ (a Heroku app of mine)
                          works fine, but navigating directly to the IP to which it resolves
                          (from here: http://23.21.169.234/ ) returns a "No such app" page.

                          --
                          Best,
                          Ben

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/d/optout.
                        Your message has been successfully submitted and would be delivered to recipients shortly.