Loading ...
Sorry, an error occurred while loading the content.
 

vim -N not working with vim-tiny

Expand Messages
  • Ludovic Tolhurst-Cleaver
    Hi there everyone, I was running *vim-tiny* on a colleague s server, realised that there was no help installed, and so installed *vim-runtime* as the fake
    Message 1 of 6 , Aug 19, 2014
      Hi there everyone,

      I was running vim-tiny on a colleague's server, realised that there was no help installed, and so installed vim-runtime as the 'fake help page' recommended. (He gave me root access and won't mind).

      vim -N doesn't seem to work with vim-tiny, and still doesn't with vim-runtime installed alongside it. (Help is now working though - good).

      Is vim-tiny too small to offer much beyond vi compatibility? If so, would it not be appropriate to mention this in the documentation?

      Basically, is vim -N not supposed to work with vim-tiny?

      BTW: I have now uninstalled vim-tiny, and installed the 'vim' package (using APT - it's a Debian server). Vim now seems to be working in nocompatible mode by default. Which I also don't understand, as there is no .vimrc file in /root that I can see...

      Thanks...

      LTC

      --

      Ludovic Tolhurst-Cleaver
      IT Software Programmer
      CallCare
      CallCare Ltd.
      Units 1 & 2 | Buffalo Court | Kansas Avenue | Salford Quays | M50 2QL
      0845 056 1000
      website | map | email
      Google+ Twitter LinkedIn Facebook

      CallCare Ltd. Registered as a company in England and Wales no. 3497122. Registered office: 186 Sloane Street, Knightsbridge, London, SW1X 9QR.

      This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please notify us immediately by returning it to the sender and delete this copy from your system. Thank you for your cooperation.






      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Stefan Klein
      Hi, I can t comment on the first part ... 2014-08-19 13:34 GMT+02:00 Ludovic Tolhurst-Cleaver
      Message 2 of 6 , Aug 19, 2014
        Hi,

        I can't comment on the first part ...


        2014-08-19 13:34 GMT+02:00 Ludovic Tolhurst-Cleaver <ludovic.tolhurst-cleaver@...>:

        BTW: I have now uninstalled vim-tiny, and installed the 'vim' package (using APT - it's a Debian server). Vim now seems to be working in nocompatible mode by default. Which I also don't understand, as there is no .vimrc file in /root that I can see...


        ... but for that part:

        $ grep noco /etc/vim/vimrc
        " NOTE: debian.vim sets 'nocompatible'.  Setting 'compatible' changes numerous
        $ dpkg -L vim-common | grep debian.vim
        /usr/share/vim/vim74/debian.vim
        $ grep noco /usr/share/vim/vim74/debian.vim
        set nocompatible    " Use Vim defaults instead of 100% vi compatibility
        " vulnerabilities -- disable by default, even when 'nocompatible' is set

        So it is set by the debian default configuration.

        regards,
        Stefan

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Ludovic Tolhurst-Cleaver
        Oh thanks Stefan, that s great to know. At least that solves one problem for me! Danke sehr! L. ... -- -- You received this message from the vim_use
        Message 3 of 6 , Aug 19, 2014
          Oh thanks Stefan, that's great to know. At least that solves one problem for me!

          Danke sehr!

          L.


          On 19/08/14 14:23, Stefan Klein wrote:
          Hi,

          I can't comment on the first part ...


          2014-08-19 13:34 GMT+02:00 Ludovic Tolhurst-Cleaver <ludovic.tolhurst-cleaver@...>:

          BTW: I have now uninstalled vim-tiny, and installed the 'vim' package (using APT - it's a Debian server). Vim now seems to be working in nocompatible mode by default. Which I also don't understand, as there is no .vimrc file in /root that I can see...


          ... but for that part:

          $ grep noco /etc/vim/vimrc
          " NOTE: debian.vim sets 'nocompatible'.  Setting 'compatible' changes numerous
          $ dpkg -L vim-common | grep debian.vim
          /usr/share/vim/vim74/debian.vim
          $ grep noco /usr/share/vim/vim74/debian.vim
          set nocompatible    " Use Vim defaults instead of 100% vi compatibility
          " vulnerabilities -- disable by default, even when 'nocompatible' is set

          So it is set by the debian default configuration.

          regards,
          Stefan
          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Tony Mechelynck
          ... I cannot reproduce this on Vim 7.4.410, tiny build without GUI, compiled on Linux from Bram s sources and installed as vi to avoid clash with vim which
          Message 4 of 6 , Aug 19, 2014
            On 19/08/14 13:34, Ludovic Tolhurst-Cleaver wrote:
            > Hi there everyone,
            >
            > I was running *vim-tiny* on a colleague's server, realised that there
            > was no help installed, and so installed *vim-runtime* as the 'fake help
            > page' recommended. (He gave me root access and won't mind).
            >
            > vim -N doesn't seem to work with vim-tiny, and still doesn't with
            > vim-runtime installed alongside it. (Help is now working though - good).

            I cannot reproduce this on Vim 7.4.410, tiny build without GUI, compiled
            on Linux from Bram's sources and installed as "vi" to avoid clash with
            "vim" which is the Huge build: Either "vi -N" (with my usual vimrc) or
            "vi -u NONE -N" (with no vimrc and no plugins) followed by ":set cp?"
            give "nocompatible" as the answer.

            Caveat: When asking the value of a Boolean option, the question mark is
            necessary; without it you're setting it to TRUE instead.

            >
            > Is vim-tiny too small to offer much beyond vi compatibility? If so,
            > would it not be appropriate to mention this in the documentation?
            >
            > Basically, is vim -N not supposed to work with vim-tiny?

            It ought to; but Debian is known for making unsupported changes to the
            packages they distribute. As the saying (usually applied to paper book
            publishers) goes, “they like it better after they piss on it”. Try
            compiling yourself, it isn't hard. See:
            http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
            http://users.skynet.be/antoine.mechelynck/vim/compunix.htm
            The last phase, "make install", of the above, also installs the full
            runtime files, including the help and all kinds of plugins, plus various
            other stuff; usually as a tree starting at /usr/local/share/vim/vim74
            for release 7.4.

            Normally you would compile and install only a Huge GUI-enabled build: on
            Linux that can serve also in a console. But it's quite possible to
            compile two or more versions with different featuresets and install them
            side-by-side if their objdir (for compiling) and names (after
            installing) don't clash. I compile a Huge build with GTK2/GNOME2 GUI and
            a Tiny build without GUI using shadow directories (see the target
            "shadow" in the Makefile) and I install them as /usr/local/bin/vim (with
            symlinks from most other names) and /usr/local/bin/vi respectively. I
            don't even need to uninstall the Vim from my distro (openSUSE) which is
            at /bin/vim (without GUI) and at /usr/bin/gvim (with GTK2 GUI) i.e.
            after my own in the $PATH but still available if I use a full path or a
            specially crafted symlink; but only at patchlevel 7.4.52 so far.

            >
            > BTW: I have now uninstalled vim-tiny, and installed the 'vim' package
            > (using APT - it's a Debian server). Vim now seems to be working in
            > nocompatible mode by default. Which I also don't understand, as there is
            > no .vimrc file in /root that I can see...

            Check for a system vimrc. It usualy has no leading dot and its location
            is shown near the middle of the output of the :version command.

            >
            > Thanks...
            >
            > LTC
            >
            > --
            >
            > Ludovic Tolhurst-Cleaver [...]

            Best regards,
            Tony.
            --
            Q: What do you have when you have a lawyer buried up to his neck in sand?
            A: Not enough sand.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Ludovic Tolhurst-Cleaver
            Thanks Tony... I ll build it myself at some point and check that out. Odd thing to take out but stranger things have happened. ... -- -- You received this
            Message 5 of 6 , Aug 19, 2014
              Thanks Tony... I'll build it myself at some point and check that out.
              Odd thing to take out but stranger things have happened.

              On 19/08/14 15:24, Tony Mechelynck wrote:
              > On 19/08/14 13:34, Ludovic Tolhurst-Cleaver wrote:
              >> Hi there everyone,
              >>
              >> I was running *vim-tiny* on a colleague's server, realised that there
              >> was no help installed, and so installed *vim-runtime* as the 'fake help
              >> page' recommended. (He gave me root access and won't mind).
              >>
              >> vim -N doesn't seem to work with vim-tiny, and still doesn't with
              >> vim-runtime installed alongside it. (Help is now working though - good).
              >
              > I cannot reproduce this on Vim 7.4.410, tiny build without GUI,
              > compiled on Linux from Bram's sources and installed as "vi" to avoid
              > clash with "vim" which is the Huge build: Either "vi -N" (with my
              > usual vimrc) or "vi -u NONE -N" (with no vimrc and no plugins)
              > followed by ":set cp?" give "nocompatible" as the answer.
              >
              > Caveat: When asking the value of a Boolean option, the question mark
              > is necessary; without it you're setting it to TRUE instead.
              >
              >>
              >> Is vim-tiny too small to offer much beyond vi compatibility? If so,
              >> would it not be appropriate to mention this in the documentation?
              >>
              >> Basically, is vim -N not supposed to work with vim-tiny?
              >
              > It ought to; but Debian is known for making unsupported changes to the
              > packages they distribute. As the saying (usually applied to paper book
              > publishers) goes, “they like it better after they piss on it”. Try
              > compiling yourself, it isn't hard. See:
              > http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
              > http://users.skynet.be/antoine.mechelynck/vim/compunix.htm
              > The last phase, "make install", of the above, also installs the full
              > runtime files, including the help and all kinds of plugins, plus
              > various other stuff; usually as a tree starting at
              > /usr/local/share/vim/vim74 for release 7.4.
              >
              > Normally you would compile and install only a Huge GUI-enabled build:
              > on Linux that can serve also in a console. But it's quite possible to
              > compile two or more versions with different featuresets and install
              > them side-by-side if their objdir (for compiling) and names (after
              > installing) don't clash. I compile a Huge build with GTK2/GNOME2 GUI
              > and a Tiny build without GUI using shadow directories (see the target
              > "shadow" in the Makefile) and I install them as /usr/local/bin/vim
              > (with symlinks from most other names) and /usr/local/bin/vi
              > respectively. I don't even need to uninstall the Vim from my distro
              > (openSUSE) which is at /bin/vim (without GUI) and at /usr/bin/gvim
              > (with GTK2 GUI) i.e. after my own in the $PATH but still available if
              > I use a full path or a specially crafted symlink; but only at
              > patchlevel 7.4.52 so far.
              >
              >>
              >> BTW: I have now uninstalled vim-tiny, and installed the 'vim' package
              >> (using APT - it's a Debian server). Vim now seems to be working in
              >> nocompatible mode by default. Which I also don't understand, as there is
              >> no .vimrc file in /root that I can see...
              >
              > Check for a system vimrc. It usualy has no leading dot and its
              > location is shown near the middle of the output of the :version command.
              >
              >>
              >> Thanks...
              >>
              >> LTC
              >>
              >> --
              >>
              >> Ludovic Tolhurst-Cleaver [...]
              >
              > Best regards,
              > Tony.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • John Little
              ... If you want to do that, remember the magic incantation: sudo apt-get build-dep vim-gtk Installs all the development libraries and whatever to build gvim.
              Message 6 of 6 , Aug 19, 2014
                On Wednesday, August 20, 2014 3:47:09 AM UTC+12, Ludovic Tolhurst-Cleaver wrote:
                > Thanks Tony... I'll build it myself at some point and check that out.

                If you want to do that, remember the magic incantation:

                sudo apt-get build-dep vim-gtk

                Installs all the development libraries and whatever to build gvim. APT rocks.

                Regards, John Little

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.