Loading ...
Sorry, an error occurred while loading the content.

Word completion seems to have problem

Expand Messages
  • tom arnall
    Word completion seems to have problem: In this line: wordTom,wordDick, wordD When I try to complete wordD with or I get: Keyword completion:
    Message 1 of 9 , Jul 28, 2014
    • 0 Attachment
      Word completion seems to have problem:

      In this line:

      wordTom,wordDick, wordD

      When I try to complete 'wordD' with <c-p> or <c-n> I get:

      "Keyword completion: pattern not found"

      But, when I put instead this in the file (i.e., move 'wordD' to the next line):

      wordTom,wordDick

      wordD

      'wordD' completes successfully.

      ':set complete' gets:

      complete=i

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • John Little
      ... I see this with 7.4.383, invoked as vim -u NONE -N -c set cpt=i Strange. I wonder why complete=i is supposed to scan current when the . flag is for
      Message 2 of 9 , Jul 28, 2014
      • 0 Attachment
        On Tuesday, July 29, 2014 10:32:31 AM UTC+12, tom arnall wrote:
        > Word completion seems to have problem:
        >
        > wordTom,wordDick, wordD
        >
        > When I try to complete 'wordD' with <c-p> ... (fails)
        >
        I see this with 7.4.383, invoked as vim -u NONE -N -c "set cpt=i"

        Strange. I wonder why complete=i is supposed to "scan current" when the "." flag is for the current buffer. As a workaround, you could

        :set complete=.,i

        Note that complete=i,. hits the problem too.

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • tom arnall
        John, works! thanks. how did you learn this? i want to become more knowledgeable of such details but often i can t find an answer in the vim documentation. Tom
        Message 3 of 9 , Jul 29, 2014
        • 0 Attachment
          John,

          works! thanks. how did you learn this? i want to become more
          knowledgeable of such details but often i can't find an answer in the
          vim documentation.

          Tom


          ---------
          On the sea of life, the occasional loss of a boat is inevitable.




          On 7/28/14, John Little <John.B.Little@...> wrote:
          > On Tuesday, July 29, 2014 10:32:31 AM UTC+12, tom arnall wrote:
          >> Word completion seems to have problem:
          >>
          >> wordTom,wordDick, wordD
          >>
          >> When I try to complete 'wordD' with <c-p> ... (fails)
          >>
          > I see this with 7.4.383, invoked as vim -u NONE -N -c "set cpt=i"
          >
          > Strange. I wonder why complete=i is supposed to "scan current" when the "."
          > flag is for the current buffer. As a workaround, you could
          >
          > :set complete=.,i
          >
          > Note that complete=i,. hits the problem too.
          >
          > Regards, John Little
          >
          > --
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > ---
          > You received this message because you are subscribed to the Google Groups
          > "vim_use" group.
          > To unsubscribe from this group and stop receiving emails from it, send an
          > email to vim_use+unsubscribe@....
          > For more options, visit https://groups.google.com/d/optout.
          >

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Gevisz
          On Tue, 29 Jul 2014 21:27:01 -0700 ... The most complete documentation is usually the source code. :) ... -- -- You received this message from the vim_use
          Message 4 of 9 , Jul 29, 2014
          • 0 Attachment
            On Tue, 29 Jul 2014 21:27:01 -0700
            tom arnall <kloro2006@...> wrote:

            > John,
            >
            > works! thanks. how did you learn this? i want to become more
            > knowledgeable of such details but often i can't find an answer in the
            > vim documentation.

            The most complete documentation is usually the source code. :)

            > ---------
            > On the sea of life, the occasional loss of a boat is inevitable.
            >
            >
            >
            >
            > On 7/28/14, John Little <John.B.Little@...> wrote:
            > > On Tuesday, July 29, 2014 10:32:31 AM UTC+12, tom arnall wrote:
            > >> Word completion seems to have problem:
            > >>
            > >> wordTom,wordDick, wordD
            > >>
            > >> When I try to complete 'wordD' with <c-p> ... (fails)
            > >>
            > > I see this with 7.4.383, invoked as vim -u NONE -N -c "set cpt=i"
            > >
            > > Strange. I wonder why complete=i is supposed to "scan current"
            > > when the "." flag is for the current buffer. As a workaround, you
            > > could
            > >
            > > :set complete=.,i
            > >
            > > Note that complete=i,. hits the problem too.
            > >
            > > Regards, John Little
            > >
            > > --
            > > --
            > > You received this message from the "vim_use" maillist.
            > > Do not top-post! Type your reply below the text you are replying to.
            > > For more information, visit http://www.vim.org/maillist.php
            > >
            > > ---
            > > You received this message because you are subscribed to the Google
            > > Groups "vim_use" group.
            > > To unsubscribe from this group and stop receiving emails from it,
            > > send an email to vim_use+unsubscribe@....
            > > For more options, visit https://groups.google.com/d/optout.
            > >
            >

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • John Little
            ... Note that there s a trick there; if there s a conflict between an option name and someother topic (as with :help complete), prefixing the option name with
            Message 5 of 9 , Jul 29, 2014
            • 0 Attachment
              On Wednesday, July 30, 2014 4:27:11 PM UTC+12, tom arnall wrote:
              > how did you learn this? i want to become more

              I checked the vim help:

              :help 'complete

              Note that there's a trick there; if there's a conflict between an option name and someother topic (as with :help complete), prefixing the option name with a single quote will get the option help.

              Regards, John Little

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Christian Brabandt
              ... Tricky. I think what happens is this: complete=i talks about included files. Included files are found for what is specified with the include option. I
              Message 6 of 9 , Jul 30, 2014
              • 0 Attachment
                On Mo, 28 Jul 2014, tom arnall wrote:

                > Word completion seems to have problem:
                >
                > In this line:
                >
                > wordTom,wordDick, wordD
                >
                > When I try to complete 'wordD' with <c-p> or <c-n> I get:
                >
                > "Keyword completion: pattern not found"
                >
                > But, when I put instead this in the file (i.e., move 'wordD' to the next line):
                >
                > wordTom,wordDick
                >
                > wordD
                >
                > 'wordD' completes successfully.
                >
                > ':set complete' gets:
                >
                > complete=i

                Tricky. I think what happens is this:
                complete=i talks about included files. Included files are found for what
                is specified with the 'include' option. I don't see any included files
                here, so I wouldn't expect a match here. Use 'complete=.' if you want to
                scan the current buffer (or even better, leave it at the default value).

                Best,
                Christian
                --
                Die Menschen achten den, der sie verachtet.
                -- Honoré de Balzac

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • tom arnall
                John, thanks. how did you learn the trick? T ... Everybody is a genius, but if you try to teach a monkey to swim like a fish, all you get is a pissed off
                Message 7 of 9 , Jul 30, 2014
                • 0 Attachment
                  John,

                  thanks. how did you learn the ' trick?

                  T


                  -------------------
                  "Everybody is a genius, but if you try to teach a monkey to swim like
                  a fish, all you get is a pissed off monkey." Albert Einstein,
                  paraphrastically.



                  On 7/29/14, John Little <John.B.Little@...> wrote:
                  > On Wednesday, July 30, 2014 4:27:11 PM UTC+12, tom arnall wrote:
                  >> how did you learn this? i want to become more
                  >
                  > I checked the vim help:
                  >
                  > :help 'complete
                  >
                  > Note that there's a trick there; if there's a conflict between an option
                  > name and someother topic (as with :help complete), prefixing the option name
                  > with a single quote will get the option help.
                  >
                  > Regards, John Little
                  >
                  > --
                  > --
                  > You received this message from the "vim_use" maillist.
                  > Do not top-post! Type your reply below the text you are replying to.
                  > For more information, visit http://www.vim.org/maillist.php
                  >
                  > ---
                  > You received this message because you are subscribed to the Google Groups
                  > "vim_use" group.
                  > To unsubscribe from this group and stop receiving emails from it, send an
                  > email to vim_use+unsubscribe@....
                  > For more options, visit https://groups.google.com/d/optout.
                  >

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • Christian Brabandt
                  Hi tom! ... Open the help window and read the paragraph starting with Get specific help: Best, Christian -- Die Menschen wären alle bescheidener und
                  Message 8 of 9 , Jul 30, 2014
                  • 0 Attachment
                    Hi tom!

                    On Mi, 30 Jul 2014, tom arnall wrote:

                    > thanks. how did you learn the ' trick?

                    Open the help window and read the paragraph starting with
                    "Get specific help:"

                    Best,
                    Christian
                    --
                    Die Menschen wären alle bescheidener und demütiger, trieben sie alle
                    nur eine Kunst.
                    -- Jean Paul

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • tom arnall
                    you mean, when all else fails, read the instructions? ;o) ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply
                    Message 9 of 9 , Jul 30, 2014
                    • 0 Attachment
                      you mean, 'when all else fails, read the instructions?' ;o)

                      On 7/30/14, Christian Brabandt <cblists@...> wrote:
                      > Hi tom!
                      >
                      > On Mi, 30 Jul 2014, tom arnall wrote:
                      >
                      >> thanks. how did you learn the ' trick?
                      >
                      > Open the help window and read the paragraph starting with
                      > "Get specific help:"
                      >
                      > Best,
                      > Christian
                      > --
                      > Die Menschen wären alle bescheidener und demütiger, trieben sie alle
                      > nur eine Kunst.
                      > -- Jean Paul
                      >
                      > --
                      > --
                      > You received this message from the "vim_use" maillist.
                      > Do not top-post! Type your reply below the text you are replying to.
                      > For more information, visit http://www.vim.org/maillist.php
                      >
                      > ---
                      > You received this message because you are subscribed to the Google Groups
                      > "vim_use" group.
                      > To unsubscribe from this group and stop receiving emails from it, send an
                      > email to vim_use+unsubscribe@....
                      > For more options, visit https://groups.google.com/d/optout.
                      >

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    Your message has been successfully submitted and would be delivered to recipients shortly.